Bug 196417 - PLIST issue in x11-toolkits/pango and sysutils/polkit
Summary: PLIST issue in x11-toolkits/pango and sysutils/polkit
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
: 195567 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-01 06:50 UTC by Sunpoet Po-Chuan Hsieh
Modified: 2015-01-01 19:21 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sunpoet Po-Chuan Hsieh freebsd_committer 2015-01-01 06:50:26 UTC
Theses ports failed to build in poudriere due to the following PLIST issue:

====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: @dir %%ETCDIR%%
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/x11-toolkits/pango

====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/10-vendor.d
Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/20-org.d
Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/30-site.d
Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/50-local.d
Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/90-mandatory.d
Error: Orphaned: @dir %%DATADIR%%-1/rules.d
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/polkit


The patch is available at:
- https://people.freebsd.org/~sunpoet/gnome/pango.patch
- https://people.freebsd.org/~sunpoet/gnome/polkit.patch
Comment 1 Bugzilla Automation freebsd_committer 2015-01-01 06:50:26 UTC
Auto-assigned to maintainer gnome@FreeBSD.org
Comment 2 Olivier Duchateau freebsd_committer 2015-01-01 09:08:16 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #0)
> Theses ports failed to build in poudriere due to the following PLIST issue:
> 
> ====> Checking for pkg-plist issues (check-plist)
> ===> Parsing plist
> ===> Checking for items in STAGEDIR missing from pkg-plist
> Error: Orphaned: @dir %%ETCDIR%%
> ===> Checking for items in pkg-plist which are not in STAGEDIR
> ===> Error: Plist issues found.
> *** Error code 1
> 
> Stop.
> make: stopped in /usr/ports/x11-toolkits/pango
> 
> ====> Checking for pkg-plist issues (check-plist)
> ===> Parsing plist
> ===> Checking for items in STAGEDIR missing from pkg-plist
> Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/10-vendor.d
> Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/20-org.d
> Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/30-site.d
> Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/50-local.d
> Error: Orphaned: @dir %%ETCDIR%%-1/localauthority/90-mandatory.d
> Error: Orphaned: @dir %%DATADIR%%-1/rules.d
> ===> Checking for items in pkg-plist which are not in STAGEDIR
> ===> Error: Plist issues found.
> *** Error code 1
> 
> Stop.
> make: stopped in /usr/ports/sysutils/polkit
> 
> 
> The patch is available at:
> - https://people.freebsd.org/~sunpoet/gnome/pango.patch
> - https://people.freebsd.org/~sunpoet/gnome/polkit.patch

I think, it's better to replace %%ETCDIR%%-1 by etc/polkit-1.
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-01-01 16:28:06 UTC
(In reply to Olivier Duchateau from comment #2)
> (In reply to Sunpoet Po-Chuan Hsieh from comment #0)
> I think, it's better to replace %%ETCDIR%%-1 by etc/polkit-1.

You're right. It should be etc/polkit-1. Thanks.
Comment 4 commit-hook freebsd_committer 2015-01-01 16:36:23 UTC
A commit references this bug:

Author: kwm
Date: Thu Jan  1 16:35:25 UTC 2015
New revision: 376000
URL: https://svnweb.freebsd.org/changeset/ports/376000

Log:
  Remove mkdir line in post-install, this is a left over form the old pango
  cache location.

  PR:		196417
  Submitted by:	sunpoet@

Changes:
  head/x11-toolkits/pango/Makefile
Comment 5 commit-hook freebsd_committer 2015-01-01 16:56:26 UTC
A commit references this bug:

Author: kwm
Date: Thu Jan  1 16:56:00 UTC 2015
New revision: 376002
URL: https://svnweb.freebsd.org/changeset/ports/376002

Log:
  Add @dir lines for empty directories reported by check-plist.

  PR:		196417
  Submitted by:	sunpoet@

Changes:
  head/sysutils/polkit/Makefile
  head/sysutils/polkit/pkg-plist
Comment 6 Koop Mast freebsd_committer 2015-01-01 16:57:09 UTC
Problems resolved, thanks for reporting.
Comment 7 Kurt Jaeger freebsd_committer 2015-01-01 19:21:49 UTC
*** Bug 195567 has been marked as a duplicate of this bug. ***