Bug 196528 - [MAINTAINER] [PATCH] net-mgmt/nagios-check_dhcp.pl: patch to make it work with net/p5-IO-Interface 1.09
Summary: [MAINTAINER] [PATCH] net-mgmt/nagios-check_dhcp.pl: patch to make it work wit...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-perl mailing list
URL:
Keywords:
Depends on: 197404
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-06 03:03 UTC by Lawrence Chen
Modified: 2015-02-08 03:30 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (perl)


Attachments
patch file (1.24 KB, patch)
2015-01-06 03:03 UTC, Lawrence Chen
no flags Details | Diff
poudriere testport results on 9.3/amd64 (17.22 KB, text/plain)
2015-01-06 03:04 UTC, Lawrence Chen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lawrence Chen 2015-01-06 03:03:00 UTC
Created attachment 151378 [details]
patch file

Due to net/p5-IO-Interface getting updated to 1.09, the deprecated access method used by net-mgmt/nagios-check_dhcp.pl has stopped working.

Did a quick patch to switch to using preferred way to get things working again.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-06 03:03:00 UTC
Auto-assigned to maintainer perl@FreeBSD.org
Comment 2 Lawrence Chen 2015-01-06 03:04:44 UTC
Created attachment 151379 [details]
poudriere testport results on 9.3/amd64
Comment 3 Lawrence Chen 2015-01-07 02:07:37 UTC
Well, this is annoying....not sure if the patch has any validity now.  Since I discovered that I had forgotten to update p5-IO-Interface in my test environment (still working out the issues from upgrading to 9.3...have other production servers still on 9.1 or 9.2 to work on.) 

Found it didn't work on my production servers, and now after upgrading my test jail...it is still broken with or without this patch.

Makes for an issue in net/p5-IO-Interface ?
Comment 4 Lawrence Chen 2015-01-07 03:51:50 UTC
Ok, the problem does lie in p5-IO-Interface 1.09.  This is upstreams first conversion to use Module::Build.

Previously, in Makefile.PL there was configure code to check for what options to define in compiling Interface.xs...

None of that exists in the current Build.pl method.

So, without -DUSE_GETIFADDRS and -DHAVE_SOCKADDR_DL_STRUCT it doesn't use the getifaddrs(3) interface and attempts to use ioctl method that results in the "Illegal Seek" error.
Comment 5 Kurt Jaeger freebsd_committer 2015-02-08 03:30:03 UTC
Closing this bug as the root cause is fixed in PR 197404.