Bug 196591 - multimedia/libx264: fails to build on armv6 with clang3.5.0
Summary: multimedia/libx264: fails to build on armv6 with clang3.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-07 13:49 UTC by mikael.urankar
Modified: 2015-01-12 21:07 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments
import upstream patches for clang350 (36.38 KB, patch)
2015-01-07 13:49 UTC, mikael.urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mikael.urankar 2015-01-07 13:49:23 UTC
Created attachment 151457 [details]
import upstream patches for clang350

Hi,

Clang enabled the integrated assembler by default and it breaks the libx264 build:
/nxb-bin/usr/bin/cc -O -pipe  -fno-strict-aliasing -mcpu=arm1136jf-s -Wall -I. -I. -I/usr/local/include -std=gnu99 -c -DSTACK_ALIGNMENT=16 -DPIC -DHIGH_BIT_DEPTH=0 -DBIT_DEPTH=8 -o common/arm/cpu-a.o common/arm/cpu-a.S
<instantiation>:6:9: error: unknown directive
        .func x264_cpu_neon_test
        ^
common/arm/cpu-a.S:33:1: note: while in macro instantiation
function x264_cpu_neon_test

The problem is fixed upstream:
http://git.videolan.org/?p=x264.git;a=patch;h=d72760401cb0602b8bf86037988e66cdc810681c
http://git.videolan.org/?p=x264.git;a=patch;h=feec4a478bfdfb4426268b2ee79bac473b97488c

To apply the patch:
cd /usr/ports/multimedia/libx264 ; patch < /path/to/patch
find /usr/ports/multimedia/libx264/files -name "*.orig" -delete

failure log:
http://chips.ysv.freebsd.org/data/11armv6-11armv6/2015-01-07_01h29m17s/logs/errors/libx264-0.142.2455_1.log

with patch log:
http://mikael.urankar.free.fr/FreeBSD/arm/build_logs/libx264-0.142.2455_1.log
Comment 1 Bugzilla Automation freebsd_committer 2015-01-07 13:49:23 UTC
Auto-assigned to maintainer koobs@FreeBSD.org
Comment 2 Sean Bruno freebsd_committer 2015-01-07 16:34:18 UTC
I'll take this as koobs is on vacation.
Comment 3 mikael.urankar 2015-01-12 21:07:06 UTC
fixed in 376488: https://svnweb.freebsd.org/changeset/ports/376488