Bug 196632 - [exp-run] Ruby 2.1 as default ruby
Summary: [exp-run] Ruby 2.1 as default ruby
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-12 18:15 UTC by Steve Wills
Modified: 2015-03-01 04:14 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2015-01-12 18:15:52 UTC
Ruby 1.9 is old and will be expiring soon, see:

https://www.ruby-lang.org/en/news/2014/01/10/ruby-1-9-3-will-end-on-2015/

And ruby-lang.org recommends 2.1 so it's time to look at making 2.1 our default
too. See attached patch, need exp-run for this.
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2015-01-12 18:48:54 UTC
Hi,

Due to an issue with the backend FreeBSD Bugzilla database, your original PR and any updates to it since have been lost.  I've recreated the original PR as best as I can, however any attachments and updates you submitted to the PR have been lost.  Please could you resubmit them?

Thanks, and apologies.
Comment 2 Antoine Brodin freebsd_committer 2015-01-12 19:12:19 UTC
Exp-run results:

http://package22.nyi.freebsd.org/build.html?mastername=101amd64-default-PR196632&build=2015-01-11_21h53m30s

Looks good,  0 new failure
Comment 3 commit-hook freebsd_committer 2015-03-01 03:05:24 UTC
A commit references this bug:

Author: swills
Date: Sun Mar  1 03:04:41 UTC 2015
New revision: 380171
URL: https://svnweb.freebsd.org/changeset/ports/380171

Log:
  - Switch default version of Ruby to 2.0

  PR:		196632

Changes:
  head/Mk/bsd.default-versions.mk
  head/UPDATING