Bug 196681 (pinentry-qt4) - security/pinentry-qt4 does not compile with libc++
Summary: security/pinentry-qt4 does not compile with libc++
Status: Closed FIXED
Alias: pinentry-qt4
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-13 14:06 UTC by Gerard Seibert
Modified: 2015-01-22 08:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Seibert 2015-01-13 14:06:39 UTC
FreeBSD scorpio.seibercom.net 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

The "www/pinentry-qt4" port fails to build due to an apparent problem with "libc++".

This is the build output:

make
===>  pinentry-qt4-0.9.0_1 does not compile with libc++.
*** Error code 1

Stop.
make: stopped in /usr/ports/security/pinentry-qt4
Comment 1 Bugzilla Automation freebsd_committer 2015-01-13 14:06:39 UTC
Auto-assigned to maintainer makc@FreeBSD.org
Comment 2 Max Brazhnikov freebsd_committer 2015-01-19 19:30:14 UTC
Known problem. The message comes from the port itself:
> grep IGNORE /usr/ports/security/pinentry/Makefile
IGNORE=         does not compile with libc++

To see the actual error, comment this line and try to build the port. Patches are always welcome!
Comment 3 Gerard Seibert 2015-01-19 21:42:29 UTC
(In reply to Max Brazhnikov from comment #2)

I understand that; my question would be why even have the option to begin with if you know it doesn't work? That makes absolutely no sense and is counter productive. Can I supply a patch that removes that option entirely?
Comment 4 commit-hook freebsd_committer 2015-01-21 10:39:15 UTC
A commit references this bug:

Author: makc
Date: Wed Jan 21 10:38:39 UTC 2015
New revision: 377584
URL: https://svnweb.freebsd.org/changeset/ports/377584

Log:
  security/pinentry:
  - Make it apparent that Qt 4 frontend is broken on 10.x and greater

  PR:		196681
  Submitted by:	Gerard Seibert

Changes:
  head/security/pinentry/Makefile
Comment 5 Max Brazhnikov freebsd_committer 2015-01-21 10:58:44 UTC
(In reply to Gerard Seibert from comment #3)
Because it works on 8.x and 9.x. I've altered Qt 4 option description, hopefully, this will lessen the confusion.
Comment 6 Gerard Seibert 2015-01-21 12:24:47 UTC
(In reply to commit-hook from comment #4)
Thank you. After reading your later comment(5), I was not aware that it worked on earlier releases of FreeBSD. Is it possible that this might be fixed in later versions as well or is it not feasible?
Comment 7 Max Brazhnikov freebsd_committer 2015-01-22 08:43:12 UTC
(In reply to Gerard Seibert from comment #6)
Somebody interested should step in. Porting to Qt 5 would be nice to have also.