Bug 196711 - update www/squid to 3.4.11
Summary: update www/squid to 3.4.11
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-14 09:09 UTC by timp87
Modified: 2015-01-17 12:51 UTC (History)
2 users (show)

See Also:


Attachments
patch (855 bytes, patch)
2015-01-14 09:09 UTC, timp87
no flags Details | Diff
poudriere log (337.98 KB, text/plain)
2015-01-14 09:09 UTC, timp87
no flags Details
Updated patch (4.97 KB, patch)
2015-01-16 12:55 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description timp87 2015-01-14 09:09:03 UTC
Created attachment 151611 [details]
patch

Hi!

This release doesn't solve the problem with NTLM (why we still need www/squid33), but there is some progress in that question. At least a working patch was introduced and I hope it will be included in next release.
Comment 1 timp87 2015-01-14 09:09:17 UTC
Created attachment 151612 [details]
poudriere log
Comment 2 timp87 2015-01-15 12:54:10 UTC
(In reply to timp87 from comment #0)
I meant this https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195556
Comment 3 ncrogers 2015-01-15 16:50:41 UTC
+1 getting squid port updated. Patch works for me as well. Just an FYI as I was about to submit the same patch. Thanks!
Comment 4 Guido Falsi freebsd_committer 2015-01-16 12:55:13 UTC
Created attachment 151733 [details]
Updated patch

Hi,

I've tested your patch and found a few glithces in the port (not caused by your patch).

- files/extra-patch-gen-stacktrace for some reason contained the patch two times, failing to apply cleanly.

- the STACKTRACE option depends on libunwind one of whose include files causes a failure if -Werror is used, so I disable -Werror when building with that option.

- I added a patch files/patch-compat_compat.h because of an obscure error about that file. I've just removed the offending code since it's something for solaris and not relevant for us.

- A friend of mine reported tha on upgrade/reinstallation the squid port is resetting wrong permissions on the log and cache directories, so I fixed the plist to put reasonable permissions on the created directories.

Please test the port with these fixes, especially the last one and report back if it all looks ok.

Thanks!
Comment 5 timp87 2015-01-17 07:46:05 UTC
(In reply to Guido Falsi from comment #4)
Works good!
Comment 6 Guido Falsi freebsd_committer 2015-01-17 12:51:06 UTC
Committed. Thanks!
Comment 7 commit-hook freebsd_committer 2015-01-17 12:51:54 UTC
A commit references this bug:

Author: madpilot
Date: Sat Jan 17 12:50:58 UTC 2015
New revision: 377223
URL: https://svnweb.freebsd.org/changeset/ports/377223

Log:
  - Update to 3.4.11
  - Fix STACKTRACES option
  - Put correct permissions on /var directories creted by the port

  PR:		196711
  Submitted by:	timp87 at gmail.com

Changes:
  head/www/squid/Makefile
  head/www/squid/distinfo
  head/www/squid/files/extra-patch-gen-stacktrace
  head/www/squid/files/patch-compat_compat.h
  head/www/squid/pkg-plist