Bug 196721 - [MAINTAINER] games/wesnoth: Update to 1.12.0, Take MAINTAINER'ship
Summary: [MAINTAINER] games/wesnoth: Update to 1.12.0, Take MAINTAINER'ship
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Marino
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-01-14 12:17 UTC by Torsten Zühlsdorff
Modified: 2015-02-06 13:45 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
Patch against games/wesnoth (65.01 KB, patch)
2015-01-14 12:17 UTC, Torsten Zühlsdorff
no flags Details | Diff
Patch against games/wesnoth - Version 2 (fixed plist issues) (63.70 KB, patch)
2015-01-21 16:36 UTC, Torsten Zühlsdorff
no flags Details | Diff
gzip'ed log of "poudriere bulk -t games/wesnoth" build (151.37 KB, application/octet-stream)
2015-01-21 16:53 UTC, Torsten Zühlsdorff
no flags Details
Patch against games/wesnoth - Version 3 (remove @dirrmtry) (70.07 KB, patch)
2015-01-21 16:55 UTC, Torsten Zühlsdorff
no flags Details | Diff
Patch against games/wesnoth - Version 4 (correct @dir usage) (68.95 KB, patch)
2015-01-22 11:07 UTC, Torsten Zühlsdorff
no flags Details | Diff
Patch against games/wesnoth - Version 4 (the correct one) (68.93 KB, patch)
2015-01-22 11:32 UTC, Torsten Zühlsdorff
no flags Details | Diff
Patch against games/wesnoth - Version 5 (all @dir removed) (67.16 KB, patch)
2015-01-22 14:32 UTC, Torsten Zühlsdorff
no flags Details | Diff
Patch against games/wesnoth - Version 6 (removed desktop-file-utils warning) (67.19 KB, patch)
2015-01-26 11:50 UTC, Torsten Zühlsdorff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Zühlsdorff 2015-01-14 12:17:00 UTC
Created attachment 151619 [details]
Patch against games/wesnoth

The recent version in ports is more than 1,5 years old. I've wrote a patch to update to the most recent version. This is the biggest port i ever worked on, so i had only touch most thinks to get it work.

I also contacted the maintainer, which said, that he do not have time for the port and dropped maintainership in December last year. Therefore i will take the maintainership.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-14 12:17:00 UTC
Maintainer CC'd
Comment 2 rnejdl 2015-01-14 13:44:14 UTC
Approved to take over maintainership.
Comment 3 John Marino freebsd_committer 2015-01-20 19:01:13 UTC
This is all fine (and thanks for picking up the port), but given the size and complexity of the port, you really need to run this through poudriere testing (bulk -t option for stage-qa testing) and upload the log.  (former maintainer was requested for this as well)

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/testing-poudriere.html
Comment 4 Torsten Zühlsdorff 2015-01-21 16:36:46 UTC
Created attachment 151975 [details]
Patch against games/wesnoth - Version 2 (fixed plist issues)

Fixes plist issues
Comment 5 Torsten Zühlsdorff 2015-01-21 16:38:11 UTC
You're right, there were a handful of plist entries wrong. I attached a new patch for this. This log is currently generated and will be added in some Minutes :)
Comment 6 Torsten Zühlsdorff 2015-01-21 16:53:36 UTC
Created attachment 151979 [details]
gzip'ed log of "poudriere bulk -t games/wesnoth" build
Comment 7 Torsten Zühlsdorff 2015-01-21 16:55:59 UTC
Created attachment 151980 [details]
Patch against games/wesnoth - Version 3 (remove @dirrmtry)

As the attached log of poudriere advices, i replaced the @dirrmtry with @dir.
Comment 8 John Marino freebsd_committer 2015-01-21 17:06:12 UTC
Unfortunately, replacing @dirrmtry with @dir is wrong (@dir is not a new name for @dirrm* it has a specific use)

Please review https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/plist-keywords.html section 7.6.7.9:
Declare directory name. By default, directories created under PREFIX by a package installation are automatically removed. Use this when an empty directory under PREFIX needs to be created, or when the directory needs to have non default owner, group, or mode. Directories outside of PREFIX need to be registered. For example, /var/db/${PORTNAME} needs to have a @dir entry whereas ${PREFIX}/share/${PORTNAME} does not if it contains files or uses the default owner, group, and mode.


In practical terms, that means most ports have no @dir at all.  They only use them for empty directories or directories with no-standard ownership or permissions.  You can probably remove them all.
Comment 9 Torsten Zühlsdorff 2015-01-22 11:07:09 UTC
Created attachment 152007 [details]
Patch against games/wesnoth - Version 4 (correct @dir usage)
Comment 10 Torsten Zühlsdorff 2015-01-22 11:09:58 UTC
I see you're point. I'm sorry, i should have reviewed this better in the first place. Now i had a look at the link and cleaned the plist once again. Some entries are needed, some not. Attached the updated patch. :)

I also create a new poudriere log for verification. You can see it here (Attention: its 3.8 MB):
http://ports.toco-domains.de/poudriere-test-logs/wesnoth-1.12.0.log
Comment 11 John Marino freebsd_committer 2015-01-22 11:25:08 UTC
(In reply to Torsten Zühlsdorff from comment #10)

>I see you're point. I'm sorry, i should have reviewed this better in the first
> place. 

That's okay. You are learning and will do better next time, right? :)

> Now i had a look at the link and cleaned the plist once again. Some
> entries are needed, some not. Attached the updated patch. :)

Am I am looking at the right patch?  I see dozens of @dir lines still and I don't know why they are there.

Also, why did you comment out "MAN6" line instead of just deleting it directly?
Comment 12 Torsten Zühlsdorff 2015-01-22 11:32:47 UTC
Created attachment 152010 [details]
Patch against games/wesnoth - Version 4 (the correct one)
Comment 13 Torsten Zühlsdorff 2015-01-22 11:36:14 UTC
(In reply to John Marino from comment #11)

>>I see you're point. I'm sorry, i should have reviewed this better in the first
>> place. 

> That's okay. You are learning and will do better next time, right? :)

You're right, i will do :)

>> Now i had a look at the link and cleaned the plist once again. Some
>> entries are needed, some not. Attached the updated patch. :)

> Am I am looking at the right patch?  I see dozens of @dir lines still 
> and I don't know why they are there.

Nearly. ;) I've already tried to remove the @dir lines but this results in plist-errors (orphaned @dir). At the moment i don't understand why the entries are needed, but without them there are errors. Do you want a log?

> Also, why did you comment out "MAN6" line instead of just deleting it directly?

Because i've attached the wrong version of the patch. -.-
Comment 14 John Marino freebsd_committer 2015-01-22 11:46:56 UTC
> Do you want a log?

yes, if http://ports.toco-domains.de/poudriere-test-logs/wesnoth-1.12.0.log is not valid (I didn't look at it yet)

I suspect these are all empty directories (you can confirm by looking in stage/user/local/man directory).

If that's the cause, you need to use "${FIND} ${STAGEDIR}${PREFIX}/man -type d -empty -delete" or something like that in post-install target to remove these.

Putting them in pkg-plist is worse than seeing the warnings in the pkg-plist check.
Comment 15 Torsten Zühlsdorff 2015-01-22 11:56:46 UTC
(In reply to John Marino from comment #14)

>> Do you want a log?

> yes, if http://ports.toco-domains.de/poudriere-test-logs/wesnoth-1.12.0.log 
> is not valid (I didn't look at it yet)

Its valid.

> I suspect these are all empty directories (you can confirm by looking 
> in stage/user/local/man directory).

You are right.

> If that's the cause, you need to use "${FIND} ${STAGEDIR}${PREFIX}/man -type 
> d -empty -delete" or something like that in post-install target to remove these.

I will figure it out and update patch and log when i'm done. Thanks for your help so far :)
Comment 16 Torsten Zühlsdorff 2015-01-22 14:32:35 UTC
Created attachment 152014 [details]
Patch against games/wesnoth - Version 5 (all @dir removed)
Comment 17 Torsten Zühlsdorff 2015-01-22 14:34:38 UTC
All @dir entries successfully removed. You're code snipped worked well! :)

I've attached the new diff and create a new test-log (3.9 MB):
http://ports.toco-domains.de/poudriere-test-logs/wesnoth-1.12.0-v5.log
Comment 18 John Marino freebsd_committer 2015-01-25 15:38:15 UTC
great!  Looking at the log, this minor blip shows in stage-qa: 

"Warning: you may not need USES=desktop-file-utils"

So the obvious question is: If you remove desktop-file-utils, does it still build and work as before?
Comment 19 Torsten Zühlsdorff 2015-01-26 11:50:23 UTC
Created attachment 152171 [details]
Patch against games/wesnoth - Version 6 (removed desktop-file-utils warning)
Comment 20 Torsten Zühlsdorff 2015-01-26 11:56:56 UTC
I looked at the warning yesterday and changed the port. After some hours of testing (and playing ;)) i can say: it works without this USE-flag.

New poudriere test log (3.9 MB):
http://ports.toco-domains.de/poudriere-test-logs/wesnoth-1.12.0-v6.log
Comment 21 John Marino freebsd_committer 2015-01-26 11:58:55 UTC
Very good!
I am promoting the PR to the next level (patch-ready) where it should be committed.
Comment 22 commit-hook freebsd_committer 2015-02-06 13:44:23 UTC
A commit references this bug:

Author: marino
Date: Fri Feb  6 13:44:07 UTC 2015
New revision: 378538
URL: https://svnweb.freebsd.org/changeset/ports/378538

Log:
  games/wesnoth: Upgrade version 1.10.7 => 1.12.0, change maintainers

  With the blessing of the former maintainer, the submitter of the PR
  takes over the maintainership of Wesnoth.

  PR:		196721
  Submitted by:	Torsten Zuehlsdorff

Changes:
  head/games/wesnoth/Makefile
  head/games/wesnoth/distinfo
  head/games/wesnoth/files/
  head/games/wesnoth/pkg-plist
Comment 23 John Marino freebsd_committer 2015-02-06 13:45:29 UTC
Thanks!