Bug 196745 - devel/qgit fix with newer git
Summary: devel/qgit fix with newer git
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-15 04:00 UTC by Steve Wills
Modified: 2017-03-06 18:46 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (itetcu)


Attachments
patch to update commands for new version of git (1.30 KB, text/plain)
2015-01-15 04:00 UTC, Steve Wills
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2015-01-15 04:00:12 UTC
Created attachment 151653 [details]
patch to update commands for new version of git

qgit calls git with repo-config arg which is no longer supported, see attached patch to update, obtained from:

https://github.com/alexandreroman/qgit4/commit/8557406f2ee017d87518c8befa17af12d13daf08
Comment 1 Bugzilla Automation freebsd_committer 2015-01-15 04:00:12 UTC
Auto-assigned to maintainer itetcu@FreeBSD.org
Comment 2 Martin Wilke freebsd_committer 2016-01-17 12:25:42 UTC
(In reply to Steve Wills from comment #0)
Hi Steve;

Looks like the patch is rejecting, I wonder if this port still works with the current git version.

Would you mind to check?
Comment 3 Rene Ladan freebsd_committer 2017-02-27 20:50:46 UTC
Maintainer reset.
Comment 4 commit-hook freebsd_committer 2017-03-02 18:12:52 UTC
A commit references this bug:

Author: tcberner
Date: Thu Mar  2 18:12:37 UTC 2017
New revision: 435291
URL: https://svnweb.freebsd.org/changeset/ports/435291

Log:
  Fix devel/qgit with newer git versions

  repo-config is no longer supported by any upstream-supported
  git version. Instead, use git config (which is implicitly
  git config --file, corresponding to the earlier config-in-repo).

  PR:		196745
  Submitted by:	Adriaan de Groot <groot@kde.org>, swills
  Reported by:	swills, groot@kde.org
  Reviewed by:	tcberner, rakuco
  Approved by:	rakuco (mentor)
  Differential Revision:	https://reviews.freebsd.org/D9861

Changes:
  head/devel/qgit/Makefile
  head/devel/qgit/files/
  head/devel/qgit/files/patch-src_git.cpp
Comment 5 commit-hook freebsd_committer 2017-03-06 18:46:20 UTC
A commit references this bug:

Author: tcberner
Date: Mon Mar  6 18:45:32 UTC 2017
New revision: 435564
URL: https://svnweb.freebsd.org/changeset/ports/435564

Log:
  MFH: r435291

  Fix devel/qgit with newer git versions

  repo-config is no longer supported by any upstream-supported
  git version. Instead, use git config (which is implicitly
  git config --file, corresponding to the earlier config-in-repo).

  PR:		196745
  Submitted by:	Adriaan de Groot <groot@kde.org>, swills
  Reported by:	swills, groot@kde.org
  Reviewed by:	tcberner, rakuco
  Approved by:	rakuco (mentor)
  Differential Revision:	https://reviews.freebsd.org/D9861

  Approved by:	ports-secteam (junovitch), rakuco (mentor)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/devel/qgit/Makefile
  branches/2017Q1/devel/qgit/files/