Bug 196746 - sysutils/bbcp new MASTER_SITES, new PORTVERSION, req MAINTAINER(ship)
Summary: sysutils/bbcp new MASTER_SITES, new PORTVERSION, req MAINTAINER(ship)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
: 192405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-15 06:50 UTC by Chris Hutchinson
Modified: 2015-01-29 17:21 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (jhein)


Attachments
sysutils/bbcp SVN DIFF (1.95 KB, patch)
2015-01-15 06:50 UTC, Chris Hutchinson
no flags Details | Diff
1 of 4 new patches required for sysutils/bbcp (335 bytes, text/x-c++src)
2015-01-15 06:52 UTC, Chris Hutchinson
no flags Details
2 of 4 new patches required for sysutils/bbcp (312 bytes, text/x-c++src)
2015-01-15 06:52 UTC, Chris Hutchinson
no flags Details
3 of 4 new patches required for sysutils/bbcp (335 bytes, text/x-c++src)
2015-01-15 06:53 UTC, Chris Hutchinson
no flags Details
4 of 4 new patches required for sysutils/bbcp (343 bytes, text/x-c++src)
2015-01-15 06:53 UTC, Chris Hutchinson
no flags Details
requisite QA session (91.98 KB, text/plain)
2015-01-15 06:54 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2015-01-15 06:50:09 UTC
Created attachment 151654 [details]
sysutils/bbcp SVN DIFF

sysutils/bbcp

in response to a request in ports@ I've brought this port
to the latest version available upstream. Doing so, required
a great deal of source modification (it was a mess). As such,
I'll be maintaining this version locally. In any event, this
was built and tested on 11-CURRENT.

Modifications to
Makefile
distinfo
pkg-descr

removed previous patch

added four new patches:
patch-src__bbcp_BuffPool.C
patch-src__bbcp_File.C
patch-src__bbcp_NetAddr.C
patch-src__bbcp_NetAddrInfo.C

Please see svn(1) diff(1) attached, as well as QA session,
and the four patch files named above.

Thank you for all your time, and consideration.

--Chris
Comment 1 Bugzilla Automation freebsd_committer 2015-01-15 06:50:09 UTC
Maintainer CC'd
Comment 2 Chris Hutchinson 2015-01-15 06:52:15 UTC
Created attachment 151656 [details]
1 of 4 new patches required for sysutils/bbcp
Comment 3 Chris Hutchinson 2015-01-15 06:52:58 UTC
Created attachment 151657 [details]
2 of 4 new patches required for sysutils/bbcp
Comment 4 Chris Hutchinson 2015-01-15 06:53:27 UTC
Created attachment 151658 [details]
3 of 4 new patches required for sysutils/bbcp
Comment 5 Chris Hutchinson 2015-01-15 06:53:55 UTC
Created attachment 151659 [details]
4 of 4 new patches required for sysutils/bbcp
Comment 6 Chris Hutchinson 2015-01-15 06:54:56 UTC
Created attachment 151660 [details]
requisite QA session
Comment 7 Chris Hutchinson 2015-01-15 06:56:30 UTC
Please note that this also modifies MAINTAINER,
as per discussion with the currently listed maintainer.

Thanks again.

--Chris
Comment 8 Kurt Jaeger freebsd_committer 2015-01-15 08:21:40 UTC
testing@work
Comment 9 Kurt Jaeger freebsd_committer 2015-01-15 08:30:59 UTC
maintainer approved in

https://lists.freebsd.org/pipermail/freebsd-ports/2015-January/097591.html
Comment 10 commit-hook freebsd_committer 2015-01-15 08:53:16 UTC
A commit references this bug:

Author: pi
Date: Thu Jan 15 08:53:07 UTC 2015
New revision: 377063
URL: https://svnweb.freebsd.org/changeset/ports/377063

Log:
  sysutils/bbcp: 20120520 -> 20150113

  Change maintainer

  Other Changes: See section "New Features" and "Backward Compatibility" at
  http://www.slac.stanford.edu/~abh/bbcp/#_Toc392015164

  - The new -ptime option forces bbcp to preserve only source file's
    access and modification time at the destination; leaving the group
    and mode unchanged.
  - The new -gross option forces bbcp to copy empty directory structures
    in recursive mode.
  - The new -mkdir option creates the destination directory for a
    recursive copy should it not exist.
  - The new -symlinks option specifies how symbolic links are to be
    handled during a recursive copy.
  -  Dual stack IPv6 mode is fully functional and is the default mode
    of operation. The new -ipv4 option forces bbcp to use the IPv4 TCP
    stack.
  - The new -license option prints the license under which bbcp is
    distributed.
  - The new -version option displays bbcp's version number installed
    on the current host.
  - The BBCP_ALLOWPP environmental variable may be used to restrict
    program pipes to a specified set of programs or disable the feature
    altogether.
  - The new -Z option allows you to specify the port range to be used
    for incoming connections on the command line instead of relying on
    /etc/services to contain those values.

  Notes:
  - Older version will fail if any of the new option:  -ptime  is specified.
  - Older version will fail if any of the new options:  -gross, --mkdir, or
    --symlinks is specified.
  - Older version will fail if the new -ipv4 option is specified.
    Older versions always use the IPv4 TCP stack, making the option
    generally unnecessary.
  - Older versions will fail if the new -Z option is specified.

  PR:		196746
  Submitted by:	Chris Hutchinson <portmaster@bsdforge.com>
  Approved by:	John Hein <jhein@symmetricom.com> (maintainer)
  Requested from:	Freddie Cash <fjwcash@gmail.com>

Changes:
  head/sysutils/bbcp/Makefile
  head/sysutils/bbcp/distinfo
  head/sysutils/bbcp/files/patch-src__bbcp.C
  head/sysutils/bbcp/files/patch-src__bbcp_BuffPool.C
  head/sysutils/bbcp/files/patch-src__bbcp_File.C
  head/sysutils/bbcp/files/patch-src__bbcp_NetAddr.C
  head/sysutils/bbcp/files/patch-src__bbcp_NetAddrInfo.C
  head/sysutils/bbcp/pkg-descr
Comment 11 Kurt Jaeger freebsd_committer 2015-01-15 08:54:05 UTC
Committed, thanks!
Comment 12 Chris Hutchinson 2015-01-15 14:26:47 UTC
(In reply to Kurt Jaeger from comment #11)
Thank you, Kurt! :)

--Chris
Comment 13 Mark.Martinec 2015-01-29 17:21:02 UTC
*** Bug 192405 has been marked as a duplicate of this bug. ***