Bug 196802 - www/firefox: Crash on Wikipedia when built with clang 3.5
Summary: www/firefox: Crash on Wikipedia when built with clang 3.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-16 10:15 UTC by Jean-Sébastien Pédron
Modified: 2015-01-22 02:46 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
Patch from bug 1083461 (8.51 KB, text/plain)
2015-01-16 10:15 UTC, Jean-Sébastien Pédron
jbeich: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sébastien Pédron freebsd_committer 2015-01-16 10:15:28 UTC
Created attachment 151731 [details]
Patch from bug 1083461

Hi!

I hit the following regression with Firefox 35:
https://bugzilla.mozilla.org/show_bug.cgi?id=1083461

The problem is fixed upstream. I tried the patch (attached to this report) and I confirm it works.

The upstream bug also contains a patch for Firefox ESR.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-16 10:15:28 UTC
Auto-assigned to maintainer gecko@FreeBSD.org
Comment 2 Jan Beich freebsd_committer 2015-01-17 04:43:20 UTC
Comment on attachment 151731 [details]
Patch from bug 1083461

Patches that have landed upstream don't need an approval. They often work fine but be careful to not break build. And thanks for properly naming patchfile.

In the meantime, I've made a complete version after copying esr31 patch and adjusting paths for thunderbird/seamonkey while testing in poudriere for 9.3R i386 together with bug 196772.

https://trillian.chruetertee.ch/freebsd-gecko/changeset/1806
Comment 3 commit-hook freebsd_committer 2015-01-20 23:59:19 UTC
A commit references this bug:

Author: jbeich
Date: Tue Jan 20 23:59:05 UTC 2015
New revision: 377564
URL: https://svnweb.freebsd.org/changeset/ports/377564

Log:
  Backport Wikipedia crashfix for clang 3.5

  PR:		196802
  Reported by:	dumbbell
  Obtained from:	https://github.com/mozilla/gecko-dev/commit/87f367b
  Obtained from:	https://github.com/mozilla/gecko-dev/commit/c97894b (esr31 version)
  Differential Revision:	https://reviews.freebsd.org/D1568
  Approved by:	flo (mentor)
  MFH:		2015Q1

Changes:
  head/mail/thunderbird/files/patch-bug1083461
  head/www/firefox/files/patch-bug1083461
  head/www/firefox-esr/files/patch-bug1083461
  head/www/libxul/files/patch-bug1083461
  head/www/seamonkey/files/patch-bug1083461
Comment 4 commit-hook freebsd_committer 2015-01-21 05:00:51 UTC
A commit references this bug:

Author: jbeich
Date: Wed Jan 21 05:00:47 UTC 2015
New revision: 377576
URL: https://svnweb.freebsd.org/changeset/ports/377576

Log:
  MFH: r377564

  Backport Wikipedia crashfix for clang 3.5

  PR:		196802
  Reported by:	dumbbell
  Obtained from:	https://github.com/mozilla/gecko-dev/commit/87f367b
  Obtained from:	https://github.com/mozilla/gecko-dev/commit/c97894b (esr31 version)
  Differential Revision:	https://reviews.freebsd.org/D1568
  Approved by:	flo (mentor)
  Approved by:	portmgr (bapt)

Changes:
_U  branches/2015Q1/
  branches/2015Q1/mail/thunderbird/files/patch-bug1083461
  branches/2015Q1/www/firefox/files/patch-bug1083461
  branches/2015Q1/www/firefox-esr/files/patch-bug1083461
  branches/2015Q1/www/libxul/files/patch-bug1083461
  branches/2015Q1/www/seamonkey/files/patch-bug1083461
Comment 5 Jean-Sébastien Pédron freebsd_committer 2015-01-21 08:13:14 UTC
Thank you Jan!

Shouldn't the PORTREVISION be incremented? The port requires a rebuild to benefit from the fix.
Comment 6 Jan Beich freebsd_committer 2015-01-21 09:20:25 UTC
Clang 3.5 is used only on 11.0-CURRENT. Not a month has passed since it was imported in 2014-12-31. beef1/beefy2 still list 2015-01-15 as the latest build with firefox-34.0.5,1.

So, is PORTREVISION bump still wanted? What's the next date 11.0-CURRENNT packages are scheduled to build?
Comment 7 Jan Beich freebsd_committer 2015-01-21 09:28:15 UTC
One more request for PORTREVISION bump:
https://lists.freebsd.org/pipermail/svn-ports-head/2015-January/082300.html
Comment 8 Jean-Sébastien Pédron freebsd_committer 2015-01-21 09:48:40 UTC
My understanding is that PORTREVISION targets Ports users (not packages users).

Without the bug fix, Firefox builds fine; the problem occurs at runtime. Therefore, without a PORTREVISION bump, someone who built Firefox will see Firefox crash but no tool will suggest him that the port could be updated. If PORTREVISION is bumped, the user can notice that an update is available and rebuild Firefox.

If the problem was a build failure, a PORTREVISION bump would not be necessary because the port would not build without the fix anyway.
Comment 9 commit-hook freebsd_committer 2015-01-21 13:37:32 UTC
A commit references this bug:

Author: jbeich
Date: Wed Jan 21 13:36:38 UTC 2015
New revision: 377605
URL: https://svnweb.freebsd.org/changeset/ports/377605

Log:
  Bump PORTREVISION after r377564.

  PR:		196802
  Requested by:	dumbbell, tijl
  Differential Revision:	https://reviews.freebsd.org/D1574
  Approved by:	bapt (mentor)
  MFH:		2015Q1

Changes:
  head/mail/thunderbird/Makefile
  head/www/firefox/Makefile
  head/www/firefox-esr/Makefile
  head/www/libxul/Makefile
  head/www/seamonkey/Makefile
Comment 10 commit-hook freebsd_committer 2015-01-21 13:53:35 UTC
A commit references this bug:

Author: jbeich
Date: Wed Jan 21 13:53:24 UTC 2015
New revision: 377609
URL: https://svnweb.freebsd.org/changeset/ports/377609

Log:
  MFH: r377605

  Bump PORTREVISION after r377564.

  PR:		196802
  Requested by:	dumbbell, tijl
  Differential Revision:	https://reviews.freebsd.org/D1574
  Approved by:	bapt (mentor)
  Approved by:	portmgr (bapt)

Changes:
_U  branches/2015Q1/
  branches/2015Q1/mail/thunderbird/Makefile
  branches/2015Q1/www/firefox/Makefile
  branches/2015Q1/www/firefox-esr/Makefile
  branches/2015Q1/www/libxul/Makefile
  branches/2015Q1/www/seamonkey/Makefile
Comment 11 mp39590 2015-01-21 22:07:47 UTC
After the bump, on recompilation I got this error:

c++ -o nsUTF8ToUnicodeSSE2.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /usr/ports/www/firefox/work/mozilla-release/config/gcc_hidden.h -DSTATIC_E
XPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/usr/ports/www/firefox/work/mozilla-release/intl/uconv -I
. -I/usr/ports/www/firefox/work/mozilla-release/intl/uconv/ucvcn -I/usr/ports/www/firefox/work/mozilla-release/intl/uconv/ucvja -I/usr/ports/www/firefox/work/mozilla-rele
ase/intl/uconv/ucvko -I/usr/ports/www/firefox/work/mozilla-release/intl/uconv/ucvlatin -I/usr/ports/www/firefox/work/mozilla-release/intl/uconv/ucvtw -I/usr/ports/www/fir
efox/work/mozilla-release/intl/uconv/util -I../../dist/include   -I/usr/local/include/nspr -I/usr/local/include/nss -I/usr/local/include/nss/nss -I/usr/local/include -I/u
sr/local/include  -I/usr/local/include/pixman-1     -fPIC  -Qunused-arguments -isystem/usr/local/include -DLIBICONV_PLUG  -DMOZILLA_CLIENT -include ../../mozilla-config.h
 -MD -MP -MF .deps/nsUTF8ToUnicodeSSE2.o.pp -Qunused-arguments -isystem/usr/local/include -DLIBICONV_PLUG  -Qunused-arguments -Wall -Wempty-body -Woverloaded-virtual -Wsi
gn-compare -Wwrite-strings -Werror=endif-labels -Werror=int-to-pointer-cast -Werror=missing-braces -Werror=pointer-arith -Werror=return-type -Werror=sequence-point -Werro
r=unused-label -Werror=trigraphs -Werror=type-limits -Wno-invalid-offsetof -Wno-inline-new-delete -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option
 -Wno-return-type-c-linkage -O2 -pipe -O3 -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -DLIBICONV_PLUG -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction
-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pipe  -DNDEBUG -DTRIMMED -O2 -O3 -fomit-frame-pointer   -msse2  /usr/ports/www/firefox/work/mozill
a-release/intl/uconv/nsUTF8ToUnicodeSSE2.cpp
Unified_cpp_intl_uconv0.o
/usr/ports/www/firefox/work/mozilla-release/intl/uconv/nsUTF8ToUnicodeSSE2.cpp:8:10: fatal error: 'emmintrin.h' file not found
#include <emmintrin.h>
         ^
1 error generated.
/usr/ports/www/firefox/work/mozilla-release/config/rules.mk:948: recipe for target 'nsUTF8ToUnicodeSSE2.o' failed
Comment 12 mp39590 2015-01-22 02:46:53 UTC
Looks like it was issue in my installation, false alarm.