Bug 196845 - devinfo does not present vital info (compared to sysctl)
Summary: devinfo does not present vital info (compared to sysctl)
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-18 19:34 UTC by Uffe Jakobsen
Modified: 2015-01-18 19:35 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uffe Jakobsen 2015-01-18 19:34:27 UTC
devinfo does not present vital info (compared to sysctl)

Please observe this output from cmd: "sysctl dev.umodem" 
The device in question appears as an USB-serial port to the system.
Please note the fields "ttyname" and "ttyports" in the "%pnpinfo" record

dev.umodem.%parent: 
dev.umodem.0.%desc: Microchip Technology Inc. CDC RS-232 Emulation Demo, class 2/0, rev 2.00/1.00, addr 1
dev.umodem.0.%driver: umodem
dev.umodem.0.%location: bus=4 hubaddr=1 port=3 devaddr=2 interface=0
dev.umodem.0.%pnpinfo: vendor=0x04d8 product=0xfa95 devclass=0x02 devsubclass=0x00 sernum="Logic Pirate v1" release=0x0100 mode=host intclass=0x02 intsubclass=0x02 intprotocol=0x01  ttyname=U0 ttyports=1
dev.umodem.0.%parent: uhub1
dev.umodem.0.ttyname: U0
dev.umodem.0.ttyports: 1

This is the output from devinfo for the same device:

umodem0 pnpinfo vendor=0x04d8 product=0xfa95 devclass=0x02 devsubclass=0x00 sernum="Logic Pirate v1" release=0x0100 mode=host intclass=0x02 int at bus=4 hubaddr=1 port=3 devaddr=2 interface=0

Note that the "ttyname" and "ttyports" entries are missing.

This makes it impossible to use devinfo in order to determine the mapping between USB(-serial) devices and the /dev/cuaUx serial ports that the provide