Bug 196847 - [arm] multimedia/gstreamer-ffmpeg: fails to build on armv6 with clang3.5.0
Summary: [arm] multimedia/gstreamer-ffmpeg: fails to build on armv6 with clang3.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-18 19:48 UTC by Mikael Urankar
Modified: 2015-01-20 16:38 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments
fix build on armv6 (1.29 KB, patch)
2015-01-18 19:48 UTC, Mikael Urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2015-01-18 19:48:30 UTC
Created attachment 151806 [details]
fix build on armv6

Hi,

clang enabled the integrated assembler by default and it breaks the build of gst-ffmpeg.

AS from base cannot assemble some c files, we need to use AS from binutils

Import libav upstream patch to fix cpu detection:
https://git.libav.org/?p=libav.git;a=commitdiff;h=8ee2b4672f6ad5cfd003e742f887cffcfea26021

The attached patch fixes that.

To apply the patch:
cd /usr/ports/multimedia/gstreamer-ffmpeg; patch < /path/to/patch
find /usr/ports/multimedia/gstreamer-ffmpeg -type f -name "*.orig" -delete
Comment 1 Bugzilla Automation freebsd_committer 2015-01-18 19:48:30 UTC
Auto-assigned to maintainer multimedia@FreeBSD.org
Comment 2 Sean Bruno freebsd_committer 2015-01-19 17:29:49 UTC
Confirmed.  I'll commit this later today.

http://tasty.ysv.freebsd.org/build.html?mastername=11armv6-11-armv6-ports&build=2015-01-19_17h23m05s
Comment 3 commit-hook freebsd_committer 2015-01-20 16:37:23 UTC
A commit references this bug:

Author: sbruno
Date: Tue Jan 20 16:36:56 UTC 2015
New revision: 377529
URL: https://svnweb.freebsd.org/changeset/ports/377529

Log:
  Disable clang's integrated-as for this build.  Modify ARM assembly
  with upstream patch to handle different ARM revisions.  This fixes the build
  since the clang 3.5 import

  PR:		196847
  Submitted by:	mikael.urankar@gmail.com
  Reviewed by:	kwm
  Approved by:	mentor (implicit)

Changes:
  head/multimedia/gstreamer-ffmpeg/Makefile
  head/multimedia/gstreamer-ffmpeg/files/patch-gst-libs_ext_libav_libavcodec_arm_asm.S