Bug 196862 - [PATCH] x11-toolkits/py-wxPython28: Fail embedding_in_wx5.py - gcc48/libgfortran.so.3 not found
Summary: [PATCH] x11-toolkits/py-wxPython28: Fail embedding_in_wx5.py - gcc48/libgfort...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python mailing list
URL:
Keywords: needs-qa, patch
Depends on: 208120
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-19 03:58 UTC by f0andrey
Modified: 2018-01-17 07:31 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (mainland)


Attachments
patch-Makefile x11-toolkits/py-wxPython28 (327 bytes, patch)
2015-04-13 20:52 UTC, Andrey Fesenko
no flags Details | Diff
patch-Makefile x11-toolkits/py-wxPython28 (548 bytes, patch)
2015-04-13 21:06 UTC, Andrey Fesenko
no flags Details | Diff
poudriere bulk -t log py-wxPython28 (529.91 KB, text/x-log)
2015-04-18 07:05 UTC, Andrey Fesenko
no flags Details
patch-Makefile and files x11-toolkits/py-wxPython28 (2.74 KB, patch)
2015-05-01 13:05 UTC, Andrey Fesenko
no flags Details | Diff
poudriere bulk -t log py-wxPython28 (529.72 KB, text/plain)
2015-05-01 13:05 UTC, Andrey Fesenko
no flags Details
poudriere portlint -AC py-wxPython28 (803 bytes, text/plain)
2015-05-01 13:07 UTC, Andrey Fesenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description f0andrey 2015-01-19 03:58:05 UTC
I encountered a problem that occurs in a similar Bug 188114, but not closed last patch

environment for reproduction:
# python -c "import matplotlib as m; print(m.__version__); print(m.__path__[0]);"             
1.4.0
/usr/local/lib/python2.7/site-packages/matplotlib
# python -c "import numpy as m; print(m.__version__); print(m.__path__[0]);"                  
1.9.1
/usr/local/lib/python2.7/site-packages/numpy
# python -c "import wx as m; print(m.__version__); print(m.__path__[0]);"
2.8.12.1
/usr/local/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx

/usr/local/share/examples/py-matplotlib % python user_interfaces/embedding_in_wx5.py
Traceback (most recent call last):
  File "user_interfaces/embedding_in_wx5.py", line 7, in <module>
    import matplotlib as mpl
  File "/usr/local/lib/python2.7/site-packages/matplotlib/__init__.py", line 179, in <module>
    from matplotlib.cbook import is_string_like
  File "/usr/local/lib/python2.7/site-packages/matplotlib/cbook.py", line 32, in <module>
    import numpy as np
  File "/usr/local/lib/python2.7/site-packages/numpy/__init__.py", line 170, in <module>
    from . import add_newdocs
  File "/usr/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 18, in <module>
    from .polynomial import *
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/polynomial.py", line 19, in <module>
    from numpy.linalg import eigvals, lstsq, inv
  File "/usr/local/lib/python2.7/site-packages/numpy/linalg/__init__.py", line 51, in <module>
    from .linalg import *
  File "/usr/local/lib/python2.7/site-packages/numpy/linalg/linalg.py", line 29, in <module>
    from numpy.linalg import lapack_lite, _umath_linalg
ImportError: /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc48/libgfortran.so.3 not found

user_interfaces/embedding_in_wx2-4.py - work fine
Comment 1 Bugzilla Automation freebsd_committer 2015-01-19 03:58:05 UTC
Maintainer CC'd
Comment 2 Andrey Fesenko 2015-04-13 12:02:49 UTC
Problem solves the global definition in libmap.conf

libgcc_s.so.1   gcc48/libgcc_s.so.1

But as I understand it, so globally determine not very good, I could not tell whether someone constraint for libmap?
Comment 3 Andrey Fesenko 2015-04-13 13:52:02 UTC
(In reply to Andrey Fesenko from comment #2)
[/usr/local/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/]
libgcc_s.so.1   gcc48/libgcc_s.so.1
 
[/usr/local/lib/python2.7/site-packages/wx-2.8-gtk2-ansi/]
libgcc_s.so.1   gcc48/libgcc_s.so.1

two conditions are necessary, since different programs can be used ansi or unicode
Comment 4 Andrey Fesenko 2015-04-13 20:52:46 UTC
Created attachment 155565 [details]
patch-Makefile x11-toolkits/py-wxPython28

Add USES fortran, fix this bug.
Comment 5 Andrey Fesenko 2015-04-13 21:06:05 UTC
Created attachment 155570 [details]
patch-Makefile x11-toolkits/py-wxPython28

fix PORTREVISION
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2015-04-18 02:11:50 UTC
QA results would help here:

- portlint -AC output (as attachment)
- poudriere testport (or bulk -t) output (as attachment)
Comment 7 Andrey Fesenko 2015-04-18 07:05:11 UTC
Created attachment 155687 [details]
poudriere bulk -t log py-wxPython28

Port x11-toolkits/py-wxPython28  have Maintainer: python@FreeBSD.org
Bug was first seen makes it possible for math/py-matplotlib his Maintainer: mainland@apeiron.net

x11-toolkits/py-wxPython28 # portlint -AC
WARN: Makefile: [125]: do not use muted INSTALL_foo commands (i.e., those that start with '@').  These should be printed.
WARN: Makefile: Consider adding support for a NLS knob to conditionally disable gettext support.
WARN: Makefile: [19]: possible direct use of command "python" found. use ${PYTHON_CMD} instead.
WARN: Makefile: [0]: possible direct use of command "echo" found. use ${ECHO_CMD} or ${ECHO_MSG} instead.
WARN: Makefile: [133]: possible use of "${CHMOD}" found. Use @(owner,group,mode) syntax or @owner/@group operators in pkg-plist instead.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
WARN: Makefile: new ports should not set PORTREVISION.
WARN: Makefile: Consider defining LICENSE.
WARN: Makefile: "PKGNAMESUFFIX" has to appear earlier.
WARN: /usr/ports/x11-toolkits/py-wxPython28/files/patch-config.py: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' to ensure proper patch format.
WARN: /usr/ports/x11-toolkits/py-wxPython28/files/patch-setup.py: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' to ensure proper patch format.
0 fatal errors and 11 warnings found.

If you want, I can try to remove WARNINGS.

There is also a related ports x11-toolkits/py-wxPython28-common (have portversion) x11-toolkits/py-wxPython28-unicode (not have), how best to standardize?
Comment 8 Andrey Fesenko 2015-05-01 13:05:00 UTC
Created attachment 156206 [details]
patch-Makefile and files x11-toolkits/py-wxPython28

Update patch for port, Fix warnings portlint -AC
Comment 9 Andrey Fesenko 2015-05-01 13:05:59 UTC
Created attachment 156207 [details]
poudriere bulk -t log py-wxPython28

update poudriere log
Comment 10 Andrey Fesenko 2015-05-01 13:07:26 UTC
Created attachment 156208 [details]
poudriere portlint -AC py-wxPython28

actual portlint -AC py-wxPython28
Comment 11 Andrey Fesenko 2015-05-16 02:16:11 UTC
For reproduce
Install (default options

x11-toolkits/py-wxPython28-unicode
math/py-matplotlib

run

python /usr/local/share/examples/py-matplotlib/user_interfaces/embedding_in_wx5.py

this test crash https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196862#c0
Comment 12 Walter Schwarzenfeld freebsd_triage 2018-01-17 07:31:00 UTC
Any news here?