Bug 196866 - [maintainer update] net-mgmt/ccnet: add support to LDAP
Summary: [maintainer update] net-mgmt/ccnet: add support to LDAP
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Marino
URL:
Keywords:
: 196868 (view as bug list)
Depends on: 196921
Blocks: 196920
  Show dependency treegraph
 
Reported: 2015-01-19 05:56 UTC by Jingfeng Yan
Modified: 2015-02-23 09:15 UTC (History)
2 users (show)

See Also:


Attachments
svn diff for ccnet (626 bytes, patch)
2015-01-19 05:56 UTC, Jingfeng Yan
no flags Details | Diff
portlint result (203 bytes, text/plain)
2015-01-19 05:57 UTC, Jingfeng Yan
no flags Details
testport result (205.60 KB, text/plain)
2015-01-19 05:59 UTC, Jingfeng Yan
no flags Details
svn diff for ccnet (9.42 KB, patch)
2015-01-20 04:38 UTC, Jingfeng Yan
no flags Details | Diff
svn diff for ccnet (9.58 KB, patch)
2015-01-20 04:51 UTC, Jingfeng Yan
no flags Details | Diff
svn diff (9.58 KB, patch)
2015-01-27 01:36 UTC, Jingfeng Yan
no flags Details | Diff
portlint result (186 bytes, text/plain)
2015-01-27 01:36 UTC, Jingfeng Yan
no flags Details
testport result (198.93 KB, text/plain)
2015-01-27 01:37 UTC, Jingfeng Yan
no flags Details
svn diff (8.95 KB, patch)
2015-02-08 20:24 UTC, Jingfeng Yan
no flags Details | Diff
testport result (205.96 KB, text/plain)
2015-02-08 20:27 UTC, Jingfeng Yan
no flags Details
svn diff (8.93 KB, patch)
2015-02-23 04:02 UTC, Jingfeng Yan
no flags Details | Diff
testport result (197.14 KB, text/plain)
2015-02-23 04:04 UTC, Jingfeng Yan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jingfeng Yan 2015-01-19 05:56:49 UTC
Created attachment 151826 [details]
svn diff for ccnet

ccnet was not built with LDAP support by default.  Now adding an option to build with openLDAP, and it will be part of default building.
Comment 1 Jingfeng Yan 2015-01-19 05:57:50 UTC
Created attachment 151827 [details]
portlint result
Comment 2 Jingfeng Yan 2015-01-19 05:59:19 UTC
Created attachment 151829 [details]
testport result
Comment 3 Jingfeng Yan 2015-01-19 06:03:48 UTC
*** Bug 196868 has been marked as a duplicate of this bug. ***
Comment 4 Jingfeng Yan 2015-01-20 04:38:24 UTC
Created attachment 151877 [details]
svn diff for ccnet
Comment 5 Jingfeng Yan 2015-01-20 04:51:04 UTC
Created attachment 151878 [details]
svn diff for ccnet
Comment 6 Jingfeng Yan 2015-01-20 04:53:45 UTC
(In reply to Jingfeng Yan from comment #0)

In addition, clean the installation to global site-packages, and server installation by non-root user/group.
Comment 7 Jingfeng Yan 2015-01-27 01:36:13 UTC
Created attachment 152225 [details]
svn diff
Comment 8 Jingfeng Yan 2015-01-27 01:36:46 UTC
Created attachment 152226 [details]
portlint result
Comment 9 Jingfeng Yan 2015-01-27 01:37:20 UTC
Created attachment 152227 [details]
testport result
Comment 10 John Marino freebsd_committer 2015-02-06 08:41:13 UTC
this one grew @dir lines too.  Why were these added?
Comment 11 Jingfeng Yan 2015-02-06 15:35:31 UTC
(In reply to John Marino from comment #10)

@dir lines added for changing owner and group's permission purpose.
Comment 12 Jingfeng Yan 2015-02-08 20:24:57 UTC
Created attachment 152770 [details]
svn diff

(1) move python pkg to server deployment directory instead of global pkg site.
(2) only top level server directory www/haiwen is set onwership (www/www).
(3) add LDAP support.
Comment 13 Jingfeng Yan 2015-02-08 20:27:32 UTC
Created attachment 152771 [details]
testport result

test port use portlint already. So, only test port result is loaded.
Comment 14 John Marino freebsd_committer 2015-02-16 08:51:08 UTC
what about this line?
	@exec install -d -o %%SEAFILE_USERNAME%% -g %%SEAFILE_GROUPNAME%% -m 755 %D/%%HAIWENDIR%%

Also, there's a "@" on the rm of post-install target
Comment 15 Jingfeng Yan 2015-02-23 04:02:02 UTC
Created attachment 153353 [details]
svn diff

correct the @exec to @dir
Comment 16 Jingfeng Yan 2015-02-23 04:04:03 UTC
Created attachment 153354 [details]
testport result
Comment 17 commit-hook freebsd_committer 2015-02-23 09:14:48 UTC
A commit references this bug:

Author: marino
Date: Mon Feb 23 09:14:27 UTC 2015
New revision: 379648
URL: https://svnweb.freebsd.org/changeset/ports/379648

Log:
  net-mgmt/ccnet: Add support for LDAP

  PR:		196866
  Submitted by:	maintainer (JingFeng Yan)

Changes:
  head/net-mgmt/ccnet/Makefile
  head/net-mgmt/ccnet/pkg-plist
Comment 18 John Marino freebsd_committer 2015-02-23 09:15:14 UTC
Thanks