Bug 196985 - [arm] audio/bristol attempts to use SSE instructions on all architectures
Summary: [arm] audio/bristol attempts to use SSE instructions on all architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Many People
Assignee: Mark Linimon
URL: http://chips.ysv.freebsd.org/data/11a...
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-01-22 01:44 UTC by Sean Bruno
Modified: 2018-06-12 04:23 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (pierrejacques.mimifir)


Attachments
Patch (937 bytes, patch)
2015-01-25 03:01 UTC, Dmitry Marakasov
amdmi3: maintainer-approval? (pierrejacques.mimifir)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Bruno freebsd_committer 2015-01-22 01:44:43 UTC
I suspect a configure option needs to be passed to bristol in order to not use SSE 4.1 instructions.

If there is no option for this, then the port should be marked as ONLY_FOR_ARCHS=i386 amd64
Comment 1 Bugzilla Automation freebsd_committer 2015-01-22 01:44:43 UTC
Maintainer CC'd
Comment 2 Dmitry Marakasov freebsd_committer 2015-01-25 03:01:28 UTC
Created attachment 152115 [details]
Patch

This should fix it (removed offending CFLAGS).

While here:
- Strip libraries
- Add empty dir to plist
Comment 4 Sean Bruno freebsd_committer 2015-02-07 23:56:50 UTC
(In reply to Dmitry Marakasov from comment #2)


Isn't that going to remove the instructions for all ARCHs?
Comment 5 Dmitry Marakasov freebsd_committer 2015-02-08 03:43:04 UTC
(In reply to Sean Bruno from comment #4)

Yes. That's what respecting C(XX)FLAGS is.
Comment 6 Sean Bruno freebsd_committer 2015-02-08 20:36:58 UTC
(In reply to Dmitry Marakasov from comment #5)
So, with this patch, will i386/amd64 still get SSE instructions?
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 04:24:38 UTC
Reporter is Committer.
Comment 8 Dmitry Marakasov freebsd_committer 2015-02-24 17:53:04 UTC
(In reply to Sean Bruno from comment #6)
Yes, this patch removes extra stuff including sse instructions on all targets. If they are really needed, they may be re-added with an option.
Comment 9 pierrejacques.mimifir 2015-11-02 13:59:01 UTC
Comment on attachment 152115 [details]
Patch

Dear  Dmitry,

Ok for the patch. It working fine o my computer.

Regards,
Pierre-Jacques MIMIFIR
Comment 10 Walter Schwarzenfeld freebsd_triage 2018-01-12 23:53:33 UTC
Is this still relevant?
Comment 11 Mark Linimon freebsd_committer freebsd_triage 2018-03-23 14:16:06 UTC
I had not seen this PR when I marked the port BROKEN on all tier-2.  I have not yet tried the patch.
Comment 12 Mark Linimon freebsd_committer freebsd_triage 2018-06-12 04:21:32 UTC
Committed.
Comment 13 commit-hook freebsd_committer 2018-06-12 04:23:35 UTC
A commit references this bug:

Author: linimon
Date: Tue Jun 12 04:23:29 UTC 2018
New revision: 472231
URL: https://svnweb.freebsd.org/changeset/ports/472231

Log:
  Fix build on non-x86 archs.

  PR:		196985
  Submitted by:	sbruno

Changes:
  head/audio/bristol/Makefile