Bug 197054 - net/shadowsocks-libev: update to 1.6.4
Summary: net/shadowsocks-libev: update to 1.6.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Bartek Rutkowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-24 16:50 UTC by Fukang Chen
Modified: 2015-03-22 15:07 UTC (History)
4 users (show)

See Also:
delphij: maintainer-feedback+


Attachments
1.6.4 diff (1.99 KB, patch)
2015-01-24 16:50 UTC, Fukang Chen
no flags Details | Diff
Add -fstack-protector option to CFLAGS to help solve building error (317 bytes, patch)
2015-02-07 08:18 UTC, xiaoding+freebsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fukang Chen freebsd_committer 2015-01-24 16:50:19 UTC
Created attachment 152105 [details]
1.6.4 diff

update from 1.4.0 to 1.6.4
Comment 1 Bugzilla Automation freebsd_committer 2015-01-24 16:50:19 UTC
Maintainer CC'd
Comment 2 xiaoding+freebsd 2015-01-25 03:32:09 UTC
Reviewed and accepted, thanks!
Comment 3 commit-hook freebsd_committer 2015-02-02 05:00:05 UTC
A commit references this bug:

Author: delphij
Date: Mon Feb  2 04:59:40 UTC 2015
New revision: 378292
URL: https://svnweb.freebsd.org/changeset/ports/378292

Log:
  Update to 1.6.4.

  PR:		ports/197054
  Submitted by:	loader
  Approved by:	maintainer (Xiaoding Liu <xiaoding xiaoding org>)

Changes:
  head/net/shadowsocks-libev/Makefile
  head/net/shadowsocks-libev/distinfo
  head/net/shadowsocks-libev/pkg-plist
Comment 4 xiaoding+freebsd 2015-02-07 08:18:21 UTC
Created attachment 152661 [details]
Add -fstack-protector option to CFLAGS to help solve building error

This updated port fails to build in 8.4 and 9.3 on i386 platform.
See http://portsmon.freebsd.org/portoverview.py?category=net&portname=shadowsocks-libev 

This is caused by the newly integrated libsodium library, which enables
the -fstack-protector options to help improve security. However, the
configure script did not handle it well while building the main port.
Manually specified -fstack-protector option solve the problem.
Comment 5 Bartek Rutkowski freebsd_committer 2015-03-21 10:51:08 UTC
There seems to be another problem with building the port, where it fails with fetching the sources:

http://pd.valinor.palantiri.org/data/84amd64-default/2015-03-21_11h49m10s/logs/errors/shadowsocks-libev-1.6.4.log

If you could post the patch that fixes them both, I could test it and committ once it builds fine.
Comment 6 xiaoding+freebsd 2015-03-21 12:30:29 UTC
(In reply to Bartek Rutkowski from comment #5)
The makefile is updated at 2015-03-20 by bdrewery in revision 381775, as a result the port distfile name is slightly changed. You may have to update your port and distfile repo.
Just now I performed a test building in my whole new FreeBSD 8.4-p24 amd64 virtual machine, it succeeded with no error. Seems the bug got fixed, would you test again?
Comment 7 Bartek Rutkowski freebsd_committer 2015-03-22 11:27:47 UTC
(In reply to xiaoding+freebsd from comment #6)

I've updated the svn ports tree to latest version, and indeed, the latest revision is 381775 with changes from bdrewery, however exactly this one fails to build on fetch phase.
Comment 8 xiaoding+freebsd 2015-03-22 13:33:35 UTC
(In reply to Bartek Rutkowski from comment #7)
That's a bit weird. The fetch target succeeded in my machine. Here is my console output:

[xiaoding@vps2 /usr/ports/net/shadowsocks-libev]$ sudo make distclean checksum
===>  Cleaning for shadowsocks-libev-1.6.4
===>  Deleting distfiles for shadowsocks-libev-1.6.4
===>  License GPLv3 accepted by the user
===>   shadowsocks-libev-1.6.4 depends on file: /usr/local/sbin/pkg - found
=> shadowsocks-libev-v1.6.4_GH0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/madeye/shadowsocks-libev/tar.gz/v1.6.4?dummy=/shadowsocks-libev-v1.6.4_GH0.tar.gz
shadowsocks-libev-v1.6.4_GH0.tar.gz           100% of 2348 kB 1458 kBps 00m02s
===> Fetching all distfiles required by shadowsocks-libev-1.6.4 for building
=> SHA256 Checksum OK for shadowsocks-libev-v1.6.4_GH0.tar.gz.

What if you run "make distclean checksum" manually from the console?
Comment 9 Bartek Rutkowski freebsd_committer 2015-03-22 13:50:58 UTC
pd# make distclean checksum
===>  Cleaning for shadowsocks-libev-1.6.4
===>  Deleting distfiles for shadowsocks-libev-1.6.4
===>  License GPLv3 accepted by the user
===>   shadowsocks-libev-1.6.4 depends on file: /usr/local/sbin/pkg - found
=> shadowsocks-libev-v1.6.4.tar.gz is not in /pd/ports/default/net/shadowsocks-libev/distinfo.
=> Either /pd/ports/default/net/shadowsocks-libev/distinfo is out of date, or
=> shadowsocks-libev-v1.6.4.tar.gz is spelled incorrectly.
*** Error code 1

Stop.
make: stopped in /pd/ports/default/net/shadowsocks-libev
pd# cat distinfo
SHA256 (shadowsocks-libev-v1.6.4_GH0.tar.gz) = 517b92e69e371efac4a9ca76e78095e3e866149a484ec4c88589dd4a3bdbb7b7
SIZE (shadowsocks-libev-v1.6.4_GH0.tar.gz) = 2404815
pd# head Makefile
# Created by: Xiaoding Liu <xiaoding+freebsd@xiaoding.org>
# $FreeBSD: head/net/shadowsocks-libev/Makefile 381775 2015-03-20 19:24:24Z bdrewery $

PORTNAME=	shadowsocks-libev
DISTVERSIONPREFIX=v
PORTVERSION=	1.6.4
CATEGORIES=	net

MAINTAINER=	xiaoding+freebsd@xiaoding.org
COMMENT=	Lightweight tunnel proxy which can help you get through firewalls
Comment 10 xiaoding+freebsd 2015-03-22 14:10:49 UTC
(In reply to Bartek Rutkowski from comment #9)
Hmm... i cannot reproduce this error in my machine. I believe it's the problem of the ports script itself since the fetch target filename differs from expected in distinfo. Both 8.4-Release and 9.3-Release of mine work smoothly.

Maybe you can check the ports script in /usr/ports/Mk/, especially bsd.sites.mk file(revision 381782 in my machine), or try to fetch another ports tree with "portsnap -p /path/to/another fetch extract" and then test again.
Comment 11 commit-hook freebsd_committer 2015-03-22 15:06:49 UTC
A commit references this bug:

Author: robak
Date: Sun Mar 22 15:05:58 UTC 2015
New revision: 381926
URL: https://svnweb.freebsd.org/changeset/ports/381926

Log:
  net/shadowsocks-libev: fix i386 builds on 8.4 and 9.3

  PR:		197054
  Submitted by:	Xiaoding Liu <xiaoding+freebsd@xiaoding.org>

Changes:
  head/net/shadowsocks-libev/Makefile
Comment 12 Bartek Rutkowski freebsd_committer 2015-03-22 15:07:58 UTC
It turns out I was missing the updated Mk files, sorry it took so long to unravel that. Committed, thanks for your work!