Bug 197057 - Netstat -w1 and systat -ifstat show no out traffic
Summary: Netstat -w1 and systat -ifstat show no out traffic
Status: Closed DUPLICATE of bug 184626
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-wireless mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-24 22:00 UTC by Michael Gmelin
Modified: 2015-01-24 22:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gmelin freebsd_committer 2015-01-24 22:00:07 UTC
This seems to be a known issue, I couldn't find anything in bug database though. I experienced it using ath on 11-CURRENT, but it doesn't seem limited to this:

https://lists.freebsd.org/pipermail/freebsd-current/2014-June/050631.html

Examples are on a machine using ath0, wlan0 and wpa_supplicant, basically:

wlans_ath0="wlan0"
ifconfig_wlan0="WPA DHCP"

in /etc/rc.conf, while transferring about 10GB of data.

systat -iface:

          wlan0  in     73.489 KB/s         95.061 KB/s          624.790 MB
                 out     0.000 KB/s          0.000 KB/s            0.000 KB

netstat -w1:

            input        (Total)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
      3096    57     0     104070       6014     0          0     0
      3035    81     0     102054       5858     0          0     0


netstat -w1 -Iwlan0:
            input          wlan0           output
   packets  errs idrops      bytes    packets  errs      bytes colls
       733     0     0      50130       1354     0          0     0
      1494     0     0     100800       2927     0          0     0
      1334     0     0      89952       2545     0          0     0


netstat -w1 -Iath0:
            input           ath0           output
   packets  errs idrops      bytes    packets  errs      bytes colls
      1492   126     0          0       2834     0          0     0
      1548    50     0          0       2977     0          0     0
      1539   112     0          0       2929     0          0     0

For comparison, this is what this looks like at the receiving end:

netstat -w1
            input        (Total)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
      2812     0     0    4033836       1457     0      98414     0
      2089     0     0    2995736       1083     0      73154     0
      2959     0     0    4245570       1534     0     103592     0

netstat -h -w1
            input        (Total)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
      2.9K     0     0       4.1M       1.5K     0       101K     0
      2.9K     0     0       4.0M       1.5K     0       101K     0
      1.3K     0     0       1.8M        706     0        47K     0
Comment 1 Michael Gmelin freebsd_committer 2015-01-24 22:04:27 UTC

*** This bug has been marked as a duplicate of bug 184626 ***