Bug 197110 - emulators/i386-wine-devel 1.7.34 installation broken
Summary: emulators/i386-wine-devel 1.7.34 installation broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: David Naylor
URL:
Keywords:
: 197111 197112 197113 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-26 22:58 UTC by nick.rozhkov
Modified: 2015-01-27 05:12 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (dbn)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nick.rozhkov 2015-01-26 22:58:08 UTC
===>  Installing for i386-wine-devel-1.7.34,1
===>  Checking if i386-wine-devel already installed
===>   Registering installation for i386-wine-devel-1.7.34,1
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/include/wine/windows/ddk/csq.h: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/include/wine/windows/mferror.h: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/include/wine/windows/ntifs.h: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libffi.so.6: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libgmp.so.10: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libgnutls.so.28: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libhogweed.so.2: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libintl.so.8: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libnettle.so.4: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libp11-kit.so.0: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libtasn1.so.6: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libtspi.so.1: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/libxslt.so.1: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-datetime-l1-1-0.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-datetime-l1-1-1.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-fibers-l1-1-0.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-fibers-l1-1-1.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-file-l2-1-0.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-localization-l1-2-1.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-winrt-error-l1-1-1.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-winrt-l1-1-0.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/api-ms-win-core-xstate-l2-1-0.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-datetime-l1-1-0.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-datetime-l1-1-1.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-fibers-l1-1-0.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-fibers-l1-1-1.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-file-l2-1-0.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-localization-l1-2-1.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-winrt-error-l1-1-1.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-winrt-l1-1-0.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/api-ms-win-core-xstate-l2-1-0.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/fakedlls/wined3d-csmt.dll: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/lib32/wine/wined3d-csmt.dll.so: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/share/wine/fonts/arial.ttf: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/share/wine/fonts/cour.ttf: No such file or directory
pkg-static: Unable to access file /usr/ports/emulators/i386-wine-devel/work/stage/usr/local/share/wine/fonts/msyh.ttf: No such file or directory
*** Error code 74

Stop.
make[1]: stopped in /usr/ports/emulators/i386-wine-devel
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/i386-wine-devel

The same problem occurs during installation in i386 chroot environment

Environment:
root@daemon:/usr/ports/emulators/i386-wine-devel # uname -a
FreeBSD daemon.sanitarium.com.ua 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r275674: Sun Dec 14 19:31:23 EET 2014     root@daemon.sanitarium.com.ua:/usr/obj/usr/src/sys/JUNKIES  amd64
Comment 1 Bugzilla Automation freebsd_committer 2015-01-26 22:58:08 UTC
Auto-assigned to maintainer dbn@FreeBSD.org
Comment 2 nick.rozhkov 2015-01-27 01:18:32 UTC
*** Bug 197113 has been marked as a duplicate of this bug. ***
Comment 3 nick.rozhkov 2015-01-27 01:19:49 UTC
*** Bug 197111 has been marked as a duplicate of this bug. ***
Comment 4 nick.rozhkov 2015-01-27 01:20:13 UTC
*** Bug 197112 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2015-01-27 05:02:57 UTC
A commit references this bug:

Author: dbn
Date: Tue Jan 27 05:02:06 UTC 2015
New revision: 377981
URL: https://svnweb.freebsd.org/changeset/ports/377981

Log:
  emulators/i386-wine-devel: fix plist generation.

  The port-update target incorrectly used ${suffix:U} - instead of ${suffix:tu} -
  causing the plists for compholio to be used for both itself and devel.  Devel,
  however, does not include all those files.  Thus, filtering of compholio
  specific files broke.

  Apologies for the issues during the update of i386-wine-devel to 1.7.34.

  PR:		197110

Changes:
  head/emulators/i386-wine-devel/Makefile.inc
  head/emulators/i386-wine-devel/pkg-plist
Comment 6 David Naylor freebsd_committer 2015-01-27 05:12:35 UTC
Hopefully fixed.  Did manage to reproduce the error and fix it, however I did not test all 8 possible permutations (only 2).