Bug 197116 - New port: chinese/ibus-libpinyin
Summary: New port: chinese/ibus-libpinyin
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Xin LI
URL:
Keywords:
Depends on: 197115
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-26 23:44 UTC by Xin LI
Modified: 2015-03-31 21:07 UTC (History)
2 users (show)

See Also:


Attachments
Proposed change. (4.32 KB, application/x-shar)
2015-01-26 23:44 UTC, Xin LI
no flags Details
Proposed change. (4.59 KB, text/plain)
2015-03-19 08:35 UTC, Xin LI
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xin LI freebsd_committer 2015-01-26 23:44:07 UTC
Created attachment 152220 [details]
Proposed change.

This is a port for ibus-libpinyin.

I noticed this was not committed and it was under Henry Hu's maintenance (although I can't find a PR for it) so I have cleaned dust on the port and updated it to the latest version.
Comment 1 Henry Hu 2015-01-26 23:55:25 UTC
If I remember it correctly, the main reason that it's not submitted is because libpinyin is still at an old version.
I planned to update libpinyin, fcitx-libpinyin and ibus-libpinyin. They are mostly ready, but because redports is down I postponed the updates.
I'll check if libpinyin still needs to be updated.
Comment 2 Xin LI freebsd_committer 2015-01-26 23:58:08 UTC
(In reply to Henry Hu from comment #1)
JFYI I have a kludge changeset ( bug 197115 ) which updates libpinyin to 1.0.0.  If you already have better version please feel free to comment and let's use the better version.
Comment 3 Henry Hu 2015-02-07 19:59:42 UTC
Basically, the blocking items were:
ibus-libpinyin 1.6.92
DEPENDS ON libpinyin 1.0.0 (libpinyin >= 0.9.91)
REQUIRES fcitx-libpinyin 0.3.1 (fcitx-libpinyin 0.2.1 does not work with libpinyin 1.0.0)
DEPENDS ON fcitx 4.2.8 (fcitx >= 4.2.8)
REQUIRES fcitx-rime 0.3.0 (fcitx-rime 0.1.2 does not work with fcitx 4.2.8)
DEPENDS ON librime 1.1 (rime >= 1.0.0)
DEPENDS ON yaml-cpp 0.5 (libyaml-cpp >= 0.5)

But yaml-cpp was at 0.3, and it's not compatible with version 0.5.

We didn't realize that yaml-cpp was updated to 0.5 in Sep, 2014. Now the items on the dependency chain should be updated first, and then ibus-libpinyin can be created.

I have another patch which corresponds to ibus-libpinyin 1.4.93 which is the latest version that works with current libpinyin, but I think that it's better to just wait for libpinyin to be updated.
Comment 4 Xin LI freebsd_committer 2015-03-19 08:35:14 UTC
Created attachment 154507 [details]
Proposed change.
Comment 5 commit-hook freebsd_committer 2015-03-31 21:07:34 UTC
A commit references this bug:

Author: delphij
Date: Tue Mar 31 21:06:50 UTC 2015
New revision: 382867
URL: https://svnweb.freebsd.org/changeset/ports/382867

Log:
  Add ibus-libpinyin 1.7.1, intelligent Pinyin engine based on libpinyin
  for IBus.

  This is based on an old version of ibus-libpinyin submitted by Henry
  Hu <henry.hu.sh gmail com> with updates from myself.

  PR:		197116

Changes:
  head/chinese/Makefile
  head/chinese/ibus-libpinyin/
  head/chinese/ibus-libpinyin/Makefile
  head/chinese/ibus-libpinyin/distinfo
  head/chinese/ibus-libpinyin/pkg-descr
  head/chinese/ibus-libpinyin/pkg-plist