Bug 197126 - [new port] audio/lv2 supersedes audio/lv2core
Summary: [new port] audio/lv2 supersedes audio/lv2core
Status: Closed DUPLICATE of bug 213285
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-27 17:01 UTC by Radim Kolar
Modified: 2016-11-05 03:00 UTC (History)
3 users (show)

See Also:


Attachments
Lv2 shar (8.96 KB, text/plain)
2015-01-27 17:01 UTC, Radim Kolar
no flags Details
Lv2 build log (61.17 KB, text/plain)
2015-01-27 17:03 UTC, Radim Kolar
no flags Details
calf poudriere log (328.40 KB, text/plain)
2016-03-29 22:47 UTC, Tobias Brodel
no flags Details
linuxsampler poudriere log (234.24 KB, text/plain)
2016-03-29 22:48 UTC, Tobias Brodel
no flags Details
slv2 poudriere log (27.25 KB, text/plain)
2016-03-29 22:48 UTC, Tobias Brodel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Radim Kolar 2015-01-27 17:01:42 UTC
Created attachment 152261 [details]
Lv2 shar

New version of LV2 plugin API

LV2 is an open standard for audio plugins, used by hundreds of plugins
and other projects. At its core, LV2 is a simple stable interface,
accompanied by extensions which add functionality to support the needs
of increasingly powerful audio software.

WWW: http://lv2plug.in/
Comment 1 Radim Kolar 2015-01-27 17:03:35 UTC
Created attachment 152262 [details]
Lv2 build log
Comment 2 Thomas Zander freebsd_committer 2015-04-06 10:36:11 UTC
LICENSE looks more like ISCL, please double-check.

Also you might want to check the post-patch target in lv2core and reuse those replacements.

CONFLICTS_INSTALL is not needed if this port is really replacing lv2core, because then we would remove lv2core and change dependencies throughout the ports tree.
At the moment, the only dependent ports are:
audio/slv2
audio/calf
audio/linuxsampler

Did you test whether they build and work as expected when using lv2 instead of lv2core?

Thanks in advance.
Comment 3 Tobias Brodel 2016-03-29 22:47:29 UTC
Created attachment 168773 [details]
calf poudriere log
Comment 4 Tobias Brodel 2016-03-29 22:48:08 UTC
Created attachment 168774 [details]
linuxsampler poudriere log
Comment 5 Tobias Brodel 2016-03-29 22:48:37 UTC
Created attachment 168775 [details]
slv2 poudriere log
Comment 6 Tobias Brodel 2016-03-29 22:52:50 UTC
(In reply to Thomas Zander from comment #2)
not the submitter but very interested in this port.

just uploaded poudriere logs for the three dependent ports, all build without complaint against audio/lv2

i can't vouch for their functionality as i'm only familiar with calf. 

audio/lv2 seems like more of an upgrade to audio/lv2core rather than a full replacement. it's the same codebase but pulls in what were previously extensions into the "core" so to speak.
Comment 7 Jan Beich freebsd_committer 2016-10-31 05:35:18 UTC
Bug 213285 has newer version.

*** This bug has been marked as a duplicate of bug 213285 ***
Comment 8 commit-hook freebsd_committer 2016-10-31 20:40:49 UTC
A commit references this bug:

Author: jbeich
Date: Mon Oct 31 20:40:44 UTC 2016
New revision: 425024
URL: https://svnweb.freebsd.org/changeset/ports/425024

Log:
  audio/lv2: add new port

  PR:		197126, 213285 (based on)
  Submitted by:	Radim Kolar <hsn@sendmail.cz>, Michael Beer <beerml@sigma6audio.de>

  LV2 is an open standard for audio plugins, used by hundreds of plugins
  and other projects. At its core, LV2 is a simple stable interface,
  accompanied by extensions which add functionality to support the needs
  of increasingly powerful audio software.

  http://lv2plug.in/

Changes:
  head/audio/Makefile
  head/audio/lv2/
  head/audio/lv2/Makefile
  head/audio/lv2/distinfo
  head/audio/lv2/files/
  head/audio/lv2/files/patch-pkgconf
  head/audio/lv2/pkg-descr
  head/audio/lv2/pkg-plist
  head/audio/lv2core/Makefile
Comment 9 commit-hook freebsd_committer 2016-11-05 01:19:57 UTC
A commit references this bug:

Author: jbeich
Date: Sat Nov  5 01:19:47 UTC 2016
New revision: 425367
URL: https://svnweb.freebsd.org/changeset/ports/425367

Log:
  audio/lv2core: deprecate in favor of audio/lv2

  - Switch existing consumers to audio/lv2

  PR:		197126, 213285 (for tracking)

Changes:
  head/audio/calf/Makefile
  head/audio/linuxsampler/Makefile
  head/audio/linuxsampler/pkg-plist
  head/audio/lv2core/Makefile
  head/audio/slv2/Makefile
Comment 10 commit-hook freebsd_committer 2016-11-05 03:00:05 UTC
A commit references this bug:

Author: jbeich
Date: Sat Nov  5 02:59:29 UTC 2016
New revision: 425373
URL: https://svnweb.freebsd.org/changeset/ports/425373

Log:
  audio/lv2core: deprecate in favor of audio/lv2 (try#2)

  - Switch existing consumers to audio/lv2

  PR:		197126, 213285 (for tracking)

Changes:
  head/audio/calf/Makefile
  head/audio/linuxsampler/Makefile
  head/audio/lv2core/Makefile
  head/audio/slv2/Makefile