Bug 197168 - bce driver failing on 10.1p5, no reason...
Summary: bce driver failing on 10.1p5, no reason...
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-29 10:12 UTC by llevier
Modified: 2015-03-09 17:05 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description llevier 2015-01-29 10:12:13 UTC
Hi Guys,

My server runs prod on 10.1p3, kernel is specific, defined into a file I use each time (no update).

Recently I updated the OS, make buildworkd, kernel, installworld etc

I was:
FreeBSD Cquad 10.1-RELEASE-p3 FreeBSD 10.1-RELEASE-p3 #0: Fri Jan  2 01:10:12 CET 2015     root@:/usr/obj/usr/src/sys/Cquad  amd64
and moved to:
Jan 29 10:02:57 Cquad kernel: FreeBSD 10.1-RELEASE-p5 #0: Thu Jan 29 09:43:35 CET 201
5

For unknown reason, the bce driver fails on p5. ifconfig is fine but no packet passing... Nothing visible, nothing weird, just no packet passing by.

Some inputs from new kernel:
Jan 29 10:02:57 Cquad kernel: bce0: <QLogic NetXtreme II BCM5708 1000Base-SX (B2)> mem 0xdc000000-0xddffffff irq 17 at device 0.0 on pci4
Jan 29 10:02:57 Cquad kernel: bce0: /usr/src/sys/dev/bce/if_bce.c(1247): Management firmware enabled but not running!
Jan 29 10:02:57 Cquad kernel: brgphy0: <BCM5708S 1000/2500baseSX PHY> PHY 2 on miibus0
Jan 29 10:02:57 Cquad kernel: brgphy0:  1000baseSX-FDX, auto-neg workaround, auto
Jan 29 10:02:57 Cquad kernel: bce0: Ethernet address: 00:21:5e:20:19:b8
Jan 29 10:02:57 Cquad kernel: bce0: ASIC (0x57081021); Rev (B2); Bus (PCI-X, 64-bit,133MHz); B/C (3.4.4); Bufs (RX:2;TX:2;PG:8); Flags (SPLT|MSI|MFW); MFW (NOT RUNNING!)
Jan 29 10:02:57 Cquad kernel: bce0: Gigabit link up!
Jan 29 10:08:19 Cquad kernel: bce0: promiscuous mode enabled
Jan 29 10:09:16 Cquad kernel: bce0: promiscuous mode disabled

Now from old (working) kernel, I restored it:
Jan 29 10:33:30 Cquad kernel: bce0: <QLogic NetXtreme II BCM5708 1000Base-SX (B2)> me
m 0xdc000000-0xddffffff irq 17 at device 0.0 on pci4
Jan 29 10:33:30 Cquad kernel: bce0: /usr/src/sys/dev/bce/if_bce.c(1247): Management firmware enabled but not running!
Jan 29 10:33:30 Cquad kernel: brgphy0: <BCM5708S 1000/2500baseSX PHY> PHY 2 on miibus0
Jan 29 10:33:30 Cquad kernel: brgphy0:  1000baseSX-FDX, auto-neg workaround, auto
Jan 29 10:33:30 Cquad kernel: bce0: Ethernet address: 00:21:5e:20:19:b8
Jan 29 10:33:30 Cquad kernel: bce0: ASIC (0x57081021); Rev (B2); Bus (PCI-X, 64-bit,133MHz); B/C (3.4.4); Bufs (RX:2;TX:2;PG:8); Flags (SPLT|MSI|MFW); MFW (NOT RUNNING!)
Jan 29 10:33:30 Cquad kernel: bce0: Gigabit link up!
Jan 29 10:33:42 Cquad kernel: bce0: /usr/src/sys/dev/bce/if_bce.c(7869): Watchdog timeout occurred, resetting!
Jan 29 10:33:42 Cquad kernel: bce0: link state changed to DOWN
Jan 29 10:33:42 Cquad kernel: bce0:
Jan 29 10:33:42 Cquad kernel: bce0: link state changed to UP
Jan 29 10:33:42 Cquad kernel: Gigabit link up!
Jan 29 10:33:42 Cquad devd: Executing '/etc/rc.d/dhclient quietstart bce0'

Nota : 
- bce0 exists also as bce1 (not used).
- Platform is IBM Blade HS21 XM (Type 7995)
Comment 1 John Baldwin freebsd_committer freebsd_triage 2015-03-09 17:05:20 UTC
If you use ifconfig to down/up the interface post boot, does that "fix" it?