Bug 197359 - devel/critcl -- abolish DOCS-option, install man-pages instead
Summary: devel/critcl -- abolish DOCS-option, install man-pages instead
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikhail Teterin
URL:
Keywords:
: 197358 (view as bug list)
Depends on:
Blocks: 195863
  Show dependency treegraph
 
Reported: 2015-02-06 06:42 UTC by Mikhail Teterin
Modified: 2015-02-08 23:13 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (tcltk)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Teterin freebsd_committer 2015-02-06 06:42:38 UTC
Upstream's tarball includes up-to-date man-pages. These should be installed -- unconditionally.

The generated HTML-documentation is largely redundant and not useful -- once you reached for the browser, you may as well read the latest version online.

Not rebuilding the docs in this particular case is also useful for a different reason: it removes the dependency on dtplite (from devel/tcllib), which will allow tcllib depend on critcl instead and compile C-code included with tcllib (see Bug 195863).
Comment 1 Bugzilla Automation freebsd_committer 2015-02-06 06:42:38 UTC
Auto-assigned to maintainer tcltk@FreeBSD.org
Comment 2 Mikhail Teterin freebsd_committer 2015-02-06 06:45:56 UTC
*** Bug 197358 has been marked as a duplicate of this bug. ***
Comment 3 Mikhail T. 2015-02-06 23:19:31 UTC
gahr@, does reassigning the ticket to me imply, you trust my judgement on this one?
Comment 4 Pietro Cerutti freebsd_committer 2015-02-08 17:01:36 UTC
mi@, of course I do, given that you've got quite some background on Tcl/Tk ports. Also, since I've been handling most Tcl/Tk stuff myself lately, assigning this to you explicitly was also a mean to say "I'm quite busy right now, please do as you think it's best". Sorry for not being clear enough.
Comment 5 commit-hook freebsd_committer 2015-02-08 23:13:01 UTC
A commit references this bug:

Author: mi
Date: Sun Feb  8 23:12:44 UTC 2015
New revision: 378703
URL: https://svnweb.freebsd.org/changeset/ports/378703

Log:
  Install bundled man-pages.

  Remove the DOCS-option -- there is nothing in the HTML-documentation, that
  man-pages do not contain, but regenerating the docs required dtplite.

  PR:		197359
  Submitted by:	mi
  Approved by:	gahr	(blanket)
  Sponsored by:	http://sybpipe.com/

Changes:
  head/devel/critcl/Makefile
  head/devel/critcl/pkg-plist