Bug 197597 - [MAINTAINER] sysutils/py-salt: Update to 2014.7.2
Summary: [MAINTAINER] sysutils/py-salt: Update to 2014.7.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Frederic Culot
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-02-13 16:23 UTC by Christer Edwards
Modified: 2015-02-20 20:03 UTC (History)
2 users (show)

See Also:


Attachments
patch (1.55 KB, text/plain)
2015-02-13 16:23 UTC, Christer Edwards
koobs: maintainer-approval+
Details
QA (290.32 KB, text/plain)
2015-02-13 16:23 UTC, Christer Edwards
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christer Edwards 2015-02-13 16:23:02 UTC
Created attachment 152941 [details]
patch

maintainer update : sysutils/py-salt. The attached patch upgrades from 2014.7.1 (pending commit) to 2014.7.2.

Please let me know if there are any questions.
Comment 1 Christer Edwards 2015-02-13 16:23:23 UTC
Created attachment 152942 [details]
QA
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 02:57:26 UTC
Thanks Christer, does this deprecate bug 197061?

If so please close
Comment 3 Christer Edwards 2015-02-16 03:21:23 UTC
This does deprecate bug 197061, however this patch is generated against the submitted patch in bug 197061. I don't think that it'll apply cleanly against 2014.7.0 (current in ports).

If you'd like me to generate a new patch against what is currently in the ports tree I can, and also deprecate the patch in this ticket. Or you can commit the patch in bug 197061 and then apply this patch and we'll be caught up with upstream.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 03:37:14 UTC
Since we already have two open issues you may decide which way you want to go:

- Close this issue, duplicate of bug 197061, replace patch there with latest
- Close bug 197061, superseded by bug 197597, replace patch here with one against head

While it might have been 'technically' correct to have this bug "Depend on" bug 197061, its also confusing, complicated, and more work than is necessary for everyone.

Standlone, isolated patches against head (ie, not patches to patches, especially in separate issues) are the way to go in all circumstances.
Comment 5 commit-hook freebsd_committer 2015-02-16 14:15:26 UTC
A commit references this bug:

Author: culot
Date: Mon Feb 16 14:15:17 UTC 2015
New revision: 379093
URL: https://svnweb.freebsd.org/changeset/ports/379093

Log:
  - Update to 2014.7.2

  PR:		197597
  Submitted by:	Christer Edwards <christer.edwards@gmail.com> (maintainer)

Changes:
  head/sysutils/py-salt/Makefile
  head/sysutils/py-salt/distinfo
  head/sysutils/py-salt/files/patch-salt__grains__core.py
  head/sysutils/py-salt/files/patch-setup.py
  head/sysutils/py-salt/pkg-plist
Comment 6 Andres Montalban 2015-02-20 20:03:42 UTC
Hey guys,

I have just installed this port on a fresh system and I get this:

root@freebsd-10:~ # salt-call 
Traceback (most recent call last):
  File "/usr/local/bin/salt-call", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 2876, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 449, in _build_master
    ws.require(__requires__)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 745, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 639, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: salt==2014.7.0

----

root@freebsd-10:~ # cat /usr/local/bin/salt-call
#!/usr/local/bin/python2.7
# EASY-INSTALL-ENTRY-SCRIPT: 'salt==2014.7.0','console_scripts','salt-call'
__requires__ = 'salt==2014.7.0'
import sys
from pkg_resources import load_entry_point

if __name__ == '__main__':
    sys.exit(
        load_entry_point('salt==2014.7.0', 'console_scripts', 'salt-call')()
    )

----

If I reinstall the same package it works and the content of /usr/local/bin/salt-call is:

root@freebsd-10:~ # cat /usr/local/bin/salt-call
#!/usr/local/bin/python2.7
# EASY-INSTALL-ENTRY-SCRIPT: 'salt==2014.7.2','console_scripts','salt-call'
__requires__ = 'salt==2014.7.2'
import sys
from pkg_resources import load_entry_point

if __name__ == '__main__':
    sys.exit(
        load_entry_point('salt==2014.7.2', 'console_scripts', 'salt-call')()
    )

----

What can be wrokg?