Bug 197624 - [patch] multimedia/libvpx : fix build on gcc-5 (probably gcc 4.9 too)
Summary: [patch] multimedia/libvpx : fix build on gcc-5 (probably gcc 4.9 too)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ashish SHUKLA
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-14 10:52 UTC by John Marino
Modified: 2015-02-15 14:14 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ashish)


Attachments
Patch to avoid clash on max_align_t name (787 bytes, patch)
2015-02-14 10:52 UTC, John Marino
no flags Details | Diff
same patch (1.00 KB, patch)
2015-02-14 10:59 UTC, John Marino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Marino freebsd_committer 2015-02-14 10:52:38 UTC
Created attachment 152964 [details]
Patch to avoid clash on max_align_t name

libvpx will not build on current GCC because it defines max_align_t, the same type needed for C11.  Apparently Debian has also discovered this.

The attached patch will allow it to build on gcc-5.

The patch came from DragonFly user "zrj"
Comment 1 Bugzilla Automation freebsd_committer 2015-02-14 10:52:38 UTC
Auto-assigned to maintainer ashish@FreeBSD.org
Comment 2 John Marino freebsd_committer 2015-02-14 10:59:34 UTC
Created attachment 152965 [details]
same patch

This is the same patch, but it applies directly to the port
Comment 3 Ashish SHUKLA freebsd_committer 2015-02-15 07:03:17 UTC
(In reply to John Marino from comment #0)

> libvpx will not build on current GCC because it defines max_align_t, the same type needed for C11.  Apparently Debian has also discovered this.

> The attached patch will allow it to build on gcc-5.

> The patch came from DragonFly user "zrj"

I can confirm the diff fixes the build. Should I be crediting "DragonFly BSD" for this ?

Thanks,
Ashish
Comment 4 John Marino freebsd_committer 2015-02-15 07:57:04 UTC
you don't need to do anything special.

"PR: 197624" is minimal line.
"submitted by: marino@" is optional (usually done)


That's it, just standard accreditation.

Thanks!
Comment 5 commit-hook freebsd_committer 2015-02-15 14:13:02 UTC
A commit references this bug:

Author: ashish
Date: Sun Feb 15 14:12:20 UTC 2015
New revision: 379037
URL: https://svnweb.freebsd.org/changeset/ports/379037

Log:
  - Fix build with GCC 5

  PR:		197624
  Submitted by:	marino

Changes:
  head/multimedia/libvpx/files/patch-nestegg_halloc_src
Comment 6 Ashish SHUKLA freebsd_committer 2015-02-15 14:14:10 UTC
Committed.

Thanks!