Bug 197699 - mail/mutt: regression due to switch to base iconv
Summary: mail/mutt: regression due to switch to base iconv
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Thomas Quinot
URL:
Keywords: patch, patch-ready, regression
Depends on:
Blocks:
 
Reported: 2015-02-16 08:42 UTC by Thomas Quinot
Modified: 2015-04-03 15:57 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments
patch (329 bytes, patch)
2015-02-16 08:42 UTC, Thomas Quinot
koobs: maintainer-approval+
Details | Diff
maintainer patch (358 bytes, text/plain)
2015-02-16 09:53 UTC, Udo.Schweigert
Udo.Schweigert: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Quinot freebsd_committer 2015-02-16 08:42:40 UTC
Created attachment 153026 [details]
patch

The switch to the FreeBSD iconv implementation is a regression for all users whose configuration depended on GNU extensions, e.g.:

set charset=//TRANSLIT

To preserve compatibility with previous releases, I suggest reverting to GNU iconv.
Comment 1 Bugzilla Automation freebsd_committer 2015-02-16 08:42:40 UTC
Maintainer CC'd
Comment 2 Udo.Schweigert 2015-02-16 09:36:12 UTC
Approved.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 09:46:17 UTC
Reporter is committer
Comment 4 Udo.Schweigert 2015-02-16 09:53:07 UTC
Created attachment 153030 [details]
maintainer patch

Patch to take care of the mutt-lite port
Comment 5 Udo.Schweigert 2015-02-16 09:55:01 UTC
Sorry, I just realized that we also have to take care of the -lite variant of the port not to install GNU libiconv from the ports as a dependency. The maintainer-patch takes care of that.

Udo (maintainer)
Comment 6 Thomas Quinot freebsd_committer 2015-02-16 10:20:11 UTC
Thanks for your fast answer Udo! Indeed I missed the -lite part. Your patch looks fine to me.
Comment 7 Thomas Quinot freebsd_committer 2015-04-03 12:04:29 UTC
I confirm that the maintainer's patch works for me.
Comment 8 Thomas Quinot freebsd_committer 2015-04-03 12:13:06 UTC
Ah, but this does not make much sense since there is no ICONV option in LITE mode anyway???
Comment 9 Udo.Schweigert 2015-04-03 14:24:45 UTC
After again looking into it: you're right. Although my patch also would work your original patch works too and is simpler.
Comment 10 commit-hook freebsd_committer 2015-04-03 15:36:10 UTC
A commit references this bug:

Author: thomas
Date: Fri Apr  3 15:35:30 UTC 2015
New revision: 383136
URL: https://svnweb.freebsd.org/changeset/ports/383136

Log:
  Add "translit" ARG to USES=iconv so that the full port still
  uses GNU iconv (not the system iconv): users may rely on
  being able to set charset=//TRANSLIT

  PR:		197699
  Differential Revision:	D2218
  Approved by:	maintainer (Udo.Schweigert@siemens.com), portmgr (mat), roberto

Changes:
  head/mail/mutt/Makefile
Comment 11 Thomas Quinot freebsd_committer 2015-04-03 15:37:33 UTC
Initial patch committed.
Comment 12 commit-hook freebsd_committer 2015-04-03 15:57:18 UTC
A commit references this bug:

Author: thomas
Date: Fri Apr  3 15:56:58 UTC 2015
New revision: 383141
URL: https://svnweb.freebsd.org/changeset/ports/383141

Log:
  Previous change introduces a new dependency, so bump PORTREVISION

  PR:             197699
  Differential Revision:  D2218
  Approved by:    portmgr (mat)

Changes:
  head/mail/mutt/Makefile