Bug 197708 - Allocation of PCI resources failed with options NEW_PCIB
Summary: Allocation of PCI resources failed with options NEW_PCIB
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-RELEASE
Hardware: i386 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-02-16 16:20 UTC by ken73.chen
Modified: 2016-12-10 15:34 UTC (History)
1 user (show)

See Also:


Attachments
dmesg, devinfo, pciconf output when with options NEW_PCIB (97.75 KB, text/plain)
2015-02-16 16:20 UTC, ken73.chen
no flags Details
dmesg, devinfo, pciconf output when with nooptions NEW_PCIB (91.33 KB, text/plain)
2015-02-16 16:24 UTC, ken73.chen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ken73.chen 2015-02-16 16:20:06 UTC
Created attachment 153039 [details]
dmesg, devinfo, pciconf output when with options NEW_PCIB

After an old server upgrading from 8.4 to 10.1, em0/em1 and ahc0/ahc1 can not work with GENERAL server because 'can't allocate register resources'.

'hint.agp.0.disabled=1' and 'hw.pci.realloc_bars=1' are not helpful for my server.

After add 'nooptions	NEW_PCIB' to new kernel, em0/em1 and ahc0/ahc1 both come back.

I attach dmesg, devinfo and pciconf output.
Comment 1 ken73.chen 2015-02-16 16:24:07 UTC
Created attachment 153040 [details]
dmesg, devinfo, pciconf output when with nooptions NEW_PCIB
Comment 2 silicium 2016-12-10 15:34:32 UTC
After installing 10.3 on a FSC Futro S-550 thin client to work as a router, network cards in the PCI riser slot were not detected until NEW_PCIB was found in /sys/amd64/conf/DEFAULTS and commented out.