Bug 197828 - [update] emulators/pipelight to 2.8
Summary: [update] emulators/pipelight to 2.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kurt Jaeger
URL:
Keywords:
: 197223 199253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-19 18:16 UTC by sasamotikomi
Modified: 2015-08-02 17:33 UTC (History)
5 users (show)

See Also:


Attachments
Makefile (804 bytes, patch)
2015-02-19 18:16 UTC, sasamotikomi
no flags Details | Diff
distinfo (985 bytes, patch)
2015-02-19 18:20 UTC, sasamotikomi
no flags Details | Diff
patch-Makefile (1.67 KB, patch)
2015-02-19 18:21 UTC, sasamotikomi
no flags Details | Diff
update to 2.8.1 (4.95 KB, patch)
2015-05-06 19:41 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description sasamotikomi 2015-02-19 18:16:27 UTC
Created attachment 153184 [details]
Makefile

I recommended update right now, shipped version isn't last.
# pipelight-plugin --update
If you have problem at first:
# pipelight-plugin --remove-mozilla-plugins
# pipelight-plugin --create-mozilla-plugins
Comment 1 sasamotikomi 2015-02-19 18:20:14 UTC
Created attachment 153185 [details]
distinfo
Comment 2 sasamotikomi 2015-02-19 18:21:11 UTC
Created attachment 153186 [details]
patch-Makefile
Comment 3 sasamotikomi 2015-02-19 18:30:39 UTC
*** Bug 197223 has been marked as a duplicate of this bug. ***
Comment 4 sasamotikomi 2015-03-18 21:35:47 UTC
Unfortunate all not latin input method is broken. I have not idea why but look like wine-compholio bug.
Any not latin input (in all flash chat for example) look like "???????" but you can copy/paste any symbol without troubles.
Maybe it's only problem of my system.
Comment 5 sasamotikomi 2015-04-01 23:14:44 UTC
(In reply to sasamotikomi from comment #4)
I finally found what is issue really is: 
You can't use difference of latine input type in addon before you not change you locale, even if you use utf-8, locale of your user should be same as input: 
en_US-utf-8 -> only latin
??_??-utf-8 -> same as ????
Comment 6 philippe972 2015-04-21 01:20:59 UTC
Hi
I would like update pipelight to 0.2.8 but i ignore how to proceed with the 3 diff files (im a new freebsd french user)
Some help is possible ?
Thanks
Comment 7 sasamotikomi 2015-04-21 12:51:15 UTC
(In reply to philippe972 from comment #6)
# cd /usr/ports/emulators/pipelight
# patch < /path/to/Makefile.diff
# patch < /path/to/distinfo.diff
# cd files
# patch < /path/to/patch-Makefile.diff

/patch/to/ mean where is file is located,  # - mean root

or you can edit handle use vi or ee (if you never use vi) - mean removed string + mean added string, you can copy-paste by pressing middle mouse button "scroll wheel":
# cd /usr/ports/emulators/pipelight
# ee Makefile
# ee distinfo
# cd files
# ee patch-Makefile
Comment 8 philippe972 2015-04-22 21:46:09 UTC
(In reply to sasamotikomi from comment #7)
First of all, thanks for your explanations.
But i encounter 2 problems : look the outputs below

1) patch Makefile :
filip@freeBSD:/usr/ports/emulators/pipelight$sudo patch < ~/Downloads/Makefile.diff 
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- /tmp/Makefile	2015-02-19 20:51:04.000000000 +0000
|+++ Makefile	2015-02-19 18:56:56.000000000 +0000
--------------------------
Patching file Makefile using Plan A...
Hunk #1 failed at 1.
Hunk #2 failed at 27.
2 out of 2 hunks failed--saving rejects to Makefile.rej
done

It seems the patch fail, what is the problem ?

2) patch patch-Makefile : 
filip@freeBSD:/usr/ports/emulators/pipelight/files$sudo patch < ~/Downloads/patch-Makefile.diff 
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- /tmp/patch-Makefile	2015-02-19 20:52:43.000000000 +0000
|+++ patch-Makefile	2015-02-19 20:10:53.000000000 +0000
--------------------------
File to patch: 

filip@freeBSD:/usr/ports/emulators/pipelight/files$ls
pipelight-mkufs.in

I ignore what file to patch ?
Comment 9 sasamotikomi 2015-04-24 09:21:33 UTC
Comment on attachment 153184 [details]
Makefile

>--- Makefile	2015-02-19 20:51:04.000000000 +0000
>+++ Makefile	2015-02-19 18:56:56.000000000 +0000
>@@ -1,9 +1,8 @@
> # Created by: Kris Moore <kmoore@FreeBSD.org>
>-# $FreeBSD$
>+# $FreeBSD: head/emulators/pipelight/Makefile 376990 2015-01-14 01:25:55Z swills $
> 
> PORTNAME=	pipelight
>-DISTVERSION=	0.2.7.3
>-PORTREVISION=	7
>+DISTVERSION=	0.2.8
> CATEGORIES=	emulators
> MASTER_SITES=	https://bitbucket.org/mmueller2012/pipelight/get/ \
> 		http://repos.fds-team.de/pluginloader/v${DISTVERSION}/:plg
>@@ -28,7 +27,7 @@
> 		${LOCALBASE}/bin/flock:${PORTSDIR}/sysutils/flock \
> 		${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
> 
>-WRKSRC=		${WRKDIR}/mmueller2012-pipelight-79b1b7ba0032
>+WRKSRC=		${WRKDIR}/mmueller2012-pipelight-b7b5e5471d52
> USE_GCC=	yes
> USE_LDCONFIG=	yes
> CPPFLAGS+=	-I${LOCALBASE}/include
Comment 10 sasamotikomi 2015-04-24 09:23:15 UTC
Comment on attachment 153185 [details]
distinfo

>--- distinfo	2015-02-19 20:51:47.000000000 +0000
>+++ distinfo	2015-02-19 19:09:25.000000000 +0000
>@@ -1,6 +1,6 @@
>-SHA256 (pipelight/v0.2.7.3.tar.gz) = db4585f44874c0b647e7cf611b5bf8efe308fe11573891cd74dd4fa5867e2e52
>-SIZE (pipelight/v0.2.7.3.tar.gz) = 161967
>-SHA256 (pipelight/pluginloader.tar.gz) = 015c6b73accb5319b5006b208dfea9b7c768f84faf40bb80676312a650967e6a
>-SIZE (pipelight/pluginloader.tar.gz) = 423396
>-SHA256 (pipelight/pluginloader.tar.gz.sig) = 66c08ab5b6105e8fe2fb1f604d0958e264e2796ac2310dd19827736c1aa8e816
>+SHA256 (pipelight/v0.2.8.tar.gz) = ae543d6eb95b3f681bf5807de63208e42c3be2ada1d2661017ad3a215c0684c4
>+SIZE (pipelight/v0.2.8.tar.gz) = 153492
>+SHA256 (pipelight/pluginloader.tar.gz) = d693e544149a29444ca10629bf00dc65cbfe671327d7518799cdda1e157cf775
>+SIZE (pipelight/pluginloader.tar.gz) = 808906
>+SHA256 (pipelight/pluginloader.tar.gz.sig) = 9e9283c711d83b9c205b685ccf330c85bbfd55c117503e1c2f978ae5be47102c
> SIZE (pipelight/pluginloader.tar.gz.sig) = 543
Comment 11 sasamotikomi 2015-04-24 09:23:49 UTC
Comment on attachment 153186 [details]
patch-Makefile

>--- patch-Makefile	2015-02-19 20:52:43.000000000 +0000
>+++ patch-Makefile	2015-02-19 20:10:53.000000000 +0000
>@@ -1,17 +1,17 @@
>---- Makefile.orig	2015-01-13 14:39:12 UTC
>-+++ Makefile
>-@@ -69,12 +69,12 @@ linux: config.make
>+--- Makefile.orig	2015-02-19 20:04:44.000000000 +0000
>++++ Makefile	2015-02-19 20:05:50.000000000 +0000
>+@@ -71,12 +71,12 @@
>  
>  .PHONY: prebuilt32
>  prebuilt32: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
> -	$(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
> +	$(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" pluginloader-$(git_commit).tar.gz
>- 	tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader.exe src/winecheck/winecheck.exe
>+ 	tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader.exe src/windows/winecheck/winecheck.exe
>  
>  .PHONY: prebuilt64
>  prebuilt64: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
> -	$(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
> +	$(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" pluginloader-$(git_commit).tar.gz
>- 	tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader64.exe src/winecheck/winecheck64.exe
>+ 	tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader64.exe src/windows/winecheck/winecheck64.exe
>  
>- .PHONY: pluginloader32
>+ .PHONY: windows32
Comment 12 sasamotikomi 2015-04-24 09:45:07 UTC
(In reply to philippe972 from comment #8)
It's because my originally file located in /tmp you need remove prefix or use updated diff, also you forgot distinfo.
Comment 13 Kurt Jaeger freebsd_committer 2015-05-06 19:36:07 UTC
*** Bug 199253 has been marked as a duplicate of this bug. ***
Comment 14 Kurt Jaeger freebsd_committer 2015-05-06 19:41:01 UTC
Created attachment 156441 [details]
update to 2.8.1

poudriere build for 10.1a, 9.3a see

http://people.freebsd.org/~pi/logs/emulators__pipelight-10x-1430890261.txt
http://people.freebsd.org/~pi/logs/emulators__pipelight-93a-1430890261.txt

8.4i failed, because dependency emulators/wine-compholio failed to build.
(i386 jail on amd64 host, maybe that was the cause)
Comment 15 commit-hook freebsd_committer 2015-05-06 19:48:43 UTC
A commit references this bug:

Author: pi
Date: Wed May  6 19:48:22 UTC 2015
New revision: 385551
URL: https://svnweb.freebsd.org/changeset/ports/385551

Log:
  emulators/pipelight: 2.7.3 -> 2.8.1

  Changes:
  http://pipelight.net/cms/articles/2014-12/release-v0-2-8.html
  and
  https://bitbucket.org/mmueller2012/pipelight/raw/master/debian/changelog

  PR:		197828
  Submitted by:	sasamotikomi@gmail.com
  Reviewed by:	philippe.r972@gmail.com

Changes:
  head/emulators/pipelight/Makefile
  head/emulators/pipelight/distinfo
  head/emulators/pipelight/files/patch-Makefile
  head/emulators/pipelight/pkg-descr
Comment 16 Kurt Jaeger freebsd_committer 2015-08-02 17:33:02 UTC
8.x is no longer supported, so this bug can be closed.