Bug 197877 - math/maxima install 5.35.1 as ports
Summary: math/maxima install 5.35.1 as ports
Status: Closed DUPLICATE of bug 204939
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-21 12:07 UTC by satosi.kimura
Modified: 2016-02-07 17:57 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bf)


Attachments
new Makefile (3.43 KB, text/plain)
2015-02-21 12:12 UTC, satosi.kimura
no flags Details
new distinfo (136 bytes, text/plain)
2015-02-21 12:13 UTC, satosi.kimura
no flags Details
new patch-doc_info_Makefile.in (883 bytes, text/plain)
2015-02-21 12:14 UTC, satosi.kimura
no flags Details
new pkg-plist (115.12 KB, text/plain)
2015-02-21 12:15 UTC, satosi.kimura
no flags Details
modified pkg-plist (108.89 KB, text/plain)
2015-03-14 18:33 UTC, satosi.kimura
no flags Details
modified Makefile (3.33 KB, text/plain)
2015-03-23 16:18 UTC, satosi.kimura
no flags Details
log of poudriere (112.52 KB, application/gzip)
2015-03-23 16:30 UTC, satosi.kimura
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description satosi.kimura 2015-02-21 12:07:23 UTC
I can install latest maxima (5.35.1) to FreeBSD/amd64 9.3.
(date of ports.tar.gz is 2014.11.28.)


(1) download source of maxima
# fetch http://sourceforge.net/projects/maxima/files/Maxima-source/maxima-5.35.1.tar.gz
# cp maxima-5.35.1.tar.gz /usr/ports/distfiles

(2) make by ports
    # /usr/ports/math
# cp -pR maxima maxima.orig
# cd maxima

replace following files by uploaded files.
Makefile
distinfo
pkg-plist
files/patch-doc_info_Makefile.in

# make
# make install
Comment 1 Bugzilla Automation freebsd_committer 2015-02-21 12:07:23 UTC
Auto-assigned to maintainer bf@FreeBSD.org
Comment 2 satosi.kimura 2015-02-21 12:12:35 UTC
Created attachment 153267 [details]
new Makefile

new makefile for math/maxima
Comment 3 satosi.kimura 2015-02-21 12:13:45 UTC
Created attachment 153268 [details]
new distinfo

new distinfo for math/maxima
Comment 4 satosi.kimura 2015-02-21 12:14:43 UTC
Created attachment 153269 [details]
new patch-doc_info_Makefile.in

new patch-doc_info_Makefile.in for math/maxima/files
Comment 5 satosi.kimura 2015-02-21 12:15:44 UTC
Created attachment 153270 [details]
new pkg-plist

new pkg-plist for math/maxima
Comment 6 satosi.kimura 2015-03-14 18:33:21 UTC
Created attachment 154304 [details]
modified pkg-plist

 Sorry, I made mistake on pkg-plist. So I upload modified one.
Modifications are as follows:
(1) Add "man/man1/maxima.1.gz" and
(2) Delete all "@dirrm".
Comment 7 satosi.kimura 2015-03-23 16:18:06 UTC
Created attachment 154707 [details]
modified Makefile

Output of portlint for modified Makefile is as follows:

# portlint
looks fine.
Comment 8 satosi.kimura 2015-03-23 16:30:29 UTC
Created attachment 154708 [details]
log of poudriere

 It is the log of following operation.
# poudriere testport -j 93Ramd64 -o math/maxima

 Since the size of maxima-5.35.1_1.log is 1174 KB, i.e. over 1000 KB,
I upload its compression by gzip. Please decompress as follows:

% gzip -d maxima-5.35.1_1.log.gz

 I select sbcl (version 1.2.9) as LISP.
Comment 9 Brendan Fabeny freebsd_committer 2015-04-18 14:33:34 UTC
I will submit an update to  5.36.0 soon.
Comment 10 satosi.kimura 2015-04-20 08:23:25 UTC
(In reply to Brendan Fabeny from comment #9)
 I have a quaestion. Do you have any tool to create the file pkg-plist?
I use hand-made tool to do this work, which was made in the process of
installation maxima 5.35.1. If you are interested in it, I'll upload.

(At that time, /usr/ports/Tools/scripts/plist did not work. and now
 this script is missing in the directory.)
Comment 11 Kurt Jaeger freebsd_committer 2016-02-07 17:57:15 UTC
Update was covered in recent update to 5.37.3.

*** This bug has been marked as a duplicate of bug 204939 ***
Comment 12 Kurt Jaeger freebsd_committer 2016-02-07 17:57:53 UTC
(In reply to satosi.kimura from comment #10)

The tool is

make make-plist