Bug 197889 - editors/calligra fails when default version of GCC is 4.9 (or higher): /usr/local/lib/libIlmImf.so: undefined reference to `std::__throw_out_of_range_fmt(char const*, ...)@GLIBCXX_3.4.20'
Summary: editors/calligra fails when default version of GCC is 4.9 (or higher): /usr/l...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks: 196712
  Show dependency treegraph
 
Reported: 2015-02-22 01:04 UTC by Gerald Pfeifer
Modified: 2015-04-09 19:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2015-02-22 01:04:51 UTC
This is related to PR 196712 and blocks updating the default version of
GCC from 4.8 to 4.9.

Here is a build log, apparently the problem only happens on FreeBSD 9.x,
and not 10.x:

http://package18.nyi.freebsd.org/data/93i386-default-PR196712/2015-01-18_16h49m19s/logs/errors/calligra-2.7.5_14.log

To me it appears the problem is that calligra pulls in graphics/OpenEXR
which uses GCC in some cases, and now clang++ is trying to link bits 
prepared by two different compilers.  (Cf. PR 196853 for another case.)

/usr/bin/clang++   -O2 -pipe -fno-strict-aliasing -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage -O2 -DNDEBUG -DQT_NO_DEBUG   -L/usr/local/lib CMakeFiles/calligraauthor.dir/calligraauthor_dummy.cpp.o  -o calligraauthor  ../../lib/libkdeinit4_calligraauthor.so ../../lib/libkomain.so.12.0.0 /usr/local/lib/libkactivities.so.6.2.0 ../../lib/libkowidgets.so.12.0.0 /usr/local/lib/libkparts.so.4.14.2 ../../lib/libkotext.so.12.0.0 ../../lib/libflake.so.12.0.0 ../../lib/libpigmentcms.so.12.0.0 ../../lib/libkoplugin.so.12.0.0 /usr/local/lib/libImath.so /usr/local/lib/libIlmImf.so /usr/local/lib/libIex.so /usr/local/lib/libHalf.so /usr/local/lib/libIlmThread.so ../../lib/libkowidgetutils.so.12.0.0 ../../lib/libkoodf.so.12.0.0 /usr/local/lib/libkio.so.5.14.2 /usr/local/lib/libnepomukutils.so.4.14.2 /usr/local/lib/qt4/libQtXml.so /usr/local/lib/qt4/libQtNetwork.so /usr/local/lib/libnepomuk.so.4.14.2 /usr/local/lib/libsoprano.so ../../lib/libkundo2.so.12.0.0 /usr/local/lib/libkdeui.so.5.14.2 /usr/local/lib/qt4/libQtGui.so /usr/local/lib/qt4/libQtSvg.so /usr/local/lib/libkdecore.so.5.14.2 /usr/local/lib/qt4/libQtDBus.so /usr/local/lib/qt4/libQtCore.so -pthread -Wl,-rpath,/wrkdirs/usr/ports/editors/calligra/work/.build/lib:/usr/local/lib:/usr/local/lib/qt4: -Wl,-rpath-link,/usr/local/lib:/wrkdirs/usr/ports/editors/calligra/work/.build/lib 
/usr/local/lib/libIlmImf.so: undefined reference to `std::__throw_out_of_range_fmt(char const*, ...)@GLIBCXX_3.4.20'
clang++: error: linker command failed with exit code 1 (use -v to see invocation)
*** [words/part/calligraauthor] Error code 1
Comment 1 Bugzilla Automation freebsd_committer 2015-02-22 01:04:51 UTC
Auto-assigned to maintainer kde@FreeBSD.org
Comment 2 Gerald Pfeifer freebsd_committer 2015-04-09 19:02:15 UTC
OpenEXR no longer employes USE_GCC=yes, so this issue should be
resolved without changes to editors/calligra.