Bug 197946 - graphics/colord: the service doesn't start after a fresh install
Summary: graphics/colord: the service doesn't start after a fresh install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Koop Mast
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-23 10:05 UTC by f0andrey
Modified: 2015-04-12 10:17 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (dumbbell)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description f0andrey 2015-02-23 10:05:52 UTC
Option COLORD=on on the default
After start darktable /var/log/messages have flood this messages

Feb 23 12:31:27 x220 dbus[848]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 23 12:31:27 x220 dbus[848]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1
Feb 23 12:31:27 x220 dbus[848]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 23 12:31:27 x220 dbus[848]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1
Feb 23 12:31:31 x220 dbus[848]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 23 12:31:31 x220 dbus[848]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1
Feb 23 12:32:08 x220 dbus[848]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 23 12:32:08 x220 dbus[848]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1

% grep "org.freedesktop.ColorManager" /var/log/messages | wc -l
     286
Comment 1 Bugzilla Automation freebsd_committer 2015-02-23 10:05:52 UTC
Auto-assigned to maintainer dumbbell@FreeBSD.org
Comment 2 Carlos J Puga Medina 2015-02-27 21:47:09 UTC
Same problem here:

Feb 27 22:33:01 box dbus[887]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 27 22:33:01 box dbus[887]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1
Feb 27 22:33:02 box dbus[887]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Feb 27 22:33:02 box dbus[887]: [system] Activated service 'org.freedesktop.ColorManager' failed: Launch helper exited with unknown return code 1

It seems that /usr/local/lib/colord-plugins is missing:

% /usr/local/libexec/colord --verbose
22:41:24	Verbose debugging enabled (on console 1)
22:41:24	CdMappingDb: trying to open database '/usr/local/var/db/colord/mapping.db'
22:41:24	CdDeviceDb: trying to open database '/usr/local/var/db/colord/storage.db'
22:41:24	CdProfileDb: trying to open database '/usr/local/var/db/colord/storage.db'
22:41:24	failed to open plugin directory: Falló al abrir la carpeta «/usr/local/lib/colord-plugins»: No such file or directory
22:41:24	System vendor: 'Unknown', System model: 'Unknown'
22:41:24	CdMain: lost name: org.freedesktop.ColorManager
Comment 3 Jean-Sébastien Pédron freebsd_committer 2015-03-10 23:24:02 UTC
Hello!

I'm not sure the problem is related to darktable. Any application who wants to query colord (you could try colormgr(1) for instance) will trigger the message.

When I wanted to debug this, I tried to start /usr/local/libexec/colord manually: it did start and the error vanished... The problem seems to come from colord itself but I have no idea how to debug this further
Comment 4 commit-hook freebsd_committer 2015-04-12 10:15:54 UTC
A commit references this bug:

Author: kwm
Date: Sun Apr 12 10:14:54 UTC 2015
New revision: 383852
URL: https://svnweb.freebsd.org/changeset/ports/383852

Log:
  Tell colord to use /var to store information which is already prepared,
  instead of poking around in /usr/local/var/

  PR:		197946
  Submitted by:	f0andrey@gmail.com

Changes:
  head/graphics/colord/Makefile