Bug 198030 - /usr/src/crypto/openssl/util/mkbuildinf.pl: No such file or directory on freebsd-update install
Summary: /usr/src/crypto/openssl/util/mkbuildinf.pl: No such file or directory on free...
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
: 199002 (view as bug list)
Depends on:
Reported: 2015-02-25 12:29 UTC by anthony
Modified: 2019-01-10 22:38 UTC (History)
15 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description anthony 2015-02-25 12:29:21 UTC
Patching from 10.1-RELEASE-p5 to 10.1-RELEASE-p6, I get the output 

# freebsd-update install
Installing updates...install: ///usr/src/crypto/openssl/util/mkbuildinf.pl: No such file or directory

mkbuildinf.pl is the sole item in the `files will be added as part of updating' list.

I've managed to reproduce this on two systems running -p5, and another running -p4. All are amd64 and 10.1-RELEASE.

Steps to reproduce:

freebsd-update fetch -- Behaves as normal.
freebsd-update install -- Shows warning above.

Comment 1 Laszlo Danielisz 2015-02-26 08:56:54 UTC
I've found the same bug, running 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401
Comment 2 Peter 2015-02-26 09:20:54 UTC
Same error for me FreeBSD 10.1-RELEASE-p6 (GENERIC)

I didnt have the error in the morning, then I built another machine for testing later in the day from the same 10.1 amd64 ISO and then had this error now not able to apply patches.
Comment 3 Nenad Stevanovic 2015-02-26 13:57:20 UTC
After fresh installation of FreeBSD 10.1-RELEASE-p6 (amd64), I tried to run 'freebsd-update fetch'. After this I got following (end) message:

"The following files will be added as part of updating to 10.1-RELEASE-p6:

After that I runned command 'freebsd-update install' and got following message:

"Installing updates... install:
No such file or directory

Comment 4 Victor Volpe 2015-02-26 14:27:00 UTC
Same problem here in 2 boxes!

% uname -a
FreeBSD cloud01.***.com.br 10.1-RELEASE-p6 FreeBSD 10.1-RELEASE-p6 #0: Tue Feb 24 19:00:21 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

% uname -a
FreeBSD web01.***.com.br 10.1-RELEASE-p6 FreeBSD 10.1-RELEASE-p6 #0: Tue Feb 24 19:00:21 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 5 Victor Volpe 2015-02-26 14:35:10 UTC
(In reply to Victor Volpe from comment #4)
Oh! I think that I know why... Is that because I removed/not installed /usr/src as I use GENERIC kernel. =)
Comment 6 Michael Kroes 2015-02-26 18:50:56 UTC
(In reply to Victor Volpe from comment #5)

I don't think that it is the usr src. I got it on two near identical VMs (in setup, completely different packages). Both without src. One runs the update just fine. The other fails.
Comment 7 Bob Gibson 2015-02-26 18:57:40 UTC
Merely add directory "util" in /usr/src/crypto/openssl/

freebsd-update install

it will work
Comment 8 Nenad Stevanovic 2015-02-26 19:25:07 UTC
(In reply to Bob Gibson from comment #7)
It works for me too :)
Comment 9 Nenad Stevanovic 2015-02-26 19:26:27 UTC
(In reply to Bob Gibson from comment #7)
Thanks Bob :)
Comment 10 Michael Kroes 2015-02-26 19:26:43 UTC
Comment 11 horus.li 2015-02-27 02:52:59 UTC
If src is not installed, you can simply change the following line in /etc/freebsd-update.conf:

Components src world kernel


Components world kernel

then this would go without problems.
Comment 12 Peter 2015-02-27 09:20:01 UTC
(In reply to horus.li from comment #11)
Thanks this does work, do I need (src) adding back if I install ports
Comment 13 horus.li 2015-02-27 09:36:09 UTC
(In reply to Peter from comment #12)

You won't need src unless you are installing ports like emulators/virtualbox-ose-kmod, so in most cases, it's safe to not adding that back.
Comment 14 Matthias Andree freebsd_committer 2015-04-10 19:00:01 UTC
*** Bug 199002 has been marked as a duplicate of this bug. ***
Comment 15 Jeff Kletsky 2015-04-13 17:06:16 UTC
Confirmed still an issue on:

$ uname -a
FreeBSD <redacted> 10.1-RELEASE-p9 FreeBSD 10.1-RELEASE-p9 #0: Tue Apr  7 01:09:46 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
$ freebsd-version -uk
$ ls -l /usr/src/
total 0

(This machine intentionally does not have the src distribution installed)
Comment 16 Anton Saietskii 2015-06-16 12:14:04 UTC
I have the same problem on most of my 10.1-RELEASE servers (w/o dep on patchlevel).
Comment 17 Gerald Aryeetey 2019-01-10 17:34:09 UTC
This should already be solved in the most recent release as per: base r284425