Bug 198049 - net-im/jabber-pyicq: can't build with WITH_TWISTED, won't run without
Summary: net-im/jabber-pyicq: can't build with WITH_TWISTED, won't run without
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python mailing list
URL:
Keywords: needs-qa
: 198048 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-26 08:26 UTC by michal
Modified: 2015-02-26 13:00 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michal 2015-02-26 08:26:55 UTC
Removing core from TWISTED_USES helps the build (and still installs twisted core, I suspect it's not optional).

I'm not sure whether not running without WITH_TWISTED is a bug, is it for cases when the user has twisted installed in any other way?
Comment 1 michal 2015-02-26 08:28:58 UTC
*** Bug 198048 has been marked as a duplicate of this bug. ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-26 11:16:10 UTC
A couple of things to note:

- This port has no maintainer, which likely means you'll need to provide as much of the investigation effort as possible to make progress.
- Upstream source code has not changed since ~2009
- Twisted was recently updated to version 15.0 in the ports tree

Having said that,

- The port does appear to have a TWISTED option. 

Have you tried to `make config`, disable that option and retry the build?

- Are you running an up to date version of the ports tree? If not, please portsnap fetch update OR svn update, the try to reproduce the issue again.

- When was the last time this port worked for you? Did it stop working recently? If so, when?

Please add a log of the failed build as an attachment to this issue, which may provide additional clues.
Comment 3 commit-hook freebsd_committer 2015-02-26 12:12:24 UTC
A commit references this bug:

Author: sunpoet
Date: Thu Feb 26 12:12:20 UTC 2015
New revision: 379991
URL: https://svnweb.freebsd.org/changeset/ports/379991

Log:
  - Fix USES=twisted: we do not support/need twisted:core

  PR:		198049
  Submitted by:	<michal@hanu.la>

Changes:
  head/net-im/jabber-pyicq/Makefile
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-02-26 12:13:54 UTC
I've removed core from USES=twisted in r379991. Please update your ports tree and try again. Thanks.
Comment 5 michal 2015-02-26 13:00:31 UTC
Thanks a lot (that's what I did to build it before reporting the bug and it did indeed help).