Bug 198270 - [PATCH] Mk/bsd.openssl.mk update for LibreSSL 2.1.4
Summary: [PATCH] Mk/bsd.openssl.mk update for LibreSSL 2.1.4
Status: Closed DUPLICATE of bug 198269
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-03-04 08:28 UTC by Bernard Spil
Modified: 2015-03-06 08:47 UTC (History)
1 user (show)

See Also:


Attachments
svn diff of Mk/bsd.openssl.mk (364 bytes, patch)
2015-03-04 08:28 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log python27 linking to libcrypto.so.32.0.0 (562.26 KB, text/plain)
2015-03-04 08:59 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2015-03-04 08:28:19 UTC
Created attachment 153766 [details]
svn diff of Mk/bsd.openssl.mk

LibreSSL 2.1.4 bumped the shlib versions from .30 to .32. Mk/bsd.openssl.mk sets the OPENSSL_SHLIBVER accordingly so this must change as well.

This needs to be applied together with bug #198269

This was verified with a build/package of www/apache24
===>  Installing for apache24-2.4.12
===>   apache24-2.4.12 depends on file: /usr/local/lib/libcrypto.so.32 - found
Comment 1 Bernard Spil freebsd_committer 2015-03-04 08:59:52 UTC
Created attachment 153769 [details]
Poudriere build log python27 linking to libcrypto.so.32.0.0

=======================<phase: package        >============================
===>  Building package for python27-2.7.9
/usr/local/lib/libffi.so.6.0.4
/usr/local/lib/libcrypto.so.32.0.0
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-03-04 09:26:25 UTC
In the case where an "atomic" commit is important, and though separate issues is "ok" given an aware committer, I would suggest a single svn diff in a single issue for this particular change.

I would be inclined to include this change in bug 198269, rather than the other way around.

Feel free to close this bug "Duplicate of bug 198269" with a comment
Comment 3 Bernard Spil freebsd_committer 2015-03-06 08:47:17 UTC
This has been committed as part of PR198270 as this should have been an atomic patch for both security/libressl and Mk/bsd.openssl.mk

Both have been committed and work.

*** This bug has been marked as a duplicate of bug 198269 ***