Bug 198380 - Can't install using MBR
Summary: Can't install using MBR
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: i386 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-07 03:56 UTC by Blake McBride
Modified: 2015-03-10 00:18 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Blake McBride 2015-03-07 03:56:26 UTC
I am trying to install FreeBSD 10.1 Release on a 10 year old 32 bit machine with 400GB disk and 3+ GB memory.  It ran Linux for years without a problem.

I installed using the GUI install program.  I accepted all of the defaults.  Everything installed fine but then the system wouldn't boot.  I presume that is because I should use MBR instead of GPT.  Here is where all the problems start.

When you change to MBR you have to manually configure the partitions (slices).  Fine.  I create the BSD MBR just fine.  I created:

ada0  MBR

Then I created:

ada0s1  BSD

but when I go into ada0s1, it will only accept freebsd-ufs.  I can't create freebsd-boot or freebsd-swap.  It keeps telling me "invalid argument".

I have spent hours trying to boot a basic machine with no luck.  Sure appreciate some help.

Blake McBride
Comment 1 Jason Unovitch freebsd_committer 2015-03-09 01:21:01 UTC
(In reply to Blake McBride from comment #0)
Hello,
Can you clarify with the gpart(4) commands you used from the start to get to the error you've seen?  For reference, there are examples in the gpart(4) man page [1] as well as some excellent info externally at link [2].

[1] https://www.freebsd.org/cgi/man.cgi?query=pf&sektion=4
[2] http://www.wonkity.com/~wblock/docs/html/disksetup.html

Additionally, in the future keep in mind that the FreeBSD Forums at https://forums.freebsd.org or FreeBSD Questions mailing list at https://lists.freebsd.org/mailman/listinfo/freebsd-questions are usually the best venue for a user question rather than filing a bug report.

Jason
Comment 2 Blake McBride 2015-03-09 01:24:08 UTC
I didn't use gpart explicitly, nor did I enter the console.  I used the install GUI.  That gave the error I described.
Comment 3 Blake McBride 2015-03-09 13:57:11 UTC
Let me put this another way.  I have 30+ years experience with Unix and software development.  One of the things I learned is "have you tried it once"?  I assure you that your GUI installer will not install a fresh MBR system on a 32 bit machine.  Most who have tried, you have lost to Linux.  The others figured out, as I did, how to do it manually with gpart.

The biggest problem you have with FreeBSD is the huge amount of bad or out-of-date documentation, and the fact that really basic stuff doesn't work.  All you need is a tester worth his salt and someone who will listen to him.

FreeBSD could be a really great system, as those who suffered through the learning curve can attest.  The distance between where you are now, and making a system that doesn't turn off all but the most committed isn't far.
Comment 4 Jason Unovitch freebsd_committer 2015-03-10 00:17:21 UTC
(In reply to Blake McBride from comment #3)

Actually, what's with the 'freebsd-boot' partition with MBR?  That's for bootstrap code and for GPT.  What you would probably want it something like this for MBR.

ada0 MBR
adas1 #GB BSD
adas1a freebsd-ufs #GB /
adas1b freebsd-swap #GB none

An FYI, getting to the root cause of the issue with MBR/GPT selection, the SVN log does say more work is needed but r277950 in HEAD [1] may be the future fix for using MBR where appropriate.

[1] https://svnweb.freebsd.org/base?view=revision&revision=277950

Some general thoughts on the issue:
- Using the wrong size or mount point in bsdinstall(8) gives a usable error message output. Using the wrong partition type is pretty darn vague.
- The Handbook does mention partitions and give examples but it's all GPT focused [2].  And there is no big letters saying don't use freebsd-boot for MBR other than it being under sections that say it's a GPT example.  Some details showing MBR would be helpful.

[2] https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/bsdinstall-partitioning.html
Comment 5 Jason Unovitch freebsd_committer 2015-03-10 00:18:26 UTC
(In reply to jason.unovitch from comment #4)
** Correction **

ada0 MBR
ada0s1 #GB BSD
ada0s1a freebsd-ufs #GB /
ada0s1b freebsd-swap #GB none