Bug 198494 - [patch] Add a variable to recognize TEST_DEPENDS
Summary: [patch] Add a variable to recognize TEST_DEPENDS
Status: Closed DUPLICATE of bug 164896
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-perl (Nobody)
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-03-10 15:59 UTC by Adam Weinberger
Modified: 2015-03-10 16:14 UTC (History)
2 users (show)

See Also:


Attachments
WITH_PERL_TESTING (812 bytes, patch)
2015-03-10 15:59 UTC, Adam Weinberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger freebsd_committer 2015-03-10 15:59:17 UTC
Created attachment 154146 [details]
WITH_PERL_TESTING

It'd be nice to start recognizing TEST_DEPENDS and doing something with them.

This simple patch adds support for a WITH_PERL_TESTING variable to perl5.mk that adds TEST_DEPENDS to RUN_DEPENDS. It could, for example, be exported by poudriere when 'testport' is being run.
Comment 1 Bryan Drewery freebsd_committer 2015-03-10 16:14:22 UTC

*** This bug has been marked as a duplicate of bug 164896 ***