Bug 198618 - [patch] net/freerdp update to version 1.2
Summary: [patch] net/freerdp update to version 1.2
Status: Closed DUPLICATE of bug 212004
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords: needs-patch, patch
Depends on:
Blocks:
 
Reported: 2015-03-15 20:20 UTC by rozhuk.im
Modified: 2016-11-24 15:19 UTC (History)
3 users (show)

See Also:


Attachments
Update to FreeRDP 1.2.0-beta1+android9 (19.88 KB, patch)
2015-05-19 16:59 UTC, Ting-Wei Lan
no flags Details | Diff
poudriere testport logs on FreeBSD 10.1 amd64 (93.95 KB, application/x-xz-compressed-tar)
2015-05-19 17:28 UTC, Ting-Wei Lan
no flags Details
poudriere testport plain text log with the default option (734.38 KB, text/plain)
2015-05-19 17:45 UTC, Ting-Wei Lan
no flags Details
Update to FreeRDP 1.2.0-beta1+android9 - USES=execinfo added (20.05 KB, patch)
2015-05-20 04:41 UTC, Ting-Wei Lan
no flags Details | Diff
newer-patch (27.42 KB, patch)
2016-03-15 06:32 UTC, Kurt Jaeger
no flags Details | Diff
patch-v3 (30.45 KB, patch)
2016-03-15 21:30 UTC, Kurt Jaeger
no flags Details | Diff
patch-v4 (30.60 KB, patch)
2016-03-15 21:36 UTC, Kurt Jaeger
no flags Details | Diff
Patch to update net/freerdp to f818bab (devel version of 2.0.0) and add net/vinagre patches (40.31 KB, patch)
2016-06-11 18:49 UTC, Ben Woods
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2015-03-15 20:20:29 UTC
Can be updated.
Im add OSS support, integrate few patches from ports, and fix build errors under FreeBSD.
Comment 1 Ting-Wei Lan 2015-05-17 12:12:46 UTC
I hope we can get an update soon because the next release of vinagre may require newer version of FreeRDP.

https://bugzilla.gnome.org/show_bug.cgi?id=749124
Comment 2 John Marino freebsd_committer 2015-05-19 09:20:45 UTC
This is not appropriate for a PR:
https://www.freebsd.org/doc/en_US.ISO8859-1/articles/problem-reports/pr-when.html

"Please do not submit problem reports that simply state that a newer version of an application is available. Ports maintainers are automatically notified by portscout when a new version of an application becomes available. Actual patches to update a port to the latest version are welcome."

There is also no maintainer for this port, so without a patch, there is nothing to do.  I'm closing the PR.
Comment 3 John Marino freebsd_committer 2015-05-19 09:22:41 UTC
Ting-Wei Lan:  If you want a new version of vinegre, then you'll probably have to do the work to update this port first.
Comment 4 Ting-Wei Lan 2015-05-19 16:59:50 UTC
Created attachment 156953 [details]
Update to FreeRDP 1.2.0-beta1+android9
Comment 5 John Marino freebsd_committer 2015-05-19 17:04:39 UTC
reopening
Comment 6 John Marino freebsd_committer 2015-05-19 17:05:57 UTC
Ting-Wei,
The patch looks decent.  Do you have any poudriere logs showing that it builds cleanly (with stage-qa checks)?
Comment 7 Ting-Wei Lan 2015-05-19 17:28:28 UTC
Created attachment 156954 [details]
poudriere testport logs on FreeBSD 10.1 amd64

I have run 'poudriere testport' 9 times to test options on FreeBSD 10.1 amd64. I also ran xfreerdp on my desktop (FreeBSD 10.1), used it to connect to a Windows VM and shared files and the clipboard with the remote host.

Updating freerdp to the latest version also fixes the build issue in vinagre master branch. vinagre can successfully connect to the same remote host.
Comment 8 John Marino freebsd_committer 2015-05-19 17:32:26 UTC
ah, can you upload a plain text version?  tar.xz is not convenient on this windows machine.

Assuming the log is good, I'll then promote the PR.
Comment 9 Ting-Wei Lan 2015-05-19 17:35:55 UTC
There are 9 logs so I uploaded an .tar.xz file.
Is a .zip file acceptable?
Comment 10 John Marino freebsd_committer 2015-05-19 17:42:50 UTC
oh, just upload one log.
Comment 11 Ting-Wei Lan 2015-05-19 17:45:45 UTC
Created attachment 156957 [details]
poudriere testport plain text log with the default option
Comment 12 John Marino freebsd_committer 2015-05-19 17:50:23 UTC
okay, great!  If somebody wants all the logs they are still available.  I'll move this to "patch ready" so hopefully it gets fast-tracked.
Comment 13 Ting-Wei Lan 2015-05-20 04:41:31 UTC
Created attachment 156971 [details]
Update to FreeRDP 1.2.0-beta1+android9 - USES=execinfo added

USES=execinfo is required on FreeBSD 9 and 8.
Comment 14 Kurt Jaeger freebsd_committer 2015-05-23 14:35:18 UTC
testing@work
Comment 15 commit-hook freebsd_committer 2015-05-23 16:40:24 UTC
A commit references this bug:

Author: pi
Date: Sat May 23 16:39:45 UTC 2015
New revision: 387177
URL: https://svnweb.freebsd.org/changeset/ports/387177

Log:
  net/freerdp: 1.1.0 -> 1.2.0

  - The version is known as 1.2.0-beta1+android9
  - USES=execinfo is required on FreeBSD 9 and 8
  - Fixes build issues

  PR:		198618
  Requested by:	rozhuk.im@gmail.com
  Submitted by:	Ting-Wei Lan <lantw44@gmail.com>

Changes:
  head/net/freerdp/Makefile
  head/net/freerdp/distinfo
  head/net/freerdp/files/patch-channels-tsmf-client-ffmpeg-tsmf_ffmpeg.c
  head/net/freerdp/files/patch-client_common_compatibility.c
  head/net/freerdp/files/patch-git_1b663cef
  head/net/freerdp/files/patch-git_434436b7
  head/net/freerdp/files/patch-libfreerdp-locale-timezone.c
  head/net/freerdp/pkg-plist
Comment 16 Kurt Jaeger freebsd_committer 2015-05-23 16:41:19 UTC
It build on 10.1a, 9.3a, 8.4i, so: Committed, thanks!
Comment 18 Kurt Jaeger freebsd_committer 2015-05-24 07:02:38 UTC
Thanks, I was not aware of those commits against the FreeRDP github repo.

I now tried to build using the latest github commit:

GH_ACCOUNT=     FreeRDP
GH_PROJECT=     ${GH_ACCOUNT}
GH_TAGNAME=     36cb1e6dc9

but this failed.

I then thought: Maybe if I retrieve it from your repo:

GH_ACCOUNT=     ivan-83
GH_PROJECT=     FreeRDP
GH_TAGNAME=     d325a3cc48

but this failed as well. I can provide build logs.

I have no efficient workflow right now that would allow me to include
those changes into the port -- do you have an idea on how to do this ?
Maybe as a diff against the port itself ?
Comment 19 rozhuk.im 2015-05-24 10:07:22 UTC
Show build commands and logs.
Comment 20 Kurt Jaeger freebsd_committer 2015-05-24 10:17:49 UTC
build on 10.1amd64 with

make check-plist

result see http://people.freebsd.org/~pi/logs/freerdp-build-d325a3cc48.txt
Comment 21 rozhuk.im 2015-05-24 10:35:17 UTC
Linking C shared library libxfreerdp-client.so
CMakeFiles/dfreerdp.dir/dfreerdp.c.o: In function `dfreerdp_run':
dfreerdp.c:(.text+0xabe): undefined reference to `freerdp_channels_pop_event'
dfreerdp.c:(.text+0xae8): undefined reference to `freerdp_event_new'
dfreerdp.c:(.text+0xafb): undefined reference to `freerdp_channels_send_event'
dfreerdp.c:(.text+0xb08): undefined reference to `freerdp_event_free'
collect2: error: ld returned 1 exit status

looks like it try link with old lib from /usr/local/lib

Patch: https://github.com/FreeRDP/FreeRDP/pull/2481/files CMakeLists.txt
should fix it.
Comment 22 rozhuk.im 2015-06-26 15:54:01 UTC
Last code merged: https://github.com/FreeRDP/FreeRDP/pull/2719

OSS
    audin fixes
    tsmf added

cmdline
    syntax samples added

improve BSD support
    devd detection and support
    urbdrc

usb
    fixes
Comment 23 commit-hook freebsd_committer 2015-06-27 13:24:10 UTC
A commit references this bug:

Author: pi
Date: Sat Jun 27 13:23:25 UTC 2015
New revision: 390700
URL: https://svnweb.freebsd.org/changeset/ports/390700

Log:
  net/freerdp: update to a newer GIT version which builds without patches

  https://github.com/FreeRDP/FreeRDP/pull/2719
  OSS: audin fixes, tsmf added
  cmdline: syntax samples added
  improve BSD support: devd detection and support, urbdrc
  usb: fixes

  PR:		198618
  Submitted by:	Rozhuk Ivan <rozhuk.im@gmail.com>

Changes:
  head/net/freerdp/Makefile
  head/net/freerdp/distinfo
  head/net/freerdp/files/
  head/net/freerdp/pkg-plist
Comment 24 Kurt Jaeger freebsd_committer 2015-06-27 13:25:48 UTC
Test-built on 10.1a, 9.3a, 8.4i, all fine.

Committed, thanks for your persistence!
Comment 25 commit-hook freebsd_committer 2015-06-27 15:15:23 UTC
A commit references this bug:

Author: pi
Date: Sat Jun 27 15:15:19 UTC 2015
New revision: 390719
URL: https://svnweb.freebsd.org/changeset/ports/390719

Log:
  net/freerdp: fix pkg-plist conditionals

  PR:		198618
  Pointy hat to:	pi

Changes:
  head/net/freerdp/Makefile
  head/net/freerdp/pkg-plist
Comment 26 Ting-Wei Lan 2015-06-28 07:44:51 UTC
This update breaks vinagre build on FreeBSD 10.1:

Package libssl was not found in the pkg-config search path.
Perhaps you should add the directory containing `libssl.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libssl', required by 'winpr', not found
Package 'libssl', required by 'freerdp', not found
Comment 27 Ting-Wei Lan 2015-06-28 11:47:16 UTC
Build log found in freebsd-gnome mailing list

https://lists.freebsd.org/pipermail/freebsd-gnome/2015-June/032505.html
Comment 28 rozhuk.im 2015-07-05 22:02:29 UTC
Dont see OSS sound system and other patches.
https://github.com/FreeRDP/FreeRDP/pull/2719 - last patch with OSS.

freerdp-1.2.0_5
GH_TAGNAME=	f5ff6e1


It would be nice to add options:
CHANNEL_AUDIN:BOOL=ON
CHANNEL_RDPSND:BOOL=ON
CHANNEL_TSMF:BOOL=ON
WITH_OSS:BOOL=ON
WITH_ALSA:BOOL=ON
WITH_PULSE:BOOL=OFF

CHANNEL_DRIVE:BOOL=ON
CHANNEL_PARALLEL:BOOL=ON
CHANNEL_SERIAL:BOOL=ON
CHANNEL_PRINTER:BOOL=OFF
CHANNEL_SMARTCARD:BOOL=ON
CHANNEL_URBDRC:BOOL=OFF

WITH_CUPS:BOOL=OFF
WITH_DIRECTFB:BOOL=OFF
WITH_FFMPEG:BOOL=ON
WITH_MANPAGES:BOOL=ON
WITH_SSE2:BOOL=ON
WITH_XINERAMA:BOOL=ON
WITH_XRANDR:BOOL=ON
WITH_XRENDER:BOOL=ON
WITH_XSHM:BOOL=ON
WITH_XV:BOOL=ON
Comment 29 Kurt Jaeger freebsd_committer 2016-03-15 06:32:40 UTC
Created attachment 168204 [details]
newer-patch

testbuilds of depends are OK:

multimedia/vlc
net/vinagre
net/guacamole-server
net/xrdp-devel
net/krdc
Comment 30 Kurt Jaeger freebsd_committer 2016-03-15 21:30:05 UTC
Created attachment 168263 [details]
patch-v3

New version, fixes pkgconfig stuff
Comment 31 Kurt Jaeger freebsd_committer 2016-03-15 21:36:44 UTC
Created attachment 168269 [details]
patch-v4
Comment 32 Kurt Jaeger freebsd_committer 2016-03-15 21:37:58 UTC
I test-build vinagre with the newer freerdp version and it build and ran and connected to some win7 host.
Comment 33 Kurt Jaeger freebsd_committer 2016-03-16 04:25:41 UTC
The working build was with a buggy pkgconfig. TODO: find a patch that works and has a working pkgconfig.
Comment 34 Kurt Jaeger freebsd_committer 2016-03-16 04:41:09 UTC
(In reply to Kurt Jaeger from comment #33)
See

http://people.freebsd.org/~pi/logs/guacamole-server-0.9.9_1.log
and
vinagre-3.18.2.log
Comment 35 Ben Woods freebsd_committer 2016-06-11 18:49:40 UTC
Created attachment 171314 [details]
Patch to update net/freerdp to f818bab (devel version of 2.0.0) and add net/vinagre patches

This patch updates net/freerdp to a development version of 2.0.0 (f818bab) and ensures the man pages and pkgconfig are installed in the right place.

It also adds two patches to allow net/vinagre to successfully build with this update.

Note that the following ports have non-default options to enable FREERDP, and do not yet build with this change:
net/guacamole-server
net/krdc

The following ports have commented out dependencies or options for FREERDP, but already fail with the current version of freerd. They also fail with this update.
multimedia/vlc
net/xrdp-devel
Comment 36 Kurt Jaeger freebsd_committer 2016-06-11 19:00:50 UTC
Ben, please work on it, I really appreciate if you do it!
Comment 37 Ting-Wei Lan 2016-06-18 09:43:54 UTC
Skipped missing target: 'net/freerdp/files/patch-CMakeLists.txt'
Skipped missing target: 'net/freerdp/files/patch-cmake_FindGStreamer__1__0.cmake'
Skipped missing target: 'net/freerdp/files/patch-libfreerdp_freerdp.pc.in'
Skipped missing target: 'net/freerdp/files/patch-winpr_winpr.pc.in'
Summary of conflicts:
  Skipped paths: 4
Comment 38 Ben Woods freebsd_committer 2016-11-24 15:19:32 UTC

*** This bug has been marked as a duplicate of bug 212004 ***