Bug 198732 - x11-wm/enlightenment audio mixer does not recognize channels
Summary: x11-wm/enlightenment audio mixer does not recognize channels
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-enlightenment (Nobody)
Depends on:
Reported: 2015-03-20 13:21 UTC by mzs_47
Modified: 2021-09-16 12:27 UTC (History)
5 users (show)

See Also:

e19 audio mixer settings (28.08 KB, image/png)
2015-03-20 13:21 UTC, mzs_47
no flags Details
Screenshot of list of channels, after recompiling e19. (106.01 KB, image/png)
2015-04-21 12:47 UTC, mzs_47
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mzs_47 2015-03-20 13:21:26 UTC
Created attachment 154569 [details]
e19 audio mixer settings


I have installed e19 using pkg. The audio module is not showing the sound card/channels.

I can hear audio fine, I can switch channels with sysctl.
I would like to do this with the e19 volume module.
Attached a screen-shot of the mixer settings.


uname -a
FreeBSD freebsd64_10 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

 cat /dev/sndstat 
Installed devices:
pcm0: <Realtek ALC892 (Rear Analog)> (play/rec) default
pcm1: <Realtek ALC892 (Analog)> (play/rec)
pcm2: <Realtek ALC892 (Front Analog Headphones)> (play)
pcm3: <Realtek ALC892 (Rear Digital)> (play)

 sysctl hw.snd.default_unit=2
hw.snd.default_unit: 0 -> 2

pkg info enlightenment       
Name           : enlightenment
Version        : 0.19.4,2
Installed on   : Sun Mar 15 21:54:52 IST 2015
Origin         : x11-wm/enlightenment
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : x11-wm enlightenment
Licenses       : BSD2CLAUSE
Maintainer     : gblach@FreeBSD.org
WWW            : http://www.enlightenment.org/
Comment        : Artistic X window manager
Comment 1 Anonymous 2015-04-16 23:22:18 UTC
Could you please see if adding yourself to the operator group fixes this isse. I don't think it will but I could use this to lower my list of possibilitys of fixing it.
Comment 2 mzs_47 2015-04-18 09:50:25 UTC
Thanks Chris, I am already member of the operator and wheel group.
Let me know if you want me to try anything else.
Comment 3 Anonymous 2015-04-18 18:44:22 UTC
Could you reinstall Enlightenment with the small hack that removes all the suid bit stuff off?

Just comment it all out

45 	        @${REINPLACE_CMD} -e \
46 	                's/\(setuid_root_mode = a=rx,u+x\)s/\1/g' \
47 	                ${WRKSRC}/src/bin/Makefile.mk \
48 	                ${WRKSRC}/src/modules/Makefile_cpufreq.mk

See if that allows you to view the audio channels, as not having them show up seems like a perm issue to me rather E not finding the actual device since you do infact hear sound. Also this is security with obscurity since most people want a working system and not have to spend time suiding cmd's
Comment 4 mzs_47 2015-04-19 13:59:59 UTC
Well how do I do this with pkg, do you want me to install using ports?

If you want me patch this manually, please elaborate, or point to something that I can follow.
Comment 5 Anonymous 2015-04-19 20:45:45 UTC
Edit the Makefile in x11-wm/enlightenment and find those lines and comment them out (add in a # infront of the text) save and recompile.
Comment 6 mzs_47 2015-04-21 12:47:57 UTC
Created attachment 155801 [details]
Screenshot of list of channels, after recompiling e19.

Hi I did what you have suggested, now the mixer does not show any channel. I can still hear sound and change channels using sysctl.

Before compiling I removed enlightenment package using pkg. Did a portsnap fetch update.

Then commented out the following entries.

#       @${REINPLACE_CMD} -e \
#               's/\(setuid_root_mode = a=rx,u+x\)s/\1/g' \
#               ${WRKSRC}/src/bin/Makefile.mk \
#               ${WRKSRC}/src/modules/Makefile_cpufreq.mk

I ran make clean install. It compiled and installed enlightenment.
Let me know what to do next.
Comment 7 Anonymous 2015-04-21 21:23:32 UTC
I guess you're just going to have to wait for me to find a solution.
Comment 8 mzs_47 2015-04-29 15:00:44 UTC
Added a similar bug on xfce4 which I had reported.
Comment 9 Anonymous 2015-08-04 22:57:56 UTC
Hrm, is this still an issue?
Comment 10 mzs_47 2015-08-06 01:50:27 UTC
Yes, it still is. I reinstalled e19 to check this, without any modifications.

I am wondering what effort will it take to package e17 or the Moksha desktop.
Given the bugs in e19, Bodhi project is dropping it in favor of e17.


Can e17/Moksha and e19 co-exist on FreeBSD?
What do you think?
Comment 11 Grzegorz Blach freebsd_committer 2015-09-07 18:50:07 UTC
Chris, have you ever seen working mixer module on FreeBSD?  This module does not support OSS (only ALSA is supported) and never should work on system other than Linux.
Comment 12 Walter Schwarzenfeld freebsd_triage 2018-01-12 11:47:57 UTC
We have version 0.21.10. Is this still relevant?
Comment 13 mzs_47 2018-01-13 11:41:44 UTC
Have not tried with the recent version, I am on XFCE, if you think it makes sense to open a new bug for the new version, then please close this.
Comment 14 Chris Petrik 2018-03-13 23:13:14 UTC
Wonder if this could make work by using the alsa compat libs. Will play with this later.
Comment 15 Tomasz "CeDeROM" CEDRO 2020-04-20 00:40:55 UTC
It works now. Can use ALSA but uses PulseAudio by default in 0.23. Can close issue :-)