Bug 198743 - [UPDATE] chinese/fcitx to 4.2.8.5 as well as its addons
Summary: [UPDATE] chinese/fcitx to 4.2.8.5 as well as its addons
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Xin LI
URL:
Keywords:
: 198700 198701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-20 16:09 UTC by lichray
Modified: 2015-03-31 07:34 UTC (History)
1 user (show)

See Also:


Attachments
patch all in one (116.82 KB, patch)
2015-03-25 21:07 UTC, lichray
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lichray 2015-03-20 16:09:44 UTC
Pull the whole repository here:

  https://github.com/lichray/freebsd-fcitx

And replace corresponding ports with those in this repo.

Some ports are new:

  chinese/brise: separated from chinese/librime
  japanese/fcitx-skk: new IM wrapper using libskk

One or two ports may have no changes.
Comment 1 Bartek Rutkowski freebsd_committer 2015-03-20 18:26:25 UTC

*** This bug has been marked as a duplicate of bug 198700 ***
Comment 2 lichray 2015-03-20 18:37:46 UTC
(In reply to Bartek Rutkowski from comment #1)

198700 is a superseded by this bug.  Read the description again.
Comment 3 Bartek Rutkowski freebsd_committer 2015-03-20 18:40:48 UTC
(In reply to lichray from comment #2)

You're obviously talking about updating the very same software to the very same version, that's the subject of the earlier PR. Since the earlier one already has a patch and a discussion about it, this one is redundant and the relevant discussion should take place there.

*** This bug has been marked as a duplicate of bug 198700 ***
Comment 4 lichray 2015-03-20 19:12:04 UTC
(In reply to Bartek Rutkowski from comment #3)

No, I update all ports prefixed with fcitx-*, and in my comment there is an entire repository for that, while 198700 is only updating one port.
Comment 5 Bartek Rutkowski freebsd_committer 2015-03-22 12:37:05 UTC
(In reply to lichray from comment #4)

If you have updates to some ports, you should have indicated that in the PR subject and a proper description, because current one does indicate its a duplicate.

Secondly, pointing to a github repo is not the pereferred way to proposing changes, please upload separate diffs for respective ports.

In addition to that, you should also upload a poudriere logs from testing each change you're proposing, if you want your PR's to be actioned sooner than later.

And the last thing, please avoid creating one PR for more than one port changes, it should be a PR per port and when there are any dependencies amongst them then relevant fields like depends/blocks should be set up accordingly.

I hope this clears out any confusion and that you now know what to do, to get things done - I am still closing this PR, because it is not created accordingly to the above requirements, hope you understand.

Kind regards,
Bartek Rutkowski
Comment 6 lichray 2015-03-25 21:07:42 UTC
Created attachment 154805 [details]
patch all in one

Ports updated:

  chinese/
  fcitx-configtool   fcitx-sunpinyin    libpinyin
  fcitx              fcitx-googlepinyin fcitx-table-extra  librime
  fcitx-chewing      fcitx-libpinyin    fcitx-ui-light     opencc
  fcitx-cloudpinyin  fcitx-rime         libgooglepinyin

  japanese/fcitx-anthy
  korean/fcitx-hangul
  textproc/fcitx-m17n

Ports added:
  chinese/brise
  japanese/fcitx-skk
Comment 7 lichray 2015-03-25 21:09:30 UTC
I uploaded the patch.

Please do not ask people who maintains 10+ ports to open that many PR -- impossible.
Comment 8 commit-hook freebsd_committer 2015-03-31 07:09:09 UTC
A commit references this bug:

Author: delphij
Date: Tue Mar 31 07:08:20 UTC 2015
New revision: 382798
URL: https://svnweb.freebsd.org/changeset/ports/382798

Log:
  Major update to libpinyin, fcitx and their add ons:

   - New port: chinese/brise Rime schema repository
   - Update chinese/fcitx to 4.2.8.5.
   - Update chinese/fcitx-chewing to 0.2.2.
   - Update chinese/fcitx-cloudpinyin to 0.3.4.
   - Update chinese/fcitx-configtool to 0.4.8.
   - Update chinese/fcitx-libpinyin to 0.3.1.
   - Update chinese/fcitx-rime to 0.3.1.
   - Update chinese/fcitx-sunpinyin to 0.4.1.
   - Update chinese/fcitx-table-extra to 0.3.7.
   - Add LICENSE and update website (mainly move off Google Code)
     for various ports.
   - Update chinese/libpinyin to 1.1.0.
   - Update chinese/librime to 1.1.
   - Update chinese/opencc to 0.4.3.
   - Update japanese/fcitx-anthy to 0.2.1.
   - New port: japanese/fcitx-skk SKK support for Fcitx
   - Update korean/fcitx-hangul to 0.3.0.
   - Update textproc/fcitx-m17n to 0.2.3.

  PR:		ports/198743
  Submitted by:	maintainer, hiroto.kagotani@gmail.com, delphij

Changes:
  head/chinese/Makefile
  head/chinese/brise/
  head/chinese/brise/Makefile
  head/chinese/brise/distinfo
  head/chinese/brise/pkg-descr
  head/chinese/brise/pkg-plist
  head/chinese/fcitx/Makefile
  head/chinese/fcitx/distinfo
  head/chinese/fcitx/files/patch-CMakeLists.txt
  head/chinese/fcitx/files/patch-cmake__FcitxConfig.cmake
  head/chinese/fcitx/files/patch-cmake__FcitxMacro.cmake
  head/chinese/fcitx/files/patch-cmake_modules_FindLibkvm.cmake
  head/chinese/fcitx/files/patch-data__script__fcitx4-config.in
  head/chinese/fcitx/files/patch-doc_man_CMakeLists.txt
  head/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
  head/chinese/fcitx/files/patch-src_lib_fcitx-gclient_CMakeLists.txt
  head/chinese/fcitx/files/patch-src_lib_fcitx-gclient_fcitxclient.c
  head/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
  head/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
  head/chinese/fcitx/files/patch-tools__cli__CMakeLists.txt
  head/chinese/fcitx/files/patch-tools__gui__quickphrase-editor__CMakeLists.txt
  head/chinese/fcitx/files/patch-tools__gui__wrapper__CMakeLists.txt
  head/chinese/fcitx/pkg-descr
  head/chinese/fcitx/pkg-plist
  head/chinese/fcitx-chewing/Makefile
  head/chinese/fcitx-chewing/distinfo
  head/chinese/fcitx-chewing/files/
  head/chinese/fcitx-chewing/files/patch-data__CMakeLists.txt
  head/chinese/fcitx-chewing/pkg-descr
  head/chinese/fcitx-chewing/pkg-plist
  head/chinese/fcitx-cloudpinyin/Makefile
  head/chinese/fcitx-cloudpinyin/distinfo
  head/chinese/fcitx-cloudpinyin/files/patch-CMakeLists.txt
  head/chinese/fcitx-cloudpinyin/pkg-descr
  head/chinese/fcitx-cloudpinyin/pkg-plist
  head/chinese/fcitx-configtool/Makefile
  head/chinese/fcitx-configtool/distinfo
  head/chinese/fcitx-configtool/files/patch-CMakeLists.txt
  head/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
  head/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
  head/chinese/fcitx-configtool/pkg-descr
  head/chinese/fcitx-configtool/pkg-plist
  head/chinese/fcitx-googlepinyin/Makefile
  head/chinese/fcitx-googlepinyin/pkg-descr
  head/chinese/fcitx-libpinyin/Makefile
  head/chinese/fcitx-libpinyin/distinfo
  head/chinese/fcitx-libpinyin/files/patch-CMakeLists.txt
  head/chinese/fcitx-libpinyin/files/patch-dictmanager__CMakeLists.txt
  head/chinese/fcitx-libpinyin/files/patch-src__CMakeLists.txt
  head/chinese/fcitx-libpinyin/pkg-descr
  head/chinese/fcitx-libpinyin/pkg-plist
  head/chinese/fcitx-rime/Makefile
  head/chinese/fcitx-rime/distinfo
  head/chinese/fcitx-rime/files/patch-data_CMakeLists.txt
  head/chinese/fcitx-rime/files/patch-data__CMakeLists.txt
  head/chinese/fcitx-rime/pkg-descr
  head/chinese/fcitx-rime/pkg-plist
  head/chinese/fcitx-sunpinyin/Makefile
  head/chinese/fcitx-sunpinyin/distinfo
  head/chinese/fcitx-sunpinyin/pkg-descr
  head/chinese/fcitx-sunpinyin/pkg-plist
  head/chinese/fcitx-table-extra/Makefile
  head/chinese/fcitx-table-extra/distinfo
  head/chinese/fcitx-table-extra/files/
  head/chinese/fcitx-table-extra/files/patch-tables__CMakeLists.txt
  head/chinese/fcitx-table-extra/pkg-descr
  head/chinese/fcitx-table-extra/pkg-plist
  head/chinese/fcitx-ui-light/Makefile
  head/chinese/fcitx-ui-light/pkg-descr
  head/chinese/libgooglepinyin/Makefile
  head/chinese/libgooglepinyin/pkg-descr
  head/chinese/libpinyin/Makefile
  head/chinese/libpinyin/distinfo
  head/chinese/libpinyin/files/patch-configure
  head/chinese/libpinyin/files/patch-data_Makefile.in
  head/chinese/libpinyin/files/patch-libpinyin.pc.in
  head/chinese/libpinyin/files/patch-src_pinyin_internal.h
  head/chinese/libpinyin/pkg-descr
  head/chinese/libpinyin/pkg-plist
  head/chinese/librime/Makefile
  head/chinese/librime/distinfo
  head/chinese/librime/files/patch-CMakeLists.txt
  head/chinese/librime/pkg-descr
  head/chinese/librime/pkg-plist
  head/chinese/opencc/Makefile
  head/chinese/opencc/distinfo
  head/chinese/opencc/files/patch-src_utils.c
  head/chinese/opencc/pkg-descr
  head/japanese/Makefile
  head/japanese/fcitx-anthy/Makefile
  head/japanese/fcitx-anthy/distinfo
  head/japanese/fcitx-anthy/pkg-descr
  head/japanese/fcitx-anthy/pkg-plist
  head/japanese/fcitx-skk/
  head/japanese/fcitx-skk/Makefile
  head/japanese/fcitx-skk/distinfo
  head/japanese/fcitx-skk/files/
  head/japanese/fcitx-skk/files/patch-gui__CMakeLists.txt
  head/japanese/fcitx-skk/files/patch-src__CMakeLists.txt
  head/japanese/fcitx-skk/pkg-descr
  head/japanese/fcitx-skk/pkg-plist
  head/korean/fcitx-hangul/Makefile
  head/korean/fcitx-hangul/distinfo
  head/korean/fcitx-hangul/files/
  head/korean/fcitx-hangul/files/patch-data__CMakeLists.txt
  head/korean/fcitx-hangul/pkg-descr
  head/korean/fcitx-hangul/pkg-plist
  head/textproc/fcitx-m17n/Makefile
  head/textproc/fcitx-m17n/distinfo
  head/textproc/fcitx-m17n/files/
  head/textproc/fcitx-m17n/files/patch-im__CMakeLists.txt
  head/textproc/fcitx-m17n/pkg-descr
  head/textproc/fcitx-m17n/pkg-plist
Comment 9 Xin LI freebsd_committer 2015-03-31 07:09:27 UTC
*** Bug 198700 has been marked as a duplicate of this bug. ***
Comment 10 Xin LI freebsd_committer 2015-03-31 07:09:56 UTC
Committed, thanks!
Comment 11 Xin LI freebsd_committer 2015-03-31 07:34:08 UTC
*** Bug 198701 has been marked as a duplicate of this bug. ***