Bug 198937 - Xorg blank screen after r277486 on Asus Zenbook
Summary: Xorg blank screen after r277486 on Asus Zenbook
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: FreeBSD bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-26 22:18 UTC by Stefan Parvu
Modified: 2015-04-13 22:26 UTC (History)
0 users

See Also:


Attachments
hw.dri.0 dump (20.05 KB, text/plain)
2015-04-13 22:24 UTC, Stefan Parvu
no flags Details
dmesg information (52.89 KB, text/plain)
2015-04-13 22:25 UTC, Stefan Parvu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Parvu 2015-03-26 22:18:17 UTC
Im currently running 11.0-CURRENT #0 r277486 on Asus Zenbook laptop.

I have discovered Im not able to update to any new snapshots after
r277486. Xorg refuses to work, Im getting a blank screen with no possibility to
have a functional vt restoration. I always need to reboot. The kernel is up
I can use the keyboard so the only trouble seems to come from Xorg / vt.

I have tried updating my laptop to: r278452, r278908, r279514, r279813.
No luck.  If I go back to use r277486 then my Xorg and vt start functioning 
correctly. Im using the i915 driver for Xorg and my config is in [1]. 

Any ideas what is this about ? Were any changes after r277486 regarding 
i915 or Xorg ? I tried to create a new xorg.conf, reuse the old one whatever.
No luck.


Zenbook UX32VD Configuration

CPU: Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
Memory: 6 GB RAM
Storage: SanDisk SSD i100 24GB, Samsung SSD 840 PRO 500GB
Video: Intel HD Graphics 4000, Nvidia GT620M
Display: 13" IPS Full HD anti-glare
Wifi: Intel Centrino Advanced-N 6235
3 x USB 3.0 port(s) 
1 x HDMI 
1 x Mini VGA Port 
1 x SD card reader
Comment 1 Stefan Parvu 2015-04-13 22:24:42 UTC
Created attachment 155573 [details]
hw.dri.0 dump
Comment 2 Stefan Parvu 2015-04-13 22:25:31 UTC
Created attachment 155574 [details]
dmesg information
Comment 3 Stefan Parvu 2015-04-13 22:26:08 UTC
I have tried to adjust the brightness of the LCD by using: hw.acpi.video.lcd0.brightness but did not work.