Bug 199002 - freebsd-upgrade fails to find /usr/src/crypto/openssl/util/mkbuildinf.pl in SRC-LESS installations of FreeBSD
Summary: freebsd-upgrade fails to find /usr/src/crypto/openssl/util/mkbuildinf.pl in S...
Status: Closed DUPLICATE of bug 198030
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-29 14:09 UTC by mikhail.rokhin
Modified: 2015-04-10 19:00 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2015-03-29 14:09:58 UTC
freebsd-upgrade fails to find /usr/src/crypto/openssl/util/mkbuildinf.pl


uname -a 

10.1-RELEASE-p6

For upgrade to STABLE fails too - can't find metadata signature (fails to fetch
Comment 1 Jason Unovitch freebsd_committer 2015-03-30 22:29:16 UTC
(In reply to mikhail.rokhin from comment #0)

What does freebsd-version say?  This is expected when /usr/src has not been installed.  There are no files for freebsd-update(8) to maintain.

If /usr/src is empty, then change /etc/freebsd-update.conf from this:
# Components of the base system which should be kept updated.
Components src world kernel

To this to:
# Components of the base system which should be kept updated.
Components world kernel

That will be the permanent fix to resolve the message you saw.  Additionally, STABLE is not supported by the public freebsd-update servers so that would explain that issue.
Comment 2 mikhail.rokhin 2015-04-09 10:48:31 UTC
(In reply to jason.unovitch from comment #1)

root@router:/home/wella # freebsd-update fetch
Looking up update.FreeBSD.org mirrors... 5 mirrors found.
Fetching metadata signature for 10.1-RELEASE from update5.freebsd.org... done.
Fetching metadata index... done.
Fetching 2 metadata patches.. done.
Applying metadata patches... done.
Inspecting system... done.
Preparing to download files... done.
Fetching 5 patches... done.
Applying patches... done.

The following files will be added as part of updating to 10.1-RELEASE-p9:
/usr/src/crypto/openssl/util/mkbuildinf.pl


The following files will be updated as part of updating to 10.1-RELEASE-p9:
/bin/freebsd-version
/boot/kernel/kernel
/boot/kernel/kernel.symbols
/usr/libexec/bsdinstall/zfsboot
/usr/sbin/ntpd
Comment 3 mikhail.rokhin 2015-04-09 10:50:05 UTC
(In reply to jason.unovitch from comment #1)

The error still exists preventing from update SRC-LESS installations...
Comment 4 mikhail.rokhin 2015-04-09 10:56:42 UTC
Temporary solution for SRC-LESS installs:

# mkdir -p /usr/src/crypto/openssl/util/
# touch /usr/src/crypto/openssl/util/mkbuildinf.pl
Comment 5 mikhail.rokhin 2015-04-09 10:58:53 UTC
(In reply to jason.unovitch from comment #1)

I guess freebsd-update may be more intellectual, whilst inspecting the system, it may find out SRC-LESS installation of FreeBSD...
Comment 6 Jason Unovitch freebsd_committer 2015-04-10 01:27:07 UTC
(In reply to mikhail.rokhin from comment #4)

I can replicate with freebsd-update fetch before changing /etc/freebsd-update.conf.

I cannot replicate with freebsd-update fetch being run after changing /etc/freebsd-update.conf.

Also, regarding the "prevent from update" comment, freebsd-update install should still work.  It just can't handle that file for the reason mentioned before.
Comment 7 Matthias Andree freebsd_committer 2015-04-10 19:00:01 UTC

*** This bug has been marked as a duplicate of bug 198030 ***