Bug 199256 - libusb lacks LIBUSB_API_VERSION
Summary: libusb lacks LIBUSB_API_VERSION
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-07 04:07 UTC by Steve Wills
Modified: 2015-04-07 06:16 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2015-04-07 04:07:01 UTC
Trying to build usb4java (http://usb4java.org/nativelibs.html) in order to use SDRTrunk (https://code.google.com/p/sdrtrunk/), I get an error about not having LIBUSB_API_VERSION:

LibUsb.c:61:12: error: use of undeclared identifier 'LIBUSB_API_VERSION'

(There are others, but I figure this might be a good place to start).

Looking at libusb docs (http://libusb.sourceforge.net/api-1.0/group__misc.html) it says:

Since version 1.0.13, to help with feature detection, libusb defines a LIBUSB_API_VERSION macro...

But our libusb seems to lack it. Could this be added?
Comment 1 Hans Petter Selasky freebsd_committer 2015-04-07 06:16:53 UTC
Yes, please attach a complete patch.

--HPS