Bug 199264 - fix fetch error for biology/paml
Summary: fix fetch error for biology/paml
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Brad Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-07 13:51 UTC by Joseph Mingrone
Modified: 2015-04-10 15:40 UTC (History)
1 user (show)

See Also:


Attachments
svn diff (956 bytes, patch)
2015-04-07 13:51 UTC, Joseph Mingrone
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Mingrone freebsd_committer 2015-04-07 13:51:51 UTC
Created attachment 155304 [details]
svn diff

Add one letter to the makefile to fix the fetch error and remove the BROKEN line.
Comment 1 Mathieu Arnold freebsd_committer 2015-04-10 15:14:14 UTC
This looks wrong, PORTVERSION should be set to 4.8a.
Comment 2 Joseph Mingrone freebsd_committer 2015-04-10 15:18:34 UTC
We had a long discussion about this on #bsdports.  The problem is that upstream basically rolled a new version, but didn't rename the folder inside the tarball.  So, there is paml4.8.tgz, but inside is paml4.8/src.  Either way there has to be a hack, but it was decided to hack $WRKSRC rather than not changing PORTVERSION.
Comment 3 Mathieu Arnold freebsd_committer 2015-04-10 15:23:38 UTC
A new version is a new version, set PORTVERSION=4.8a and set WRKSRC=${WRKDIR}/${PORTNAME}4.8

But don't just change the DISTNAME.  The version has been upgraded, the port must reflect that.
Comment 4 Mathieu Arnold freebsd_committer 2015-04-10 15:25:15 UTC
and it's not a hack, there is a new version upstream called 4.8a, so the port must reflect that, now, if the tarball is all rotten, then WRKSRC is there to take care of that.
Comment 5 Joseph Mingrone freebsd_committer 2015-04-10 15:25:59 UTC
That's exactly what was done.
Comment 6 Joseph Mingrone freebsd_committer 2015-04-10 15:26:14 UTC
It will be rolled shortly.
Comment 7 commit-hook freebsd_committer 2015-04-10 15:39:08 UTC
A commit references this bug:

Author: brd
Date: Fri Apr 10 15:39:02 UTC 2015
New revision: 383736
URL: https://svnweb.freebsd.org/changeset/ports/383736

Log:
  Update biology/paml to 4.8a and unbreak.

  PR:		199264
  Submitted by:	Joseph Mingrone <jrm@ftfl.ca>
  Approved by:	bdrewery (mentor)

Changes:
  head/biology/paml/Makefile
  head/biology/paml/distinfo
Comment 8 Brad Davis freebsd_committer 2015-04-10 15:40:28 UTC
Committed, thanks for your submission!