Bug 199279 - multimedia/smplayer DTS problem/streaming video problem/random frenzied with livestreamer.
Summary: multimedia/smplayer DTS problem/streaming video problem/random frenzied with ...
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rusmir Dusko
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-08 01:11 UTC by sasamotikomi
Modified: 2017-05-20 17:36 UTC (History)
3 users (show)

See Also:
riggs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasamotikomi 2015-04-08 01:11:30 UTC
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 56.33.100 (internal)
[mp2float @ 0x1d6fc98]Header missing
Unknown/missing audio format -> no sound
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Unknown/missing audio format -> no sound
ADecoder init failed :(
Requested audio codec family [mad] (afm=libmad) not available.
Enable it at compilation.
Opening audio decoder: [hwmpa] MPEG audio pass-through (fake decoder)
Cannot sync MPA frame: 0

ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [spdif] libavformat/spdifenc audio pass-through decoder.
AUDIO: 48000 Hz, 2 ch, mpeg2, 768.0 kbit/50.00% (ratio: 96000->192000)
ID_AUDIO_BITRATE=768000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [spdifmpa] afm: spdif (libavformat/spdifenc MPEG AUDIO BC pass-through decoder)
==========================================================================
[format] Sample format big-endian MPEG-2 not yet supported 
Error at audio filter chain pre-init!

Exiting... (Fatal error)
ID_EXIT=ERROR
VLC play same video stream fine.
Comment 1 Thomas Zander freebsd_committer 2015-04-11 07:07:21 UTC
Did this work with the previous version of mplayer?
Could you provide a snippet of such file?
Comment 2 sasamotikomi 2015-04-12 04:03:50 UTC
(In reply to Thomas Zander from comment #1)
I think it work with libdts(renamed to libdca) 10 year ago...
https://lists.freebsd.org/pipermail/freebsd-current/2005-September/056000.html
Since libdts and liba52 is removed mplayer can't to play MPEG-2 part 3/7 and maybe AC3 too.
https://www.freshports.org/multimedia/mplayer/

- remove dependency on liba52 as this is handled by internal libavcodec

Remove libdts support (this is now done by ffmpeg) [1]
- Fix libcdio dependency [2]

It's maybe done by ffmpeg but extra plugin with DTS support isn't ported to FreeBSD so it's a little problem...
No, I can't provide file because I don't record it but you can find a lot of examples MPEG-2 by using one of supported site by livesteamer: http://docs.livestreamer.io/plugin_matrix.html#plugin-matrix
Comment 3 sasamotikomi 2015-04-12 06:19:42 UTC
(In reply to Thomas Zander from comment #1)
(In reply to sasamotikomi from comment #2)
I'm sorry problem reproduced only when I use smplayer as gui, mplayer just start it painful slow https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199386
Comment 4 Thomas Zander freebsd_committer 2015-04-12 11:26:38 UTC
(In reply to sasamotikomi from comment #2)

You know it would be really helpful if you could provide at least one command line that you are using to demonstrate the problem.
I just tried ~20 streams from that list. A few worked with no problems, the others were not accessible.
Comment 5 sasamotikomi 2015-05-13 10:17:30 UTC
(In reply to Thomas Zander from comment #4)
$ livestreamer http://www.ustream.tv/channel/nasa-hd-tv worst -p smplayer
[cli][info] Found matching plugin ustreamtv for URL http://www.ustream.tv/channel/nasa-hd-tv
[plugin.ustreamtv][warning] python-librtmp is not installed, but is needed to access the desktop streams
[cli][info] Available streams: mobile_240p (worst, best)
[cli][info] Opening stream: mobile_240p (hls)
[cli][info] Starting player: smplayer

/usr/local/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo gl:yuv=2:force-pbo:ati-hack -ao oss -nokeepaspect -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 25165860 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -noflip-hebrew -ass-styles /home/{myuser}/.config/smplayer/styles.ass -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp UTF-8 -subpos 100 -volume 42 -cache 2048 -osdlevel 0 -prefer-ipv4 -vf-add eq2,hue -vf-add screenshot -noslices -channels 2 -af volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 -cache 2048 -

MPlayer SVN-r37386-snapshot-3.4.1 (C) 2000-2015 MPlayer Team

Playing -.
Reading from stdin...

Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)
 
Cache fill:  0.00% (0 bytes)   
Cache fill:  1.56% (32768 bytes) 
  
$ livestreamer http://www.ustream.tv/channel/nasa-hd-tv worst -np smplayer
[cli][info] Found matching plugin ustreamtv for URL http://www.ustream.tv/channel/nasa-hd-tv
[plugin.ustreamtv][warning] python-librtmp is not installed, but is needed to access the desktop streams
[cli][info] Available streams: mobile_240p (worst, best)
[cli][info] Opening stream: mobile_240p (hls)
[cli][info] Creating pipe livestreamerpipe-39005
[cli][info] Starting player: smplayer
[cli][info] Player closed
[cli][info] Stream ended


libavformat version 56.28.100 (internal)
TS file format detected.
VIDEO MPEG2(pid=256) AUDIO MPA(pid=257) NO SUBS (yet)!  PROGRAM N. 0
ID_VIDEO_ID=256
ID_AUDIO_ID=257
MPEG: FATAL: EOF while searching for sequence header.
Video: Cannot read properties.
Load subtitles in /tmp/
ID_FILENAME=/tmp/livestreamerpipe-39005
ID_DEMUXER=mpegts
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_START_TIME=66144.36
ID_LENGTH=0.00
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 56.33.100 (internal)
[mp2float @ 0x1cf9850]Header missing
[mp2float @ 0x1cf9850]Header missing
[mp2float @ 0x1cf9850]Header missing
[mp2float @ 0x1cf9850]Header missing
[mp2float @ 0x1cf9850]Header missing
[mp2float @ 0x1cf9850]Header missing
Unknown/missing audio format -> no sound
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[mp2 @ 0x1cf9850]Header missing
[mp2 @ 0x1cf9850]Header missing
Unknown/missing audio format -> no sound
ADecoder init failed :(
Requested audio codec family [mad] (afm=libmad) not available.
Enable it at compilation.
Opening audio decoder: [hwmpa] MPEG audio pass-through (fake decoder)
Cannot sync MPA frame: 0

ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [spdif] libavformat/spdifenc audio pass-through decoder.
AUDIO: 48000 Hz, 2 ch, mpeg2, 768.0 kbit/50.00% (ratio: 96000->192000)
ID_AUDIO_BITRATE=768000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [spdifmpa] afm: spdif (libavformat/spdifenc MPEG AUDIO BC pass-through decoder)
==========================================================================
[format] Sample format big-endian MPEG-2 not yet supported 
Error at audio filter chain pre-init!

Exiting... (Fatal error)
ID_EXIT=ERROR  
Problem fixed since r6885
http://forum.smplayer.info/viewtopic.php?f=4&t=7981

http://sourceforge.net/projects/smplayer/files/SMPlayer/14.9.0/
last one "stable?" smplayer-r6915.tar.bz2
Comment 6 Mark Linimon freebsd_committer freebsd_triage 2015-09-03 07:19:51 UTC
Over to current maintainer.
Comment 7 commit-hook freebsd_committer 2015-09-05 13:32:44 UTC
A commit references this bug:

Author: nemysis
Date: Sat Sep  5 13:32:00 UTC 2015
New revision: 396172
URL: https://svnweb.freebsd.org/changeset/ports/396172

Log:
  Update to unstable 14.9.0.6994, announce message is here:

  http://sourceforge.net/projects/smplayer/files/Unstable/releases/

  - Add Notes_about_mpv.txt to DOCS
  - Change PORTSCOUT

  PR:		199279
  Submitted by:	sasamotikomi@gmail.com

Changes:
  head/multimedia/smplayer/Makefile
  head/multimedia/smplayer/distinfo
  head/multimedia/smplayer/pkg-plist
Comment 8 sasamotikomi 2016-01-13 15:06:31 UTC
Issue still present with smplayer + mpv:

$ livestreamer http://www.ustream.tv/nasahdtv worst -p smplayer

Playing: -
[file] Reading from stdin...
[cache] Cache is not responding - slow/stuck network connection?

And smplayer + mplayer:
Playing -.
Reading from stdin...

Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)   
Cache fill:  0.00% (0 bytes)

Work fine directly with the mplayer/mpv:
$ livestreamer http://www.ustream.tv/nasahdtv worst -p mplayer
$ livestreamer http://www.ustream.tv/nasahdtv worst -p mpv
Comment 9 Thomas Zander freebsd_committer 2016-12-04 16:53:48 UTC
We did have a number of fixes over the previous months. Is the problem still present with packages from an up-to-date ports tree?