Bug 199283 - multimedia/mplayer: Crash mplayer when play IPTV
Summary: multimedia/mplayer: Crash mplayer when play IPTV
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-08 06:14 UTC by Vladimir Omelchuk
Modified: 2015-04-14 19:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (riggs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Omelchuk 2015-04-08 06:14:59 UTC
MPlayer interrupted by signal 11 in module: video_read_properties
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

# uname -srm
FreeBSD 9.3-RELEASE-p12 amd64

# make showconfig
===> The following configuration options are available for mplayer-1.1.r20150403:
     AALIB=off: AAlib graphics library support
     AMR_NB=off: AMR Narrow Band audio support (opencore)
     AMR_WB=off: AMR Wide Band audio support (opencore)
     BLURAY=on: BluRay support
     CACA=off: libcaca graphics library support
     CDIO=off: CDIO support via libcdio
     DEBUG=off: Build with debugging support
     DV=off: Quasar DV video codec support (libdv)
     ENCA=off: Charset conversion via enca
     FONTCONFIG=on: X11 font configuration support
     FRIBIDI=off: Bidirectional text support via GNU FriBidi
     GIF=off: GIF image format support
     GNUTLS=on: SSL/TLS support via GnuTLS
     GSM=off: GSM codec support
     GUI=on: GUI (Graphical User Interface) support
     IPV6=on: IPv6 protocol support
     JACK=off: JACK audio server support
     LADSPA=off: LADSPA audio plugins support
     LIBMNG=off: MNG animated images support via libmng
     LIRC=off: Infrared remote control support
     LZO=off: External liblzo support
     NAS=off: Network Audio System support
     OCFLAGS=on: Use optimized compiler flags
     OPENAL=off: Audio support via OpenAL
     OPENGL=on: 2D/3D rendering support via OpenGL
     OPENJPEG=off: Enhanced JPEG graphics support
     OPUS=off: Opus audio codec support
     PULSEAUDIO=off: PulseAudio sound server support
     REAL=off: Enable realplayer plugin
     RTC=off: Add support for kernel real time clock
     RTCPU=on: Use runtime CPU detection on supported archs
     RTMP=off: RTMP protocol support via librtmp
     SCHROEDINGER=off: Dirac video codec support via libschroedinger
     SDL=off: Simple Direct Media Layer support
     SKINS=on: Install skins for GUI
     SMB=off: SMB network protocol support
     SVGALIB=off: SVGA graphics support
     V4L=off: Video 4 Linux support
     VDPAU=off: VDPAU (GPU video acceleration) support
     VPX=off: VP8/VP9 video codec support
     WIN32=on: Install win32 binary codecs
     X11=on: X11 (graphics) support
     X11DGA=on: X11 DGA video driver support
     X11VM=on: X11 VidMode support
     XINERAMA=on: X11 Xinerama extension support
     XVIDEO=on: X11 Video extension library support
     XVMC=off: X11 XvMC video extension support
===> Use 'make config' to modify these settings


# less /etc/make.conf
#------------------------------------------------------------------------------
#                                /etc/make.conf
#------------------------------------------------------------------------------

BATCH=YES
#FORCE_PKG_REGISTER=YES
CPUTYPE?=core2

OPTIONS_SET=CUPS
WITHOUT_LPR=YES

# ++ use PKGNG [02.09.2014]
WITH_PKGNG=YES

# Not display warning messages
NO_WARNING_PKG_INSTALL_EOL=yes

# 2014-07-13: The default version was changed from www/apache22 to www/apache24,
DEFAULT_VERSIONS+=apache=2.2
Comment 1 Vladimir Omelchuk 2015-04-08 06:22:38 UTC
P.S.
This problem not for version mplayer-1.1.r20140824_6!
Work is fine!
Comment 2 Thomas Zander freebsd_committer 2015-04-11 07:09:01 UTC
(In reply to admin from comment #1)

Did the previous version of mplayer work?
(The last snapshot we used was from December 2014, yours seems to be from August)
Comment 3 Vladimir Omelchuk 2015-04-11 08:00:10 UTC
(In reply to Thomas Zander from comment #2)

No, not work!

$ pkg version -v | grep mplayer
mplayer-1.1.r20141223_2            <   needs updating (index has 1.1.r20150403)
mplayer-skins-1.1.3_2              =   up-to-date with index

$ mplayer 2015-02-20_21.mpg 
MPlayer SVN-r37342-snapshot-3.4.1 (C) 2000-2014 MPlayer Team

Playing 2015-02-20_21.mpg.
libavformat version 56.16.101 (internal)
TS file format detected.
VIDEO MPEG2(pid=6611) AUDIO MPA(pid=6612) NO SUBS (yet)!  PROGRAM N. 6610


MPlayer interrupted by signal 11 in module: video_read_properties
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
Comment 4 Thomas Zander freebsd_committer 2015-04-11 09:08:32 UTC
(In reply to admin from comment #3)

Do you have a snippet of such file that I could use for debugging?
Comment 5 Vladimir Omelchuk 2015-04-11 09:52:31 UTC
(In reply to Thomas Zander from comment #4)

Sadly, but not.
How correct get this file for debugging?
Comment 6 Thomas Zander freebsd_committer 2015-04-11 10:50:48 UTC
(In reply to admin from comment #5)

Well, in comment #3 you are writing

> $ mplayer 2015-02-20_21.mpg 
> MPlayer SVN-r37342-snapshot-3.4.1 (C) 2000-2014 MPlayer Team
>
> Playing 2015-02-20_21.mpg.

This implies that you have an actual file on your local drive that demonstrates this bug. Would it be possible for you to extract a couple of seconds from this file (e.g. with ffmpeg or mencoder) and upload this somewhere? This would allow me to reproduce the issue on my machine and debug the problem.
Comment 7 Vladimir Omelchuk 2015-04-11 11:19:07 UTC
(In reply to Thomas Zander from comment #6)

No, this problem with any files and/or when play IPTV.
File 2015-02-20_21.mpg - is only example.

You can download this file from mine ftp: ftp://ftp.vladiom.net/pub/Tempo/2015-02-20_21.mpg
Comment 8 Thomas Zander freebsd_committer 2015-04-11 14:14:04 UTC
(In reply to admin from comment #7)

Thanks for the sample file, I'll look into it.
The file plays fine here, so give me some time to reproduce the problem.
Comment 9 Vladimir Omelchuk 2015-04-11 14:16:53 UTC
(In reply to Thomas Zander from comment #8)

No problem!
Thanks! :)
Comment 10 commit-hook freebsd_committer 2015-04-12 14:38:22 UTC
A commit references this bug:

Author: riggs
Date: Sun Apr 12 14:37:53 UTC 2015
New revision: 383871
URL: https://svnweb.freebsd.org/changeset/ports/383871

Log:
  Fix runtime crash with certain MPEG2 files on pre-10 systems.

  PR:		199283
  MFH:		2015Q2

Changes:
  head/multimedia/mencoder/Makefile
  head/multimedia/mplayer/Makefile
  head/multimedia/mplayer/Makefile.options
  head/multimedia/mplayer/files/extra-patch-aligned_alloc
  head/multimedia/mplayer/files/patch-configure
Comment 11 commit-hook freebsd_committer 2015-04-14 19:29:06 UTC
A commit references this bug:

Author: riggs
Date: Tue Apr 14 19:28:15 UTC 2015
New revision: 384023
URL: https://svnweb.freebsd.org/changeset/ports/384023

Log:
  MFH: r383871

  Fix runtime crash with certain MPEG2 files on pre-10 systems.

  PR:		199283
  Approved by:	ports-secteam (delphij)

Changes:
_U  branches/2015Q2/
  branches/2015Q2/multimedia/mencoder/Makefile
  branches/2015Q2/multimedia/mplayer/Makefile
  branches/2015Q2/multimedia/mplayer/Makefile.options
  branches/2015Q2/multimedia/mplayer/files/extra-patch-aligned_alloc
  branches/2015Q2/multimedia/mplayer/files/patch-configure