Bug 199335 - [RESSURECT] devel/py-gitpython: Python Git Library
Summary: [RESSURECT] devel/py-gitpython: Python Git Library
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL: https://reviews.freebsd.org/D2659
Keywords: feature, patch, patch-ready
: 195896 200369 (view as bug list)
Depends on: 199334
Blocks: 199336
  Show dependency treegraph
 
Reported: 2015-04-09 21:19 UTC by Maxim Filimonov
Modified: 2015-07-05 01:24 UTC (History)
6 users (show)

See Also:
che: maintainer-feedback+


Attachments
svn diff (2.60 KB, patch)
2015-04-09 21:20 UTC, Maxim Filimonov
no flags Details | Diff
shar (1.59 KB, application/x-shar)
2015-04-09 21:21 UTC, Maxim Filimonov
no flags Details
poudriere log (47.84 KB, text/x-log)
2015-04-09 21:34 UTC, Maxim Filimonov
no flags Details
svn diff (2.71 KB, patch)
2015-04-23 08:33 UTC, Maxim Filimonov
no flags Details | Diff
shar (1.55 KB, text/plain; charset=utf-8)
2015-04-23 08:37 UTC, Maxim Filimonov
no flags Details
poudriere log (48.10 KB, text/plain; charset=utf-8)
2015-04-23 08:39 UTC, Maxim Filimonov
no flags Details
shar (1.78 KB, application/x-shar)
2015-05-25 19:02 UTC, Maxim Filimonov
no flags Details
svn diff (1.59 KB, patch)
2015-05-25 19:02 UTC, Maxim Filimonov
no flags Details | Diff
svn diff (2.42 KB, patch)
2015-06-05 19:40 UTC, Maxim Filimonov
che: maintainer-approval+
Details | Diff
shar (1.81 KB, text/plain)
2015-06-05 19:40 UTC, Maxim Filimonov
no flags Details
poudriere log (48.15 KB, text/x-log)
2015-06-05 19:45 UTC, Maxim Filimonov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Filimonov 2015-04-09 21:19:12 UTC
The mentioned port is missing in the ports tree. `portlint -AC` says everything is ok.
Comment 1 Maxim Filimonov 2015-04-09 21:20:57 UTC
Created attachment 155391 [details]
svn diff

Added svn diff
Comment 2 Maxim Filimonov 2015-04-09 21:21:42 UTC
Created attachment 155392 [details]
shar
Comment 3 Maxim Filimonov 2015-04-09 21:34:05 UTC
Created attachment 155393 [details]
poudriere log
Comment 4 Bartek Rutkowski freebsd_committer 2015-04-21 13:17:46 UTC
Your port seems to be an outdated version, pypi says the gitpython latest version is 1.0.0. Also, you seem to have wrong license (MIT instead of BSD) declared and you dont have LICENSE_FILE declared.
Comment 5 Maxim Filimonov 2015-04-23 08:33:40 UTC
Created attachment 155897 [details]
svn diff

Fixed: newer version, LICENSE, LICENSE_FILE
Comment 6 Maxim Filimonov 2015-04-23 08:37:56 UTC
Created attachment 155898 [details]
shar

Fixed: PORTVERSION, LICENSE, LICENSE_FILE
Comment 7 Maxim Filimonov 2015-04-23 08:39:58 UTC
Created attachment 155899 [details]
poudriere log

Fixed: PORTVERSION, LICENSE, LICENSE_FILE
Comment 8 Maxim Filimonov 2015-05-25 19:02:08 UTC
Created attachment 157133 [details]
shar

Added regression tests
Comment 9 Maxim Filimonov 2015-05-25 19:02:36 UTC
Created attachment 157134 [details]
svn diff

Added regression tests
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2015-05-26 00:19:38 UTC
Hi Maxim, thanks for your submission :)

Since devel/py-gitpython existed in the past (now expired/deleted), can you please:

* svn copy (using -r) the last revision of the now extinct port into your tree
* Obsolete the existing attachments in this issue, AND
* Create a new attachment produced via svn diff or diff -u

Please also run poudriere and portlint again prior to updating the attachments here.
Comment 11 Maxim Filimonov 2015-06-05 19:40:11 UTC
Created attachment 157441 [details]
svn diff

Updated: TEST_DEPENDS, regression-tests target
Comment 12 Maxim Filimonov 2015-06-05 19:40:45 UTC
Created attachment 157442 [details]
shar

Updated: TEST_DEPENDS, regression-tests target
Comment 13 Maxim Filimonov 2015-06-05 19:42:12 UTC
~/git/freebsd-ports/devel/py-gitpython]% portlint -AC
looks fine.
Comment 14 Maxim Filimonov 2015-06-05 19:45:10 UTC
Created attachment 157443 [details]
poudriere log

Updated: TEST_DEPENDS, regression-tests target
Comment 15 Kubilay Kocak freebsd_committer freebsd_triage 2015-06-06 08:36:41 UTC
Maxim took this through the review process, document as such.
Comment 16 Maxim Filimonov 2015-06-06 14:47:14 UTC
Comment on attachment 157441 [details]
svn diff

Maintainer approval for the patch
Comment 17 Maxim Filimonov 2015-06-06 14:47:45 UTC
Maintainer feedback +
Comment 18 commit-hook freebsd_committer 2015-06-22 17:20:44 UTC
A commit references this bug:

Author: riggs
Date: Mon Jun 22 17:20:02 UTC 2015
New revision: 390304
URL: https://svnweb.freebsd.org/changeset/ports/390304

Log:
  Resurrect devel/py-gitpython
  - Update to upstream version 1.0.1
  - Maxim Filimonov <che@bein.link> takes maintainership
  - Update WWW: Project is now hosted on github

  PR:		199335
  Differential Revision:	https://reviews.freebsd.org/D2659
  Submitted by:	che@bein.link (maintainer)
  Reviewed by:	koobs

Changes:
  head/MOVED
  head/devel/Makefile
  head/devel/py-gitpython/
  head/devel/py-gitpython/Makefile
  head/devel/py-gitpython/distinfo
  head/devel/py-gitpython/pkg-descr
Comment 19 Kubilay Kocak freebsd_committer freebsd_triage 2015-06-25 02:30:24 UTC
*** Bug 195896 has been marked as a duplicate of this bug. ***
Comment 20 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-05 01:24:41 UTC
*** Bug 200369 has been marked as a duplicate of this bug. ***