Bug 199361 - lang/perl5.18: add c++11 compatibility patches
Summary: lang/perl5.18: add c++11 compatibility patches
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-11 01:33 UTC by Dmitry Marakasov
Modified: 2015-04-11 11:03 UTC (History)
0 users

See Also:


Attachments
Patch (4.09 KB, patch)
2015-04-11 01:33 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2015-04-11 01:33:40 UTC
Created attachment 155441 [details]
Patch

Make perl headers c++11 compatible, which allows building perl consumers which use c++11, namely games/golly.

This is similar to upstream commit https://github.com/Perl/perl5/commit/61608bb78702625b199caa5a6e160f5c0a034184
Comment 1 commit-hook freebsd_committer 2015-04-11 10:32:35 UTC
A commit references this bug:

Author: mat
Date: Sat Apr 11 10:31:46 UTC 2015
New revision: 383784
URL: https://svnweb.freebsd.org/changeset/ports/383784

Log:
  Patch Perl's header for c++11 compatibility.
  While there, drop MASTER_SITE_SUBDIRS.

  PR:		199361
  Submitted by:	amdmi3
  Sponsored by:	Absolight

Changes:
  head/lang/perl5.16/Makefile
  head/lang/perl5.16/files/patch-pad.h
  head/lang/perl5.18/Makefile
  head/lang/perl5.18/files/patch-pad.h
  head/lang/perl5.18/files/patch-perl.h
  head/lang/perl5.20/Makefile
  head/lang/perl5.20/files/patch-vutil.h