Bug 199397 - misc/gimp-help-en needs USES=python:2, not USES=python
Summary: misc/gimp-help-en needs USES=python:2, not USES=python
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Carlo Strub
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-12 15:16 UTC by Florian Limberger
Modified: 2015-09-14 22:37 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (liangtai.s16)


Attachments
Patch to fix the issue (514 bytes, patch)
2015-04-12 15:16 UTC, Florian Limberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Limberger 2015-04-12 15:16:10 UTC
Created attachment 155518 [details]
Patch to fix the issue

portmaster tries reinstalling py27-pylibxml2 when installing misc/gimp-help-en if DEFAULT_VERSIONS=python=3.4. Using python:2 in USES fixes that.
Comment 1 Carlo Strub freebsd_committer 2015-09-14 22:37:12 UTC
Committed. Thank you very much.
Comment 2 commit-hook freebsd_committer 2015-09-14 22:37:18 UTC
A commit references this bug:

Author: cs
Date: Mon Sep 14 22:36:16 UTC 2015
New revision: 396940
URL: https://svnweb.freebsd.org/changeset/ports/396940

Log:
  needs USES=python:2

  PR:		199397
  Submitted by:	Florian Limberger <flo@snakeoilproductions.net>
  Approved by:	maintainer timeout (> 4 months)

Changes:
  head/misc/gimp-help-en/Makefile