Bug 199501 - graphics/kipi-plugins-kde4 does not read a preexisting options file
Summary: graphics/kipi-plugins-kde4 does not read a preexisting options file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-17 18:03 UTC by Martin Birgmeier
Modified: 2015-12-03 17:40 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2015-04-17 18:03:51 UTC
When configuring options for graphics/kipi-plugins-kde4, saved options are not taken into account. All options except for DOCS and NLS are unset.
Comment 1 Raphael Kubo da Costa freebsd_committer 2015-04-19 11:28:40 UTC
Ouch! This was caused by the conversion to USES=metaport :-(
Comment 2 commit-hook freebsd_committer 2015-04-19 20:56:08 UTC
A commit references this bug:

Author: rakuco
Date: Sun Apr 19 20:55:31 UTC 2015
New revision: 384328
URL: https://svnweb.freebsd.org/changeset/ports/384328

Log:
  Revert USES=metaport conversion, again.

  bsd.port.pre.mk and Makefile.common were being included before the many
  options were being defined. Some of the options depend on Makefile.common to
  be defined though, so for now revert the USES=metaport conversion to get
  things back to a working state while a proper fix is devised.

  PR:		199501

Changes:
  head/graphics/kipi-plugins-kde4/Makefile