Bug 199538 - clang crash building my sources
Summary: clang crash building my sources
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Dimitry Andric
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-19 09:56 UTC by Gleb Smirnoff
Modified: 2021-01-16 20:45 UTC (History)
1 user (show)

See Also:


Attachments
preprocessed source (710.48 KB, text/plain)
2015-04-19 09:56 UTC, Gleb Smirnoff
no flags Details
run script (1.73 KB, text/plain)
2015-04-19 09:57 UTC, Gleb Smirnoff
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Smirnoff freebsd_committer 2015-04-19 09:56:21 UTC
Created attachment 155723 [details]
preprocessed source

UNREACHABLE executed at /usr/src/head/lib/clang/libclangsema/../../../contrib/llvm/tools/clang/lib/Sema/Sema.cpp:323!
Stack dump:
0.      Program arguments: /usr/bin/cc -cc1 -triple x86_64-unknown-freebsd11.0 -emit-obj -mrelax-all -disable-free -main-file-name if_media.c -mrelocation-model static -mthread-model posix -mdisable-fp-elim -relaxed-aliasing -masm-verbose -mconstructor-aliases -mcode-model kernel -target-cpu x86-64 -target-feature -mmx -target-feature -sse -target-feature -aes -target-feature -avx -disable-red-zone -no-implicit-float -gdwarf-2 -dwarf-column-info -coverage-file /usr/obj/usr/src/ifnet/sys/VM-DEBUG/if_media.c -nostdsysteminc -nobuiltininc -resource-dir /usr/bin/../lib/clang/3.6.0 -include opt_global.h -D __printf__=__freebsd_kprintf__ -D _KERNEL -D HAVE_KERNEL_OPTION_HEADERS -D __printf__=__freebsd_kprintf__ -I . -I /usr/src/ifnet/sys -I /usr/src/ifnet/sys/contrib/libfdt -O0 -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -Wmissing-include-dirs -Wno-unknown-pragmas -Wno-error-tautological-compare -Wno-error-empty-body -Wno-error-parentheses-equality -Wno-error-unused-function -Wno-error-pointer-sign -Wno-error-tautological-compare -Wno-error-empty-body -Wno-error-parentheses-equality -Wno-error-unused-function -Wno-error-pointer-sign -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -Wmissing-include-dirs -Wno-unknown-pragmas -Wno-error-tautological-compare -Wno-error-empty-body -Wno-error-parentheses-equality -Wno-error-unused-function -Wno-error-pointer-sign -Werror -std=iso9899:1999 -fdebug-compilation-dir /usr/obj/usr/src/ifnet/sys/VM-DEBUG -ferror-limit 19 -fmessage-length 147 -ffreestanding -fwrapv -stack-protector 1 -mstackrealign -fobjc-runtime=gnustep -fdiagnostics-show-option -fcolor-diagnostics -o if_media.o -x c /usr/src/ifnet/sys/net/if_media.c 
1.      /usr/src/ifnet/sys/net/if_media.c:188:3 <Spelling=/usr/src/ifnet/sys/sys/queue.h:411:33>: current parser token ';'
2.      /usr/src/ifnet/sys/net/if_media.c:99:1: parsing function body 'ifmedia_ioctl'
3.      /usr/src/ifnet/sys/net/if_media.c:99:1: in compound statement ('{}')
4.      /usr/src/ifnet/sys/net/if_media.c:104:15: in compound statement ('{}')
5.      /usr/src/ifnet/sys/net/if_media.c:163:2: in compound statement ('{}')
cc: error: unable to execute command: Abort trap (core dumped)
cc: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 3.6.0 (tags/RELEASE_360/final 230434) 20150225
Target: x86_64-unknown-freebsd11.0
Thread model: posix
cc: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
cc: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
cc: note: diagnostic msg: /tmp/if_media-1d1dff.c
cc: note: diagnostic msg: /tmp/if_media-1d1dff.sh
cc: note: diagnostic msg:
Comment 1 Gleb Smirnoff freebsd_committer 2015-04-19 09:57:10 UTC
Created attachment 155724 [details]
run script
Comment 2 Dimitry Andric freebsd_committer 2015-04-19 13:57:02 UTC
Still reproduces with upstream trunk (after some reduction and experimentation).  Reported here:

https://llvm.org/bugs/show_bug.cgi?id=23286
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:49:27 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.