Bug 199563 - databases/postgis21: is missing control files
Summary: databases/postgis21: is missing control files
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Harrison Grundy
URL:
Keywords:
: 200707 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-20 18:09 UTC by Luca Corti
Modified: 2019-03-16 12:51 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Corti 2015-04-20 18:09:33 UTC
Hello,

postgis is missing the control files apparently:

=> create extension postgis;
ERROR:  could not open extension control file "/usr/local/share/postgresql/extension/postgis.control": No such file or directory

This makes it kind of hard to use.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2015-04-23 03:20:30 UTC
To which of the postgis ports does this PR apply?
Comment 2 Luca Corti 2015-04-23 10:19:04 UTC
databases/postgis21, the issue is the default is building without raster support, but raster support is needed to generate the extension control files and SQL.
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2015-04-24 04:13:20 UTC
Fix Summary and notify maintainer.
Comment 4 Harrison Grundy 2015-05-01 06:02:44 UTC
I'm discussing this with upstream now. For the moment, the quickest workaround is to enable RASTER support.
Comment 5 Jonathan Chen 2015-06-08 06:53:31 UTC
*** Bug 200707 has been marked as a duplicate of this bug. ***
Comment 6 Chris Platts 2015-10-09 23:55:22 UTC
This one's biting me too.  Would be great to have the binary dist. working out of the box.
Comment 7 Harrison Grundy 2015-10-16 11:00:12 UTC
Per upstream's installation instructions at http://postgis.net/docs/postgis_installation.html#create_new_db_extensions, if PostGIS is built without RASTER enabled, you must enable spatial extensions using the following procedure:

createdb yourdatabase
createlang plpgsql yourdatabase
psql -d yourdatabase -f postgis.sql
psql -d yourdatabase -f postgis_comments.sql
psql -d yourdatabase -f spatial_ref_sys.sql
psql -d yourdatabase -f rtpostgis.sql
psql -d yourdatabase -f raster_comments.sql
psql -d yourdatabase -f topology.sql
psql -d yourdatabase -f topology_comments.sql
--if you built with sfcgal support --
psql -d yourdatabase -f sfcgal.sql
psql -d yourdatabase -f sfcgal_comments.sql

--- Harrison
Comment 8 w.schwarzenfeld freebsd_triage 2018-01-13 20:03:51 UTC
Is this still relevant?
Comment 9 lbartoletti 2019-03-16 12:39:51 UTC
Postgis21 is DEPRECATED, could be closed.
In fact, you have to install RASTER option to have control file on FreeBSD postgis23, 24 and 25 is correctly updated.
Comment 10 w.schwarzenfeld freebsd_triage 2019-03-16 12:51:07 UTC
See Comment9, close with Overcome.